locked
How to remove disks from Primordial Pool of an S2D deployment? RRS feed

  • Question

  • Executed this to disable auto addition of disks to the Storage Pool.

        Get-StorageSubSystem Cluster* | Set-StorageHealthSetting -Name "System.Storage.PhysicalDisk.AutoPool.Enabled" -Value False

    Then the sequence of steps is in order

    1. Created a Two Node Cluster with two disks on each node.
    2. Enabled S2D and application deployed…
    3. Added third Node to the cluster (again with two disks) but the intention is not to put the disks into S2D and keep them locally available. But somehow the disks from the new node fall under the Primordial Pool;

    Please let me know for how to get them out & assign to the box as local?


    yup

    Friday, August 31, 2018 11:41 AM

All replies

  • Hi yup,

    By default there is a storage pool named Primordial which contain all available hard disks. If it does not exist, which means there is no available hard disks to create storage pool. In server 2016 cluster, there's the new function----s2d. In your scenario, you even have used the S2D, so when add another node, if there's the available disk for S2D, it will list in Primordial pool.

    For now, I haven't find the method to directly remove from Primordial pool. There's a workaround that you could set not claimed by pool. So that it wouldn't list in Primordial pool. But you need to disable S2D so that disk can be freed from pool and set disk to not be claimed by pool. After that, please re-enable S2D.

    https://docs.microsoft.com/en-us/powershell/module/failoverclusters/set-clusterstoragespacesdirectdisk?view=win10-ps

    In your current scenario, you have enabled S2D and application deployed. I'm afraid that workaround may not suitable for you.

    And in fact, if the disk only list in Primordial pool, you haven't add it to any other specific pool. In theory, you could still used in locally on your 3rd node. You could also do a check.

    Best Regards,

    Mary


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Mary Dong Tuesday, September 4, 2018 8:08 AM
    Monday, September 3, 2018 2:15 AM
  • Likewise, the only option I’ve seen to avoid a disk going automatically into Storage Spaces is to have Partition & a Volume on it. Another is to only to disable auto addition of disks to the Storage Pool (they still get added to the Primordial Pool).

    Get-StorageSubSystem Cluster* | Set-StorageHealthSetting -Name "System.Storage.PhysicalDisk.AutoPool.Enabled" -Value False

    Now on trying this

    Set-ClusterStorageSpacesDirectDisk -CanBeClaimed:$False -PhysicalDiskGuid "abc", "xyz"

    Both before enabling S2D and after it. There’s no change and the disks are in the Cluster’s S2D pool. Its very much of a product limitation in segregating disks.


    yup

    Monday, September 3, 2018 5:58 AM
  • Hi yup,

    Thanks for your feedback.

    Maybe you could also consider to put forward your results in uservoice for windows server so that maybe more Microsoft engineer could see this.

    https://windowsserver.uservoice.com/forums/295047-general-feedback

    Best Regards,

    Mary


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, September 3, 2018 7:20 AM