locked
WSUS and WIN10 Auto Reboot Behavior RRS feed

  • Question

  • I have several Windows 10  computer's connected to WSUS Version: 6.3.9600.18228.


    I have setup two different test environments with the following registry settings - 

    1)
    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU]
    "AUOptions"=dword:00000004
    "DetectionFrequency"=dword:00000004
    "DetectionFrequencyEnabled"=dword:00000001
    "NoAutoRebootWithLoggedOnUsers"=dword:00000001
    "NoAutoUpdate"=dword:00000000
    "RebootRelaunchTimeout"=dword:000000f0
    "RebootRelaunchTimeoutEnabled"=dword:00000001
    "RescheduleWaitTime"=dword:00000014
    "RescheduleWaitTimeEnabled"=dword:00000001
    "ScheduledInstallDay"=dword:00000000
    "ScheduledInstallTime"=dword:0000000b
    "UseWuserver"=dword:00000001
    "AutoInstallMinorUpdates"=dword:00000001

    1) These registry settings are set to have updates automatically install.
    I have noticed that some of the cumulative update's from Windows will alert you that you have a few minutes before the computer reboots. Your options are "Restart / Close"


    So I went ahead and changed automatic reboot to notify to install - 
    "AUOptions"=dword:00000003

    Now when I have this set in the registry, once again..it appears to want to force a reboot and gives you a time - only a few minutes before a reboot.

    I tested with KB3147458


    I am curious as to what other's are doing in enterprise envrionments to stop this automatic reboot behavior?


    Wednesday, April 13, 2016 4:01 PM

Answers

  • Hi vs2012sv,

    I followed your original post's registry key to test, I can get the restart schedule notification.

    Since it seems more like the behavior of window10 and there seems no issue with your GPO, I would recommended you turning to win10 forum to consult why the computer do not show restart schedule notification.

    Win10 forum:

    https://social.technet.microsoft.com/Forums/en-US/home?forum=win10itprogeneral

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, April 22, 2016 8:14 AM

All replies

  • Hi vs2015sv,

    According to your information, I tested it in my lab (configure the same registry key with you), and after installing the KB, I actually got a restart schedule notification.

    This is downloading and installing updates:

    This is after installing these updates:

    Do you get the schedule after installing the KB?

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, April 14, 2016 7:53 AM
  • No option to schedule the reboot after the install.

    I get the following message - see below.

    We are pointed to a WSUS server.

    Windows 10.0.10586 Build 10586

    So I went ahead and changed the registry setting again to notify to install - AUOptions"=dword:00000003

    Rebooted, then checked for updates and get the same blue box that calls for a reboot.

    Thursday, April 14, 2016 3:12 PM
  • Hi vs2015sv,

    Try changing windows update advanced options > "Choose how updates are installed"> "Notify to schedule restart".

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, April 15, 2016 3:16 AM
  • The computer is connected to a WSUS server and you can not change how updates are delivered unless I delete the registry keys.

    Do you know exactly what registry setting that would be?

    I deleted all of the registry settings keys that I have above and created one just for "NoAutoRebootWithLoggedOnUsers"=dword:00000001. This did not change the setting to notify to schedule restart.

    I have also changed AUOptions"=dword:00000004 from 4 to 3,2,1 - nether of these give you the notify to schedule restart either.


    • Edited by vs2015sv Friday, April 15, 2016 3:49 PM
    Friday, April 15, 2016 11:51 AM
  • Hi vs2012sv,

    I followed your original post's registry key to test, I can get the restart schedule notification.

    Since it seems more like the behavior of window10 and there seems no issue with your GPO, I would recommended you turning to win10 forum to consult why the computer do not show restart schedule notification.

    Win10 forum:

    https://social.technet.microsoft.com/Forums/en-US/home?forum=win10itprogeneral

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, April 22, 2016 8:14 AM