locked
MIM installation error on sharepoint 2016 RRS feed

  • Question

  • Hi guys.

    Trying to instal MIM.

    Downloaded from MSDNAA: (Microsoft Identity Manager 2016 with Service Pack 1 (x64) - DVD (English) (Release Date: 9/20/2016)).

    Created service account in our domain and delegated "Replicating directory changes in AD".
    Opened Local Security Policy / Local Policies / User Rights Assignment
    Add this user to policy:
    Deny log on locally
    Deny log on as a batch job
    Deny access to this computer from the network

    Ran: F:\Synchronization Service\setup.exe

    At the phase of installing WIM in the wizzard it goes rolling back and installation is not finished.
    what are we doing wrong?
    We are following this guide: http://social.technet.microsoft.com/wiki/contents/articles/33698.sharepoint-2016-user-profile-service-step-by-step-installation-of-mim-2016/edit.aspx


    bostjanc

    Thursday, October 6, 2016 8:48 AM

Answers

  • This looks similar to a problem I had. I opened a case with Microsoft and they narrowed it down to being a DCOM permission issue on the server that I was installing MIM on (even though the install account was a domain admin as well). I installed MIM 2016 on the SharePoint server as well as we aren't a big environment.  Based on a quick glance at your log you may be in the same boat as I was.  I don't recall exactly what I did to fix it but it a nutshell it was:

    On the server that MIM is being installed on,

    • Run dcomcnfg.exe
    • Drill into Component Services
    • Right click on 'My Computer' under Component Services - Computer and click 'Properties'
    • Click on COM Security tab
    • This is where it gets a little fuzzy for me, you have 4 options here, Edit Limits/Edit Default for Access Permissions and Launch and Activation Permissions
    • I had to grant the Administrator account full Allow access to either the 'Edit Default' or 'Edit Limits'.   Whether you need to give the 'Allow' in all 4 of these areas I don't know, the Microsoft tech seemed pretty comfortable doing it though. Once I gave the administrator account Allow permission to all those things, then the install worked fine. 

    I was pretty skeptical that that would fix it for me but I was pleasantly surprised.  Hope this help.

    -Chris

    • Marked as answer by B_C_R Friday, October 14, 2016 12:19 PM
    Friday, October 14, 2016 11:52 AM

All replies

  • Hi Bostjan,

    The account running setup for MIM must be a SQL Server Admin on the instance of SQL Server where the MIM sync database will be hosted. The account must have local administrator permissions on the machine where the MIM Synchronization service will be installed.

    Please verify that the account installing MIM have the appropriate permission.

    And please also follow the steps in the link below for getting the logs when the installation fails:
    http://ithinkthereforeidam.com/fim-setup-wizard-ended-prematurely/

    Best Regards,

    Victoria 


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, October 7, 2016 2:17 AM
  • The best way to deal with MSI errors like this is to check the MSI log which resides in the %TMP% directory of the user who ran the installer. While what you're otherwise provided may be correct, we're simply guessing at this point in time.

    Trevor Seward

    Office Servers and Services MVP



    Author, Deploying SharePoint 2016

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Friday, October 7, 2016 2:47 AM
  • Thank you for your reply.
    The account with which we are trying to install it is a domain admin. He is in local admin group and it's also a account with full permissions on SQL server.
    This server currently is only for test because we want to test workflows on SharePoint 2016.

    Sharepoint 2016 and SQL 2016 are installed on the same server. Is it problem (I would like to stress again this is a test environment) if we want to put MIM on this same server?

    This is a log file of our previous attempts

    https://drive.google.com/open?id=0B_Cst0SCMGxWUVktZzY0MWJFYnc

    Please advise.
    With best regards


    bostjanc

    Thursday, October 13, 2016 5:57 AM
  • Any other suggestions guys?

    With best regards


    bostjanc

    Friday, October 14, 2016 6:15 AM
  • This looks similar to a problem I had. I opened a case with Microsoft and they narrowed it down to being a DCOM permission issue on the server that I was installing MIM on (even though the install account was a domain admin as well). I installed MIM 2016 on the SharePoint server as well as we aren't a big environment.  Based on a quick glance at your log you may be in the same boat as I was.  I don't recall exactly what I did to fix it but it a nutshell it was:

    On the server that MIM is being installed on,

    • Run dcomcnfg.exe
    • Drill into Component Services
    • Right click on 'My Computer' under Component Services - Computer and click 'Properties'
    • Click on COM Security tab
    • This is where it gets a little fuzzy for me, you have 4 options here, Edit Limits/Edit Default for Access Permissions and Launch and Activation Permissions
    • I had to grant the Administrator account full Allow access to either the 'Edit Default' or 'Edit Limits'.   Whether you need to give the 'Allow' in all 4 of these areas I don't know, the Microsoft tech seemed pretty comfortable doing it though. Once I gave the administrator account Allow permission to all those things, then the install worked fine. 

    I was pretty skeptical that that would fix it for me but I was pleasantly surprised.  Hope this help.

    -Chris

    • Marked as answer by B_C_R Friday, October 14, 2016 12:19 PM
    Friday, October 14, 2016 11:52 AM
  • Dude, you are a live saver! Installation sucessfully continues.

    Many thanks !!!
    with best regards


    bostjanc


    • Edited by B_C_R Friday, October 14, 2016 12:19 PM
    Friday, October 14, 2016 12:19 PM