none
connecting to virtual machine management service hangs RRS feed

  • Question

  • Re-posting from this thread:
    https://answers.microsoft.com/en-us/windows/forum/windows_other-performance/connecting-to-virtual-machine-management-service/f1c6c189-7937-4bac-b800-0400292ada7c

    ORIGINAL POST from itr88:

    Overview of environment

    Hyper-V host 1 - Server 2016 - not domain bound - static IP - 4 nics (1 mgmt 2 guests and 1 spare)

    - software additional to OS (webroot / labtech / veeam backup & replication)

    - Runs two guests

    --guest1 = DC / FS / DNS / DHCP / Backup server

    --guest2 = WEBSERVER

    Situation

    This morning at 4am, the host reboot because of monthly patches (was not suppose to but a different story altogether), issue since then.

    Can connect to host, but cannot connect to hyper-v manager, stuck on this: "connecting to hyper v management service"

    We have done the following in troubleshooting

    -Setup DHCP and DNS (as this is running on the DC that is not running atm)

    -Run MOFCOMP %SYSTEMROOT%\System32\WindowsVirtualization.V2.mof

    -Uninstall webroot and labtech and patches.

    -Ran DCOM fixes and various other attempts to fix this

    We have then booted from OS disc, reinstalled OS, after reinstall could access Hyper-V manager, imported VM's, one failed, one succeeded, rebooted server and back to square one, unable to connect to hyper-v manager service.

    Hyper-V still runs as we have the webserver running, and we can do some management via powershell, but that's it.

    Anyone encounter this or a similar issue, we've searched the internet and we can't find anything closely related to this issue.

    RESPONSE:

    Did you end-up figuring out what happened, or find a fix?

    We experienced the exact same issue on June 17th (the day after your post).

    We have two VM host servers. After scheduled Windows patches in the middle-of-the-night, both rebooted.  One came up normal.  But when the other host rebooted, it came up, but none of the VMs were online.

    Same thing - It was stuck on "connecting to hyper v management service".

    We tried the following, but had no luck
    - Reviewed Error logs - (nothing useful, other than the service was not able to change the states of the VMs)
    - Tried running MOFCOMP %SYSTEMROOT%\System32\WindowsVirtualization.V2.mof
    - Uninstalled the recent Windows patches, rebooted

    We're running a Lenovo System X server.  We initially thought perhaps it was a firmware issue / incompatibility issue with the latest patch, but uninstalling the patch didn't help.

    We ended up re-installing Window Server 2016, after updating all system firmware.  Ran all Windows Updates, then reinstalled Hyper-V role.

    With no VMs added, we started Hyper-V manager and it came up.

    We did not restore any of the prior VMs. Instead we created a new one. Started it. Rebooted the host, it all came up.

    We added two more VMs, rebooted the host, all came up.

    Since then, we added the rest of our VMs but have not rebooted the server.  We are definitely concerned about not having yet determined the root cause of this issue, troubleshooting (besides reinstalling everything from scratch) or a fix.  Nothing we did brought the service back, so this is still of great concern.

    Any new information you may have on this issue would be highly appreciated.

    Monday, June 25, 2018 7:06 PM

All replies

  • Hi,
    Based on the complexity and the specific situation, we need do more researches. If we have any updates or any thoughts about this issue, we will keep you posted as soon as possible. Your kind understanding is appreciated. If you have further information during this period, you could post it on the forum, which help us understand and analyze this issue comprehensively.
    Sorry for the inconvenience and thank you for your understanding and patience.
    Best Regards,

    Frank

    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, June 26, 2018 9:20 AM
    Moderator
  • This has been an ongoing issue for numerous people / customers, where backups are failing because of an issue with VMMS service.  I had a call with a guy from MS and our scenario was after a long running hyperv host was restarted, several updates were applied, the vmms service no longer would start.  He spent hours resolving it, never had a complete answer to the question of 'what caused it to break?' - he plainly stated it wasn't an update, because we didn't remove any updates to make it work.  There were registry key changes, permissions on files changed, and after 4hours, 12 reboots, and 2 pull the plug because it isn't responding anymore (after waiting for 20mins), a final restart after he thought he was done, and viola, it started and has worked well ever since.

    I have another customer currently, with an image based backup solution (no vendor named), and it can't get a good backup of the hypervisor because of VSS/VMMS issues.

     Understanding I may have, but patience I do not.  I'd love to get a fix for this, a solid, repeatable, understandable fix, that we as IT people can implement.  And don't bother with 'each scenario is different and each one has it's own complexities', because it will fall on deaf ears, I hear it every day... that's an excuse for 'I really don't know what I'm doing, i'm just trying to sound smart' or 'I have no idea how to fix it, let me google it some more and get back to you'.

    Lets put our heads together and figure it out... it's a service issue somehow, somewhere... is it a permission on the service, a permission on the registry key?  It's somewhere in there...

    ...and a reboot is simply not the solution...

    Wednesday, September 19, 2018 7:08 PM
  • Did you ever get an answer on this issue? We get the same thing where we lose connectivity to vmms. We notice this when we have to restart a vm and it doesn’t come back up.
    Thursday, November 14, 2019 3:08 PM
  • Have the same issue after installing updates and restarting.

    "connecting to virtual machine management service..." It just hangs.

    Uninstalled updates but same result.

    Saturday, November 16, 2019 3:36 AM
  • It happened to us again a few days ago. It’s the vmms.exe service that hangs. I see some errors the following day after rebooting related to replication then it’s all clean up until we have to reboot an old ws2003 vm when that doesn’t cone up we know the vmms is hung up not sure for how long though. Rebooting hangs at vmms.exe had to kill that remotely. I really don’t want to go through rebuilding the host.
    Saturday, November 16, 2019 12:48 PM