none
setting "Allow scheduled maintenance to wake up mycomputer at the sheduled time" to domain computers

    Question

  • we have about 300 windows 8.1 machines in our domain

    I have read some articles online regarding windows 8 changes in windows update behavior based on my understating it is possible to install windows updates during "automatic maintenance" even when the computer sleeps it will bring it online and install the updates "and restarts it if required" then after specific time it will sleeps again .in order to make this work the "allow wake on timers" should be set to Enable just like I did to all my computers by a script:

    also I have modified the "automatic maintenance activation boundary" to start daily at 10:00 PM

    and enabled the "automatic maintenance wakeup policy"

    here is the issue from one of the clients :

    the tick box wont be check by the GPO!

    any idea why ?

    shad

    Tuesday, December 01, 2015 10:08 PM

Answers

  • Hi shad,

     

    >> but it became active ,before it was greyed out

    According to your description, the option became active for a while after deleting the registry key HKLM\Software\Policies\Microsoft\Windows\Task Scheduler\Maintenance!WakeUp, is that correct?

    In my testing environment, the option is configurable after the registry key above was deleted until next Group Policy update.

    Therefore, I suspect there are policy settings or scripts in your environment leading to the option to be greyed out, I suggest you run GPresult.exe and check whether any related preconfigured security templates or scripts are in use.

    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, December 14, 2015 3:16 AM
    Moderator

All replies

  • Hi shad,

    Does this only happen to one client?

    Could you please check whether the correct registry key below has been created on the problematic machines?

    HKLM\Software\Policies\Microsoft\Windows\Task Scheduler\Maintenance!WakeUp

    The value data of WakeUp should be 1, not 0.

    If you have any questions, please feel free to contact us.


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, December 02, 2015 9:13 AM
    Moderator
  • Hi Wendy,

    all the values are correct 

    one more thing I would like to add if a computer is not joined to the domain "part of the workgroup" I can change those values without any issue

    any idea ?

    best

    shad

    Wednesday, December 02, 2015 10:30 AM
  • Thanks for the update Shad. So group policy applied well on this client machine, Windows just doesn’t read this registry key.

    As asked above, does this only happen to this specific client? Please try to run “gpresult /h C:\result.html” on this client and another client which doesn’t have issue, then check if any additional policy is applied on the faulty machine, which might be causing this issue.

    Also, have you verified the actual result?


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, December 04, 2015 8:35 AM
    Moderator
  • Hi Wendy,

    again thanks for your follow up

    I have checked more than 20 clients all same story

    all other policy's are fine and functioning well

    for the sake of troubleshooting I have Isolated an organizational unit and only Linked the GPO that contain above setting "setting for allow automatic maintenance" same thing !

    but I have noticed automatic maintenance will run as soon as the computer turned on and left for a while "when they are Idle for a while" but this is not what I want

    I want machines wake up at 10:00 Pm every night and do the maintenance plus windows update installation then go back to the sleep but turns put my machines are lazy

    Shad

    Saturday, December 05, 2015 3:41 PM
  • Hi shad,

    Could you please delete the key below on the problematic machines, then check if “Allow scheduled maintenance to wake up mycomputer at the sheduled time” is enabled or not?

    HKLM\Software\Policies\Microsoft\Windows\Task Scheduler\Maintenance!WakeUp

    I’m trying to determine whether any other setting is controlling this.


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, December 08, 2015 1:34 AM
    Moderator
  • HI Wendy,

    i have removed the Registry Key you mentioned

    and the "Allow scheduled maintenance to wake up my computer at scheduled time"

    is still unchecked "disabled"

    but it became active ,before it was greyed out

    thanks for your replay

    shad

    Friday, December 11, 2015 11:38 PM
  • Hi shad,

     

    >> but it became active ,before it was greyed out

    According to your description, the option became active for a while after deleting the registry key HKLM\Software\Policies\Microsoft\Windows\Task Scheduler\Maintenance!WakeUp, is that correct?

    In my testing environment, the option is configurable after the registry key above was deleted until next Group Policy update.

    Therefore, I suspect there are policy settings or scripts in your environment leading to the option to be greyed out, I suggest you run GPresult.exe and check whether any related preconfigured security templates or scripts are in use.

    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, December 14, 2015 3:16 AM
    Moderator