none
General failure. The URL was: "URL" Class not registered RRS feed

  • Question

  • After installing Internet Explorer 10 a lot of users are reporting General failure. The URL was: "URL" Class not registered  problem. I have tried all the solutions from the internet and nothing helps so far. When I reset the internet explorer settings, links start working in Outlook but when the computer is restarted and GPO applied the problem comes back... I need to pin point what's causing it, which policy setting if it is really related to GPO? any feedback greatly appreciated
    Wednesday, September 18, 2013 11:44 PM

Answers

  • Hi ,
     
    I would like to suggest you try the following:

    1. Go to Start > All  Programs > Accessories > Run > and type in regsvr32 ExplorerFrame.dll and then click OK.  See if that works. 
     
    2. If that doesn't work, go to Tools / internet Options / Advanced and check the box to disable script debugging in Internet Explorer and see if that helps.
     
    3. Set  IE to be the default browser in the Control Panel, Default programs applet, Set Program Access and Defaults. Change the default browser to IE.
     
    (You can also reach this dialog through IE’s Tools, Internet options menu, or Control Panel, Internet options. Look on the Programs tab for the Set Programs button.)
     
    4. You may also remove the other web browsers if you have.
     
    For more reference, try reviewing the following article:
     
    Tips for solving problems with Internet Explorer
     
    http://windows.microsoft.com/en-US/windows7/Tips-for-solving-problems-with-Internet-Explorer
     
    Change your default web browser
     
    http://windows.microsoft.com/en-US/windows7/Change-your-default-web-browser
     
    Hope it helps.
     
    Regards,
     
    Blair Deng


    Blair Deng

    TechNet Community Support

    Monday, September 23, 2013 1:04 AM
    Moderator

All replies

  • It would be better to use the System File Checker tool to troublshoot the problem.

    Start the Command Prompt as Administrator and type the next command.

    sfc /scannow

    Thursday, September 19, 2013 6:42 AM
  • did that already .... no go ...

    Thursday, September 19, 2013 8:11 AM
  • Hi ,
     
    I would like to suggest you try the following:

    1. Go to Start > All  Programs > Accessories > Run > and type in regsvr32 ExplorerFrame.dll and then click OK.  See if that works. 
     
    2. If that doesn't work, go to Tools / internet Options / Advanced and check the box to disable script debugging in Internet Explorer and see if that helps.
     
    3. Set  IE to be the default browser in the Control Panel, Default programs applet, Set Program Access and Defaults. Change the default browser to IE.
     
    (You can also reach this dialog through IE’s Tools, Internet options menu, or Control Panel, Internet options. Look on the Programs tab for the Set Programs button.)
     
    4. You may also remove the other web browsers if you have.
     
    For more reference, try reviewing the following article:
     
    Tips for solving problems with Internet Explorer
     
    http://windows.microsoft.com/en-US/windows7/Tips-for-solving-problems-with-Internet-Explorer
     
    Change your default web browser
     
    http://windows.microsoft.com/en-US/windows7/Change-your-default-web-browser
     
    Hope it helps.
     
    Regards,
     
    Blair Deng


    Blair Deng

    TechNet Community Support

    Monday, September 23, 2013 1:04 AM
    Moderator
  • You can remove AssociationActivationMode or set it to 0 from HKCU\Software\Microsoft\Internet Explorer\Main.

    this should fix the issue.

    • Proposed as answer by isrussell Monday, January 18, 2016 10:51 AM
    Tuesday, January 12, 2016 10:36 PM