locked
UAG & SharePoint 2010 - Opening Documents with Mac Office 2011 RRS feed

  • Question

  • We have SharePoint 2010 published through our UAG and some of our external users are having trouble opening documents. The users have macs and when they click on an Office document their browser hands over the download to their Mac Office 2011 client. The user is prompted for their credentials but afterwards receive an "The address is not valid" error message.

    Has anyone seen this before? Everything works for our Windows users so I'm not sure what's the deal.

    Monday, December 19, 2011 7:56 PM

All replies

  • Hi ubipa,

    Did you find an answer...having the same issue?

     


    RRS
    Wednesday, February 1, 2012 10:49 PM
  • Hi,

    Please read my post in this thread. It might be an answer to your issue.

    http://social.technet.microsoft.com/Forums/en-US/forefrontedgeiag/thread/13b103d3-5944-4dde-9c28-e9d0f752ab6f

    You have to check the Endpoint Policies for Machintosh. You need to verify that this is not causing the issue.


    Peter Selch Dahl - www.peterdahl.net - Blog: http://blog.peterdahl.net - Twitter @PeterSelchDahl
    Thursday, February 2, 2012 6:14 PM
  • Nope, I ran out of time to look into this any furter. It looks like Mac Office 2011 just doesn't play nice with the UAG. Using a different browser will allow the user to download the document. Using Safari will fail since it tries to pass over the connection to one of the office applications.

    Thursday, February 2, 2012 6:27 PM
  • So..what browser were you using instead on Safari, firefox or chrome...
    RRS
    Thursday, February 2, 2012 8:01 PM
  • Any... The Safari Mac office plugin is what hands over the connection. We specifically tested chrome and firefox, they downloaded the document as intended.
    • Proposed as answer by srituraj Tuesday, February 7, 2012 7:25 PM
    Thursday, February 2, 2012 8:05 PM