none
weird import from Oracle RRS feed

  • Question

  • Hi!

    I have encountered the following problem while importing data from Oracle DB via Power Query.

    I start by importing data with Power Query. On this step everything goes fine: the data is loaded correctly. Then I use Power Query connection to load data into PowerPivot. When data is loaded and no error message showed I found that for some rows the data in power pivot doesn’t match with the one in database and in power query. For instance, 3 out of 10 columns has been loaded correctly, other 7 appeared blank. Interestingly, some rows are imported 100% correctly i.e. all 10 columns has identical values in database, power query and powerpivot. Data types of these tables comply with those in database and power query. What am I missing? 


    • Edited by ya-ilya Tuesday, August 16, 2016 3:17 PM
    Tuesday, August 16, 2016 3:10 PM

Answers

All replies

  • The most likely explanation is that there was a problem with the data type. What does the text of your Power Query look like? If you load the same data into an Excel worksheet instead of PowerPivot, do you see the same behavior?

    Tuesday, August 16, 2016 4:25 PM
  • Curt, thnx for quick reply. 

    the problem was indeed with data type. some values were rounded to say 3-4 digits after come, some - 10 digits. so the latters were missing in powerpivot. is this a bug or normal behavior?

    Wednesday, August 17, 2016 3:51 PM
  • Hi Ya-ilya,

    What is the Oracle datatype of the columns which are loading incorrectly, and what do these column values look like in the Oracle database?


    Thursday, September 1, 2016 5:13 PM