locked
Exchange 2007 Out of office not sending mails (internal and external)

    Question

  • Here's the deal: Clients have no problem configuring their Out of office, both trough Outlook 2007 as trough OWA.
    No errors, outlook reports the oof is turned on.
    (in contrary to other posts i've read about clients not being able to set the OOO)

    But whenever someone sends a mail to that person, the mail is delivered, but the out of office reply is never sent.
    doens't mather if the mail is received from an internal sender or an external sender.
    Examining the message tracking log, i can see the mail comming in, but no mail is sent back.

    We have a server with the CAS and HUB role and a dedicated mailbox server.
    all other mailflow is working.
    Both are running Exchange 2007 SP2

    So imho it seems to be a client problem.
    or some issue with one of the virtual directories in IIS, altough all tests seem to work (autodiscover etc)

    Anyone got any clues or similar problems?

    Much appreciated!

    Friday, November 06, 2009 11:13 AM

Answers

  • Hi,

    As VISHAL asked, whether single user or all users have this issue?

    Regarding the OOF message, I would like to explain that it is a Rule saved in mailbox. The rule is only triggered when a message is delivered to the mailbox.

    Please try to restart the Exchange Mailbox Assistants Services to check this issue.

    If the issue persists, please clear OOF Rule in the mailbox:

    1. Turn off OOF on a problem user and close Outlook
    2. Use MFCMapi tool to logon the problem user’s mailbox (by using Online Mode profile)
    3. Expand Root Container->Top of Information Store
    4. Right click Inbox folder and click Open Associated contents table
    5. Delete following messages if exist:

    a. Message class == IPM.Rule.Message
    0x65EB001E == Microsoft Exchange OOF Assistant
    0x65EC001E == Microsoft.Exchange.OOF.InternalSenders.Global

    b. Message class == IPM.Note.Rules.OofTemplate.Microsoft

    c. Message class == IPM.Rule.Message
    0x65EB001E == MSFT:TDX OOF Rules

    d. Message class == IPM.Rule.Message
    0x65EB001E == Microsoft Exchange OOF Assistant
    0x65EC001E == Microsoft.Exchange.OOF. AllExternalSenders.Global

    e. Message class == IPM.Note.Rules.ExternalOOFTemplate.Microsoft

    f. Message class == IPM.ExtendedRule.Message
    0x65EB001E == Microsoft Exchange OOF Assistant
    0x65EC001E == Microsoft.Exchange.OOF.KnownExternalSenders.Global

    6. After that, please start Outlook and configure OOF for the user. Please check whether the issue persists.

    If the issue persists, please increase diagnostic logging to check whether any related error is encountered. Please enable diagnostic logging on following categories:

    MSexchangeMailboxAssistants\Service
    MSexchangeMailboxAssistants\OOF Assistant
    MSexchangeMailboxAssistants\OOF Library
    MSexchangeIS\9000 Private\Rules

    Thanks

    Allen

    • Proposed as answer by BobbyFantastic Thursday, November 19, 2009 2:14 PM
    • Marked as answer by Allen Song Friday, November 20, 2009 9:31 AM
    Monday, November 09, 2009 10:14 AM
  • Hi all,

    Well it's finally solved, I called MS tech support and logged a ticket.

    What we did is created a new mailbox datastore and moved all the mailboxes to the new store.

    After that, we removed the old mailbox store.
    It appears Exchange verifies and fixes any corrupt attributes on the mailbox, or so I was told.

    Hope it helps someone else!

    Thanks for all that tried to help

    • Marked as answer by Patje_vb Wednesday, April 14, 2010 1:54 PM
    Wednesday, April 14, 2010 1:53 PM

All replies

  • Hey,

    Is the issue with single/few users. if so then i would suggest try deleting OOO hidden rules with MAPI Editor like mfcMAPI . and the instructions are here . Also note that the OOO auto-reply is sent only once to any sender untill its reactivated.

    Thanks.



    Vishal Ramnani | MCITP - Exchange 2007 | MCSE Messaging | MCTS - Win 2008 Config
    Friday, November 06, 2009 12:28 PM
  • Hi,

    As VISHAL asked, whether single user or all users have this issue?

    Regarding the OOF message, I would like to explain that it is a Rule saved in mailbox. The rule is only triggered when a message is delivered to the mailbox.

    Please try to restart the Exchange Mailbox Assistants Services to check this issue.

    If the issue persists, please clear OOF Rule in the mailbox:

    1. Turn off OOF on a problem user and close Outlook
    2. Use MFCMapi tool to logon the problem user’s mailbox (by using Online Mode profile)
    3. Expand Root Container->Top of Information Store
    4. Right click Inbox folder and click Open Associated contents table
    5. Delete following messages if exist:

    a. Message class == IPM.Rule.Message
    0x65EB001E == Microsoft Exchange OOF Assistant
    0x65EC001E == Microsoft.Exchange.OOF.InternalSenders.Global

    b. Message class == IPM.Note.Rules.OofTemplate.Microsoft

    c. Message class == IPM.Rule.Message
    0x65EB001E == MSFT:TDX OOF Rules

    d. Message class == IPM.Rule.Message
    0x65EB001E == Microsoft Exchange OOF Assistant
    0x65EC001E == Microsoft.Exchange.OOF. AllExternalSenders.Global

    e. Message class == IPM.Note.Rules.ExternalOOFTemplate.Microsoft

    f. Message class == IPM.ExtendedRule.Message
    0x65EB001E == Microsoft Exchange OOF Assistant
    0x65EC001E == Microsoft.Exchange.OOF.KnownExternalSenders.Global

    6. After that, please start Outlook and configure OOF for the user. Please check whether the issue persists.

    If the issue persists, please increase diagnostic logging to check whether any related error is encountered. Please enable diagnostic logging on following categories:

    MSexchangeMailboxAssistants\Service
    MSexchangeMailboxAssistants\OOF Assistant
    MSexchangeMailboxAssistants\OOF Library
    MSexchangeIS\9000 Private\Rules

    Thanks

    Allen

    • Proposed as answer by BobbyFantastic Thursday, November 19, 2009 2:14 PM
    • Marked as answer by Allen Song Friday, November 20, 2009 9:31 AM
    Monday, November 09, 2009 10:14 AM
  • Hi, thanks for getting back to this, you posts seem to be in the right direction so I will defenatly try out your suggestions and post some feedback!
    Much appreciated!

    edit: Update, I found a user who has turned of his OOO but mails still are sent out (like it's still turned off)
    will start with the mfcapi tool now...  TBC
    Thursday, November 12, 2009 3:43 PM
  • Allen Song - This worked like a charm!

    In the users mailbox there was about 15 "IPM.Note.Rules.OofTemplate.Microsoft" and "IPM.Note.Rules.ExternalOOFTemplate.Microsoft" entries in her MAPI Profile.

    I deleted all of those entries and the Out Of Office reply started working!

    much thanks!
    Thursday, November 19, 2009 2:14 PM
  • Well, I've been looking into this again and again.
    So far I discovered that the PR_OOF_STATE does not change when I change the OOF settings either trough OWA or outlook 2007.
    I've deleted all the rules as stated in Allen's guide.

    I will try to start checking the logs for:
    MSexchangeMailboxAssistants\Service
    MSexchangeMailboxAssistants\OOF Assistant
    MSexchangeMailboxAssistants\OOF Library
    MSexchangeIS\9000 Private\Rules

    any other ideas are more than welcome!
    Wednesday, December 23, 2009 2:22 PM
  • Hi,

    As VISHAL asked, whether single user or all users have this issue?

    Regarding the OOF message, I would like to explain that it is a Rule saved in mailbox. The rule is only triggered when a message is delivered to the mailbox.

    Please try to restart the Exchange Mailbox Assistants Services to check this issue.

    If the issue persists, please clear OOF Rule in the mailbox:

    1. Turn off OOF on a problem user and close Outlook
    2. Use MFCMapi tool to logon the problem user’s mailbox (by using Online Mode profile)
    3. Expand Root Container->Top of Information Store
    4. Right click Inbox folder and click Open Associated contents table
    5. Delete following messages if exist:

    a. Message class == IPM.Rule.Message
    0x65EB001E == Microsoft Exchange OOF Assistant
    0x65EC001E == Microsoft.Exchange.OOF.InternalSenders.Global

    b. Message class == IPM.Note.Rules.OofTemplate.Microsoft

    c. Message class == IPM.Rule.Message
    0x65EB001E == MSFT:TDX OOF Rules

    d. Message class == IPM.Rule.Message
    0x65EB001E == Microsoft Exchange OOF Assistant
    0x65EC001E == Microsoft.Exchange.OOF. AllExternalSenders.Global

    e. Message class == IPM.Note.Rules.ExternalOOFTemplate.Microsoft

    f. Message class == IPM.ExtendedRule.Message
    0x65EB001E == Microsoft Exchange OOF Assistant
    0x65EC001E == Microsoft.Exchange.OOF.KnownExternalSenders.Global

    6. After that, please start Outlook and configure OOF for the user. Please check whether the issue persists.

    If the issue persists, please increase diagnostic logging to check whether any related error is encountered. Please enable diagnostic logging on following categories:

    MSexchangeMailboxAssistants\Service
    MSexchangeMailboxAssistants\OOF Assistant
    MSexchangeMailboxAssistants\OOF Library
    MSexchangeIS\9000 Private\Rules

    Thanks

    Allen


    Although I didn't quite see what Allen was referring to here I did delete the Message Classes he listed and then re-enabled OoO and everything was fine.
    Thursday, March 25, 2010 8:33 PM
  • I am experiencing the same issue, deleted Message classes but no luck.

    Any help would be appriciated.

    thanks in advance.

    Tuesday, April 13, 2010 3:49 AM
  • Hi all,

    Well it's finally solved, I called MS tech support and logged a ticket.

    What we did is created a new mailbox datastore and moved all the mailboxes to the new store.

    After that, we removed the old mailbox store.
    It appears Exchange verifies and fixes any corrupt attributes on the mailbox, or so I was told.

    Hope it helps someone else!

    Thanks for all that tried to help

    • Marked as answer by Patje_vb Wednesday, April 14, 2010 1:54 PM
    Wednesday, April 14, 2010 1:53 PM
  • I am experiencing the same issue, deleted Message classes but no luck.

    Any help would be appriciated.

    thanks in advance.


    Diego,

    If you still need help with this maybe you could post some info on your setup and steps you've tried. For instance... is this happening with internal AND external Out of Office replies? Is this happening with all users or just one?

    Rob

    Tuesday, April 20, 2010 6:01 PM
  • Hi All

    we are facing same issue but from client side No error from server side no error but still OOF not sending auto reply for any user.(all user same issue).I have tested autodiscover connectivity and other testing area IIS 7.0 virtual directories.

    yes one week back we have renew our ssl certificate, but ssl certificate are working fine for other like OWA, autodiscover ,outlookanywhere ....without any error.

    Get-autodiscovervirtualdiectroy | fl give and showing correct info.

    please help if anyone having any clue to resovle this

    thanks

    YASHVARDHAN 

     

    Saturday, May 22, 2010 9:07 AM
  • Hi guys

    We had a user who's mailbox wasn't sending out Out-of-Office replies. Upon further inspection we found that the user had tons of rules and we suspect they reached their rule limit and we just didn't receive an error when enabling their Out-of-Office. After we deleted some rules the Out-of-Office replies started going out.

    Hope this helps those few that are still having the problem.

    Regards

    Tom

    Wednesday, December 08, 2010 10:47 AM
  • On Wed, 8 Dec 2010 10:47:39 +0000, KillswitchEngage wrote:
     
    >We had a user who's mailbox wasn't sending out Out-of-Office replies. Upon further inspection we found that the user had tons of rules and we suspect they reached their rule limit and we just didn't receive an error when enabling their Out-of-Office. After we deleted some rules the Out-of-Office replies started going out.
     
    You can also increase the quota allowed for rules on that mailbox with
    "set-mailbox ... -RulesQuota ...".
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Wednesday, December 08, 2010 9:53 PM
  • I can see in the post that all the basics steps to resolve the issue you have taken care.

    Such a issue may occur when the mailbox has some corruption in it.

    If this issue occurs with all the users than you may need to check at the database level corruption.

    You can check Event related to MSEXCHANGE IS  event No 474 , 478, 447

    Solution : ISINTEG on database http://support.microsoft.com/kb/182081

    Note:-You have to dismount database & it run at a speed of 10 to 12 GB per hour depend on the hardware used & size of Database.

    If this issue occurs only for few user on the same database.

    Than you need to create a test database under the same storage group & move the user mailbox in case of CCR & LCR you can create new storage group and new database

    Once the move process is completed for that user if there is corruption in the affected user mailbox than move will fail

    Move the user again and in mailbox move wizard specify corrupted items as 50 to 99 & try again.

    once user is moved to new database corruption will left behind on the old database

    Check the OOF for the affected user.

    hope this time it will work.

     

    Thursday, September 29, 2011 6:19 AM
  • Just taught I would update this thread with how I solve this issue. Turned out that the Exchange Mailbox Assistants Services was not started. After starting the service everything worked fine! Thanks Allen Song for pointing me in the right direction
    • Proposed as answer by Ryan Crase Tuesday, July 03, 2012 6:45 AM
    Thursday, December 01, 2011 6:08 PM