none
Compatibility Mode button not appearing in IE9 when I deploy to Windows 2003/IIS6? RRS feed

  • Question

  • When I run my site locally on Windows 7/IE 9, I see the compatability mode button.   However, when I deploy to a Windows 2003 dev server, the site renders in the same IE 9 browser but without the compatability button in the address bar?  Is IIS6 somehow causing this not to show?

    Thanks, Dave.

    Monday, January 14, 2013 3:55 PM

Answers

  • Hi,

    for questions about html, css and scripting for website developers please post to the IE Web Development forum (with a link to your website)...

    localhost is mapped to the Intranet zone, publicdomain.com (by default) is mapped to the Internet zone.... Tools>Compatibility View Settings>check/uncheck "Display intranet sites in Compatibility View". If using Visual Studio 2010 to debug/view your website, then it may be using (depending upon how you have configured your project) the built-in webserver ("Cassini") eg.... http://localhost:{unique port no.}. Select the File>Properties menu to find out which Security Zone a website is being mapped to.

    see also

    Internet Options>Advanced tab, check "Recover from rendering errors with compatibility view"... If your web page contains markup errors (validate and correct markup errors (f12>Developer Tool>Validate>HTML or http://validator.w3.org for local files using copy/paste into the direct input tab) then IE8 and higher may fall back to using 'Near Standards' rendering (viz: IE7 emulation).

    If a web page either is in the Compatibility View List (your personal or the one from MS (see "Include updated website lists from Microsoft" in Compatibility View Settings) then the Compatibility View Button appears on the IE address bar (to give the opportunity for the user to over-ride the setting.

    Compatibility View ('Near Standards' rendering) can also be controlled by website developers by including a x-ua meta in their pages or server response headers.

    see Defining Document Compatibility View


    Rob^_^

    Monday, January 14, 2013 11:47 PM
  • Wednesday, January 16, 2013 8:12 AM
    Moderator

All replies

  • Hi,

    for questions about html, css and scripting for website developers please post to the IE Web Development forum (with a link to your website)...

    localhost is mapped to the Intranet zone, publicdomain.com (by default) is mapped to the Internet zone.... Tools>Compatibility View Settings>check/uncheck "Display intranet sites in Compatibility View". If using Visual Studio 2010 to debug/view your website, then it may be using (depending upon how you have configured your project) the built-in webserver ("Cassini") eg.... http://localhost:{unique port no.}. Select the File>Properties menu to find out which Security Zone a website is being mapped to.

    see also

    Internet Options>Advanced tab, check "Recover from rendering errors with compatibility view"... If your web page contains markup errors (validate and correct markup errors (f12>Developer Tool>Validate>HTML or http://validator.w3.org for local files using copy/paste into the direct input tab) then IE8 and higher may fall back to using 'Near Standards' rendering (viz: IE7 emulation).

    If a web page either is in the Compatibility View List (your personal or the one from MS (see "Include updated website lists from Microsoft" in Compatibility View Settings) then the Compatibility View Button appears on the IE address bar (to give the opportunity for the user to over-ride the setting.

    Compatibility View ('Near Standards' rendering) can also be controlled by website developers by including a x-ua meta in their pages or server response headers.

    see Defining Document Compatibility View


    Rob^_^

    Monday, January 14, 2013 11:47 PM
  • Wednesday, January 16, 2013 8:12 AM
    Moderator