Volumes disappeared from DFS replication


  • Hi all,

    Recently I set up DFS replication on Windows 2012 Std Server. Few days ago I tried to connect the 3rd server to this replication and found out that all volumes except C:\ drive are disappeared from DFS replication on the main server, so it can't do initial replication.

    When I go to DFS snap-in and create Diagnostic report for the replication - it shows me available volumes on every server - C:\ drive only for the main one and all volumes for other servers. Shares on the main server are up and running without any problems.

    So the question is how to add the volumes back to DFS replication, any ideas?

    Kind regards,


    Tuesday, December 17, 2013 2:43 AM

All replies

  • Your situation is not real clear. Before you "tried to connect the 3rd server to this replication", I assume you had replication working between 2 servers.  Is that correct?

    Then you added a 3rd server.  And then at that point volumes "disappeared".  Disappeared where?  From the server(s) or in the DFS console?

    When you added this 3rd server to the mix, did you first pre-seed it with the data from the main server?

    Tuesday, December 17, 2013 1:42 PM
  • Yes, the first time I set up replication, all was good. All folders were replicated without any errors. Then I haven't checked the replication status for some time, because we didn't use the second server, but it was online.

    When I connected 3rd server and set up shares and replication groups there, I found that all folders on the 3rd server are empty. I checked replication between 1st (main) and 2nd servers - it didn't work. Then I created diagnostic report and found out that on the 1st server all volumes with data are disappeared from DFS replication and DFSR working only for C:\ drive. Other 2 servers have all volumes available for replication.

    Tuesday, December 17, 2013 8:28 PM
  • Hi, 

    It seems that DFS replication can't sync between the main server and the second server. I suggest you recreate the replication group to resolve the issue. If there is any error message in the diagnostic report or event log? If so, please provide the error message to troubleshoot the issue.

    Please also refer to the thread below to see if it helps:

    DFSR Replication Broken


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    Thursday, December 26, 2013 5:57 AM
  • Hi,

    Thank you for your answer, but unfortunately we still have the problem.

    I tried to create a new Test folder and replicate it using DFS.

    This is a screenshot of DFS from our main file-server. I created a DFS replication group for the folder and second server received this update, but when I put a file in the folder - it doesn't replicate.

    Another strange thing is that I can't see my disks in DFS replication health report, only C:\ drive.

      As you can see, in "Current used and free disk space....." section there is only C:\ drive, but I have 6 drives on this server and before replication has been broken I could see all these drives in this section.

    Do you have any ideas what could happen and how to fix that?



    Sunday, February 02, 2014 7:57 PM
  • I'm also having the same problem, did you ever work it out?

    Friday, June 13, 2014 3:36 PM
  • Yes, in event log on the affected server you can find a warning, something like "Replication stopped for this volume, to resume run this command wmic /microsoftDFS........ /volume:<volumeID>... /ResumeReplication."

    So you need to make a snapshot or backup of the volume and run this command in command prompt with admin permissions. BUT! Maybe it happens only on my servers, but on all of them: when you run this command once - it will show you the output with success immediately - it's wrong. You need to run the same command again and it will think for about a minute before giving you the output string (the same one). After that replication will start.

    Good luck!

    Saturday, June 14, 2014 11:06 PM
  • Afraid I'm getting no such errors in the event log, and running the resume replication for the volume GUID in question just returned "no instance found"
    Tuesday, June 17, 2014 1:15 PM
  • Did you ever get any Event IDs 4102:   The DFS Replication service initialized the replicated folder at local path...

    That's step one, after creating the replication group and then replication folders.  You should get a 4102 for each folder in a group.  When initial replication is done you'll get a 4104.
    Have you tried deleting the replication group and recreating it?

    Tuesday, June 17, 2014 8:15 PM
  • Try to find an event 2213 (it's a warning, not error).

    Tuesday, June 17, 2014 8:50 PM
  • Hi John,

    I doesn't get that far (4102): That log message pops up when using folders on the C drive, but not on the actual volumes I need to use

    The last logged entry is: 1210

    The DFS Replication service successfully set up an RPC listener for incoming replication requests.
    Additional Information:
    Port: 5722

    I haven't got any 2213 warnings in any event logs on any of my servers, so you can see how frustrating this is!

    Wednesday, June 18, 2014 9:44 AM
  • Yes I've tried recreating the group, still no joy.

    I really hope the event log wasn't cleared any stage, this issue is long running and I've been trying different combos of servers and drives between then, I'm guessing the event log mentioning the problem with the volume wouldn't keep popping up

    Wednesday, June 18, 2014 10:59 AM
  • Hi John,

    I doesn't get that far (4102): That log message pops up when using folders on the C drive, but not on the actual volumes I need to use

    So a new replication folder on C: generates a 4102, but doing the same thing on a different volume doesn't?  Did replication ever work for this other volume?

    What is this about "event log mentioning the problem with the volume"? What is the error?

    Thursday, June 19, 2014 6:36 PM
  • Well I'm pretty sure the - Replication stopped for this volume, to resume run this command wmic /microsoftDFS........ /volume:<volumeID>... /ResumeReplication."-message has never popped up on our event logs, but yet everyone else that is having a problem similar, not being able to use certain folders or volumes, but it works fine on others, has fixed it because that message popped up and they simply did what it says in the message.

    So I'm still really stuck here.

    Ideally I'd like someone from Microsoft to remote on perhaps and investigate?

    Wednesday, July 02, 2014 9:35 AM