locked
How to enable AutoLogon on Windows Server 2012 R2 Standard RRS feed

  • Question

  • In earlier versions, it was possible to enable autologon to a Windows Server R2 by disabling of "control userpasswords2" option "Users must enter a user name and password to use this computer" (of course, the credentials have to provided and the option has to be available).

    This feature seems to no longer be supported since a windows update earlier this year. I could not nail it down to a certain KB-ID precisely, sorry.


    Tuesday, November 14, 2017 10:02 AM

All replies

  • Hi,

    Based on my research and test, Control userpasswords2 couldn't be used to enable auto-logon if the server is a DC or domain member server.

    To enable auto logon, we could follow the steps in the following KB article:

    https://support.microsoft.com/en-us/help/324737/how-to-turn-on-automatic-logon-in-windows

    If you need further help, please feel free to let us know.

    Best Regards,

    William


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, November 14, 2017 12:26 PM
  • Hi,

    Just checking in to see if the information provided was helpful. Please let us know if you would like further assistance.

    Best Regards,
    William


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, November 15, 2017 2:21 AM
  • Try to use the registry key technique.

    You will need to have an account with a password for this to work.

        Run regedit.exe

        Navigate to

        HKLM\Software\Microsoft\Windows NT\CurrentVersion\winlogon

     Set or create the following keys

        (DWORD)  AutoAdminLogon = 1
        (String) DefaultUserName = Your user name
        (String) DefaultPassword = Your password

    Restart and let us know if it works!

    https://superuser.com/questions/499724/auto-login-windows-server-2012

    https://www.geekality.net/2014/08/26/automatic-login-for-windows-server-2012-r2/

    Hope this helps!


    Solution for Active Directory auditing, monitoring and management.

    • Proposed as answer by RomanMulley Wednesday, November 15, 2017 11:08 AM
    Wednesday, November 15, 2017 7:28 AM

  • Hi,
     
    Just checking in to see if the information provided was helpful. Please let us know if you would like further assistance.
     
    Best Regards,
    William

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Saturday, November 18, 2017 2:00 PM
  • Hi,

    Was your issue resolved? 

    If you resolved it using our solution, please "mark it as answer" to help other community members find the helpful reply quickly.
    If you resolve it using your own solution, please share your experience and solution here. It will be very beneficial for other community members who have similar questions.
    If no, please reply and tell us the current situation in order to provide further help.

    Best Regards,
    William

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, November 20, 2017 8:51 AM
  • You can Use netplwiz.exe in the windows\system32 directory

    its the same that control userpasswords2

    Best Regards

    Wednesday, April 25, 2018 3:39 PM
  • Use the this one. I tried it, and it works.

    If you use the full registry method, then your password will be saved in plan text, which could be a security issue. To get around this you can force the checkbox to appear no matter what.

    - Open the registry and navigate to "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon".
    - Create ONLY the String "AutoAdminLogon" with a value of "1".
    - Close the registry editor and open a CMD prompt.
    - Type "control userpasswords2" without the quotes.

    You will now see the same dialog the OP posted but with the checkbox "Users must enter a user name and password to use this computer" and it will be unchecked.

    - Re-check the box and hit Apply.
    - Then uncheck it again and hit Apply or OK and save your UID and PWD.

    The machine will auto login, without storing your credentials in the registry in plain text. If you had previously did the full registry method before with UID and PWD I would delete them before doing this, however checking the box might delete the keys for you.

    • Proposed as answer by jtczrt Monday, August 12, 2019 3:29 PM
    Friday, August 9, 2019 9:43 AM