locked
WSUS (Server 2016) Won't Change from Replica to Sync from Microsoft RRS feed

  • Question

  • I created a new Server 2016 VM which is going to be only for the WSUS service.  I installed the service (using the WID for the database) and set it as a replica of my current WSUS so it would get all my current settings, groups, authorized and declined update configuration etc.  The plan is to decommission the current WSUS. The replication took about 2 hours and finished without errors.  I then went to change it from a replica to having it look to Microsoft, but when I click on Apply, it throws the following error at me:

    ----------------------

    The WSUS administration console was unable to connect to the WSUS Server Database.
    Verify that SQL server is running on the WSUS Server. If the problem persists, try restarting SQL.
    System.Data.SqlClient.SqlException -- Maximum stored procedure, function, trigger, or view nesting level exceeded (limit 32).
    Info:spSetConfiguration - SyncToMU or UpstreamServerName config value changed - no reset
    Source
    .Net SqlClient Data Provider
    Stack Trace:
       at Microsoft.UpdateServices.UI.AdminApiAccess.UpdateServerConfigurationManager.SaveServerConfiguration(IUpdateServerConfiguration configuration)
       at Microsoft.UpdateServices.UI.SnapIn.Dialogs.UssConnectionSettingsDialog.SaveAllSettings()
       at Microsoft.UpdateServices.UI.SnapIn.Dialogs.BaseSettingsDialog.OKDialogButton_Click(Object sender, EventArgs e)

    --------------------

    I've looked for a solution and found this page:

    https://community.spiceworks.com/topic/517057-configuring-wsus-2012r2-error-post-installation-task?page=1#entry-3583592

    None of the suggestions worked.  I removed WSUS and the WID (using the powershell command supplied).  I even wiped the VM and reinstalled Server fresh as well as WSUS.  The same problem is happening.  I can turn off the option to be a replica, but once I click Apply/Ok when changing it from 'Sync from another WSUS' to 'Sync from Microsoft' it errors out.

    I'm totally stumped here.  Does anyone have any ideas/suggestions?

    Sunday, March 4, 2018 6:59 AM

Answers

  • I checked and the ports were properly set up by the WSUS role when installed. The firewall on my outside router is fine as the master WSUS is working perfectly.  Thanks for the suggestion.

    Now, of course, Microsoft products being Microsoft products, I let the server sit overnight running, and just for kicks I decided to try changing it from a Replica to look to Microsoft this morning.  Well, it worked.  I guess you just had to let the server sit for a few hours to do whatever it is it does.  No idea what happened or why it acted differently when I didn't touch it overnight, but that's about par for the course.  At least it's working... for now.  heh

    I'll mark this as resolved... even though I don't know how it was resolved.

    • Marked as answer by Ray.Hirsch Monday, March 5, 2018 12:10 AM
    Monday, March 5, 2018 12:10 AM

All replies

  • hello,

    Did you allowed relevant ports/url from firewall to connect Microsoft update Services?

    https://technet.microsoft.com/en-us/library/bb693717.aspx?f=255&MSPPError=-2147217396

    Sunday, March 4, 2018 1:27 PM
  • I checked and the ports were properly set up by the WSUS role when installed. The firewall on my outside router is fine as the master WSUS is working perfectly.  Thanks for the suggestion.

    Now, of course, Microsoft products being Microsoft products, I let the server sit overnight running, and just for kicks I decided to try changing it from a Replica to look to Microsoft this morning.  Well, it worked.  I guess you just had to let the server sit for a few hours to do whatever it is it does.  No idea what happened or why it acted differently when I didn't touch it overnight, but that's about par for the course.  At least it's working... for now.  heh

    I'll mark this as resolved... even though I don't know how it was resolved.

    • Marked as answer by Ray.Hirsch Monday, March 5, 2018 12:10 AM
    Monday, March 5, 2018 12:10 AM