none
Need help using PE 3.0 for LiteTouch x86(instead of PE 4.0) RRS feed

  • Question

  • Hello everyone,

    I am trying to deploy a Windows XP image(we still have one model of legacy systems being phased out next year). The systems don't have the processor requirements for Windows 8. Therefore, when Windows PE 4.0 tries to boot it tells me that the processor will not boot the system. I managed to remove PE 4.0 from the deployment server and installed WAIK to get PE 3.0. The DeploymentShare updates just fine with a Windows 7 x86 boot.wim. However, when I try to run the deployment I get the following message "The Deployment Wizard was cancelled or did not complete successfully. The deployment will not proceed." If I mount the share manually, and run litetouch.vbs I get the same message. What is causing this error? I must use PE 3.0 or older do to the processor of the older computers. I have attempted to boot the LiteTouch x86 wim on a physical computer as well as a Parallels VM(which I have used several times to test deployments) but i get the same result. The computers are booted from a WDS server


    Here is the log file(BDD.log)
    • Edited by Zach_CR Monday, October 14, 2013 12:26 AM
    Monday, October 14, 2013 12:17 AM

All replies

  • Thanks for the bdd.log file.

    I can't tell what's going on here.

    Litetouch.wsf started the wizard.hta, however the wizard *immediately* exited without doing any processing?!?! I don't understand.

    It's possible that there some missing files in your winpe.wim image that are preventing the script from running. Easiest thing would be to "update" your WinPE image, and be sure to select "full update" to completely re-generate the image.


    Keith Garner - keithga.wordpress.com

    Monday, October 14, 2013 5:58 PM
    Moderator
  • I think I may have found the problem. I need to add PE 3 compatible packages for HTA compatibility, WMI, and Scripting. I will try this tomorrow and tell you what happens.
    Monday, October 14, 2013 11:41 PM
  • MDT will add those automatically, are you *not* building the WinPE images through MDT?

    Keith Garner - keithga.wordpress.com

    Tuesday, October 15, 2013 1:58 AM
    Moderator
  • I am. However, it is trying to add the PE 4 packages which isn't compatible for 3.0. I can "trick" it into using the pe.wim for PE 3.0 to add the scripts but it will not be able to add the components. I use the x64 PE 4.0 with DaRT 8 so I can't downgrade that one. Otherwise, this process could be a lot easier.
    Tuesday, October 15, 2013 11:05 PM
  • Sure Enoguh! The HTA wizard was able to start! Adding the packages worked. However, if anyone else needs something like this, I would suggest creating a VM with only WAIK to do this(therefore automatically using PE 3.) It requires lots of modifications and I am only doing it because I am rolling out new computers to replace these computers in December. 
    • Edited by Zach_CR Tuesday, October 15, 2013 11:11 PM
    Tuesday, October 15, 2013 11:10 PM