none
Rpc/Http Exchange 2003 RRS feed

  • Question

  • Hi all,

    I am in the process of migrating to Office365 but am getting stumped at the RPC/http configuration of Exchange 2003 

    My environment consists of a single Exchange 2003 server, two domain controllers (both GC) and other member servers. My internal domain is .local with the external domain being .co.uk Thus far I have:

    1. Ensured OWA is working
    2. Installed RPC/HTTP component on my exchange server.
    3. On one of my GC servers, added the NSPI interface protocol sequences. Set this value to ncacn_http:6004
    4. Completed the below port changes to the registry on my Exchange server
    5. On my exchange server, checked the "this backend server is a http" option

    port changes - Exchange1:100-5000; Exchange1:6001-6002; Exchange1.domain.LOCAL:6001-6002;
    DC/GC:6001-6002;DC/GC.domain.LOCAL:6001-6002;WEBMAIL.domain.CO.UK:6001-6002;Exchange1:6004;
    Exchange1.domain.LOCAL;DC/GC:6004;DC/GC.domain.LOCAL:6004;webmail.domain.CO.UK:6004;exchange:593;
    exchange1.domain.LOCAL:593;DC/GC:593;DC/GC.domain.LOCAL:593;WEBMAIL.domain.CO.UK:593

    I've then run the remote connectivity analyser which passes everything with the exception of the below:

    Attempting to ping RPC proxy webmail.domain.co.uk.
      RPC Proxy can't be pinged.
     
    Additional Details
     
    An unexpected network-level exception was encountered. Exception details:
    Message: The remote server returned an error: (500) Internal Server Error.
    Type: Microsoft.Exchange.Tools.ExRca.Extensions.MapiTransportException
    Stack trace:
       at Microsoft.Exchange.Tools.ExRca.Extensions.MapiRpcTestClient.PingProtocolProxy(String endpointIdentifier)
       at Microsoft.Exchange.Tools.ExRca.Tests.MapiPingProxyTest.PerformTestReally()
    Exception details:
    Message: The remote server returned an error: (500) Internal Server Error.
    Type: System.Net.WebException
    Stack trace:
       at System.Net.HttpWebRequest.GetResponse()
       at RpcPingLib.RpcPing.PingProxy(String internalServerFqdn, String endpoint)
       at Microsoft.Exchange.Tools.ExRca.Extensions.MapiRpcTestClient.PingProtocolProxy(String endpointIdentifier)

    Elapsed Time: 4640 ms

    I have tried to connect an outlook client and it connection status sits at "connecting"  in addition, I have ensured that I have Basic and NTLM setup on my IIS server

    Anyone have any ideas what I could be doing wrong?

    Thursday, February 18, 2016 12:18 PM

Answers