locked
Application remains minimised in taskbar RRS feed

  • Question

  • This is an infrequent problem.

    The application is running in a Server 2008 R2 Remote Desktop Session as part of a SBS 2008 Domain

    When user goes to open (activate) a form(winform) it appears in the taskbar, in focus, but does not display.

    It is minimised in the taskbar and can not be restored. Once this happens it can not be restored at anytime.

    Logging out of session and back on again makes no difference, however another user in their own RDS session can open the form as usual.

    Upon deleting the user from the Active Directory and then adding the user afresh with a new profile the problem goes away.

    We are using redirected folders policy with roaming profiles.

     

    This problem does not seem to happen when not running in RDS.

     

    Many Thanks for any help, direction you could provide


    18/05/2011

    I've found the reason. The form is actually displaying but the location setting for the form has been reset to 32000,-32000. Windows has done this by itself for some reason? As a work around i've added code to check the location setting and reset this if necessary.
    Looking on the internet there seems to be many instances of this happening to various programs include microsoft ones.
    Does anyone know if there is a reason for this happening that we should be aware off when writing applications?

    Thank you all for your input.

    • Edited by WheelsNZ Wednesday, May 18, 2011 12:38 AM Solved
    Monday, May 16, 2011 2:06 AM

Answers

  • I've found the reason. The form is actually displaying but the location setting for the form has been reset to 32000,-32000 (off screen). Windows has done this by itself for some reason? As a work around i've added code to check the location setting and reset this if necessary.
    Looking on the internet there seems to be many instances of this happening to various programs include microsoft ones.
    Does anyone know if there is a reason for this happening that we should be aware off when writing applications?


    • Marked as answer by WheelsNZ Thursday, May 19, 2011 8:27 PM
    Wednesday, May 18, 2011 12:39 AM

All replies

  • Hi,

     

     

     

    Can you please help to confirm the following questions to narrow down this issue?

     

     

    1.       Does this issue happen when you’re running some special application at a meantime?

     

    2.       Do you encounter the same issue when using the local profile?

     

    3.       Can other application work normally when this issue happens?

     

    4.       Have you got any related event log on the server side?

     

     

    Thanks.

    Tuesday, May 17, 2011 3:33 AM
  • I've found the reason. The form is actually displaying but the location setting for the form has been reset to 32000,-32000 (off screen). Windows has done this by itself for some reason? As a work around i've added code to check the location setting and reset this if necessary.
    Looking on the internet there seems to be many instances of this happening to various programs include microsoft ones.
    Does anyone know if there is a reason for this happening that we should be aware off when writing applications?


    • Marked as answer by WheelsNZ Thursday, May 19, 2011 8:27 PM
    Wednesday, May 18, 2011 12:39 AM