none
Are Domain Admin credentials required to run MAP 4.0? RRS feed

  • Question

  • I have installed and run MAP toolkit 4.0 successfully as a member of domain admins.  Last week, my account was removed from domain admins group and placed in a group that was added to local administrators group on all the machines in the domain.  When I attempt to start the MAP tool, I receive "<domainname>\<username> login failed."  If I have a user that is still a member of domain admins logon to the server for me, the MAP tool starts without any problems.  The getting started guide says the requirement for running inventory and metrics collection is being a member of the local admins group on each machine being processed.  However, since the tool will not even start if I'm not a member of Domain Admins, I have to wonder if local administrator permissions is not enough.  The MAP toolkit is NOT installed on a domain controller.  It is installed on a Windows Server 2003 SP2 member server.  Anyone seen this behavior before?

    TIA,
    Tom
    Wednesday, January 20, 2010 3:28 PM

All replies

  • Tom,


    You are correct in thinking that if you are part of the local administrators group on all the machines in the domain MAPS will work correctly.

    Are you saying it won't even launch the application for you now with that change in your account?


    It launches for me and I have never been a domain admin, only local...

    I'm wondering if you may have encountered this because it was installed as a "different" user...?

     

    Wednesday, January 20, 2010 5:14 PM
  • Hi Eric,
    Thank you for the quick response.
    Yes, the application does not launch when not a member of domain admins.  ANY domain admin can start the application.  Anyone who is not a member of domain admins cannot start the application.  The first time this happened, I thought the machine locked-up, but within two minutes or so I had 8 or 9 'logon failed' dialog boxes popup.  This behavior is true for the six or seven accounts I've tried so far.

    I hope this clarifies the situation.  What I was not allowed to do was to logon to the MAP server as 'the' local administrator.

    Thanks,
    Tom
    Wednesday, January 20, 2010 10:45 PM
  • Thanks for your investigation into this issue.  I will attempt to reproduce this here in a lab so that we can get a good debugging log for our devs…

     

    In the meanwhile, I would suggest uninstalling MAPS completely and then reinstalling making sure you are logged in with that account, with local administrator rights, you were planning on using to run MAPS.

    Wednesday, January 20, 2010 11:13 PM
  • Thanks for the help.  The situation has been resolved.  Adding MAP account to the SQL Login group has solved problem.  Apparently, the client DID NOT add the MAP account to the local administrators group on *all* domain computers.  Sorry to have taken your time.  At least this problem is resolved.

    Best,
    Thomas Walters
    Certified since 1989
    Monday, February 15, 2010 2:30 AM