none
outlook server proxy server setting keeps resetting. RRS feed

  • Question

  • We moved from one exchange 2007 server (EXCG001) to another exchange 2007 server (EXCH001). Now the reason for this change was mainly as part of migration to 2013. The old server was on SP1 and we ran into major problems while trying to upgrade to SP3 RU10 for coexistence with Exchange 2013. So we created a new exchange 2007 server (EXCH001) and moved all the mailboxes, and all services. Now we shutdown all the services on the old exchange.

    We checked all services and everything is working OWA, AcctiveSync etc however the RPC over HTTP outlook users show disconnected.

    Our certificates have 
    mail.domain.com
    autodiscover.domain.com
    EXCH001
    EXCH001.domain.local

    For all outlook users RPC over HTTP, the Exchange Server Proxy Settings,

    "Use this URL to connect to my proxy server for Exchange" has "EXCG001.DOMAIN.local" which is our old server.

    Now when we change this to "email.domain.com", the Outlook goes online.

    However, we are running to another problem. everytime the user logs out of outlook and opens it later the setting in "Use this URL to connect to my proxy server for Exchange" reverts to "EXCG001.DOMAIN.local" which is our old server

    My findings are as below

    Get-OutlookProvider

    Name                Server              CertPrincipalName   TTL
    ----                ------              -----------------   ---
    EXCH                EXCG001.platcor... email.domain.com  1
    EXPR                EXCG001.platcor... msstd:email.domain... 1
    WEB                 EXCG001.platcor... email.domain.com  1

    The server above is the old server. 

    How do we change this to the new server?

    PS] C:\Windows\system32>get-autodiscovervirtualdirectory | fl


    Name                            : Autodiscover (Default Web Site)
    InternalAuthenticationMethods   : {Basic, Ntlm, WindowsIntegrated}
    ExternalAuthenticationMethods   : {Basic, Ntlm, WindowsIntegrated}
    BasicAuthentication             : True
    DigestAuthentication            : False
    WindowsAuthentication           : True
    MetabasePath                    : IIS://EXCH001.DOMAIN.local/W3SVC/1/ROOT/Au
                                      todiscover
    Path                            : E:\Program Files\Microsoft\Exchange Server\Cl
                                      ientAccess\Autodiscover
    ExtendedProtectionTokenChecking : None
    ExtendedProtectionFlags         : {}
    ExtendedProtectionSPNList       : {}
    Server                          : EXCH001
    InternalUrl                     :
    ExternalUrl                     :
    AdminDisplayName                :
    ExchangeVersion                 : 0.1 (8.0.535.0)
    DistinguishedName               : CN=Autodiscover (Default Web Site),CN=HTTP,CN
                                      =Protocols,CN=EXCH001,CN=Servers,CN=Exchange
                                       Administrative Group (FYDIBOHF23SPDLT),CN=Ad
                                      ministrative Groups,CN=DOMAIN,CN=Microsoft
                                      Exchange,CN=Services,CN=Configuration,DC=plat
                                      corp,DC=local
    Identity                        : EXCH001\Autodiscover (Default Web Site)
    Guid                            : f723e3bb-0e15-4e25-a331-6eca67aaa499
    ObjectCategory                  : DOMAIN.local/Configuration/Schema/ms-Exch-A
                                      uto-Discover-Virtual-Directory
    ObjectClass                     : {top, msExchVirtualDirectory, msExchAutoDisco
                                      verVirtualDirectory}
    WhenChanged                     : 3/10/2015 1:26:45 PM
    WhenCreated                     : 3/10/2015 1:26:37 PM
    OriginatingServer               : PGCAD01.DOMAIN.local
    IsValid                         : True

    In the above there is no entry for internal and external URL? can this be a reason for the RPC over HTTP users in outlook not to work?

    [PS] C:\Windows\system32>get-clientaccessserver | fl


    Name                           : EXCG001
    OutlookAnywhereEnabled         : True
    AutoDiscoverServiceCN          : EXCG001
    AutoDiscoverServiceClassName   : ms-Exchange-AutoDiscover-Service
    AutoDiscoverServiceInternalUri : https://email.DOMAIN.com/autodiscover/autodi
                                     scover.xml
    AutoDiscoverServiceGuid        : 77378f46-2c66-4aa9-a6a6-3e7a48b19596
    AutoDiscoverSiteScope          : {Default-First-Site-Name}
    IsValid                        : True
    OriginatingServer              : PGCAD01.DOMAIN.local
    ExchangeVersion                : 0.1 (8.0.535.0)
    DistinguishedName              : CN=EXCG001,CN=Servers,CN=Exchange Administrat
                                     ive Group (FYDIBOHF23SPDLT),CN=Administrative
                                     Groups,CN=DOMAIN,CN=Microsoft Exchange,CN=Se
                                     rvices,CN=Configuration,DC=DOMAIN,DC=local
    Identity                       : EXCG001
    Guid                           : 0ffe17e1-1611-4d14-8648-547a385652a0
    ObjectCategory                 : DOMAIN.local/Configuration/Schema/ms-Exch-Ex
                                     change-Server
    ObjectClass                    : {top, server, msExchExchangeServer}
    WhenChanged                    : 6/29/2015 12:25:28 AM
    WhenCreated                    : 7/15/2010 8:52:15 AM

    Name                           : EXCH001
    OutlookAnywhereEnabled         : True
    AutoDiscoverServiceCN          : EXCH001
    AutoDiscoverServiceClassName   : ms-Exchange-AutoDiscover-Service
    AutoDiscoverServiceInternalUri : https://email.DOMAIN.com/autodiscover/autodi
                                     scover.xml
    AutoDiscoverServiceGuid        : 77378f46-2c66-4aa9-a6a6-3e7a48b19596
    AutoDiscoverSiteScope          : {Default-First-Site-Name}
    IsValid                        : True
    OriginatingServer              : PGCAD01.DOMAIN.local
    ExchangeVersion                : 0.1 (8.0.535.0)
    DistinguishedName              : CN=EXCH001,CN=Servers,CN=Exchange Administrat
                                     ive Group (FYDIBOHF23SPDLT),CN=Administrative
                                     Groups,CN=DOMAIN,CN=Microsoft Exchange,CN=Se
                                     rvices,CN=Configuration,DC=DOMAIN,DC=local
    Identity                       : EXCH001
    Guid                           : 75ba12ba-6f1f-4bb4-8526-ad58e05b9abc
    ObjectCategory                 : DOMAIN.local/Configuration/Schema/ms-Exch-Ex
                                     change-Server
    ObjectClass                    : {top, server, msExchExchangeServer}
    WhenChanged                    : 7/3/2015 12:43:19 AM
    WhenCreated                    : 3/10/2015 1:20:48 PM

    In the above the entries of both and old server is showing. Do we need to remove the old server entry? How?

    Will this help in the Exchange Server Proxy settings from not reverting and outlook users to work.


    Friday, July 3, 2015 12:04 PM

Answers

  • Hi,

    what about chaning Outlook anywhere URL from EXCG001.DOMAIN.local to email.domain.com?

    https://technet.microsoft.com/en-us/library/aa996902(v=exchg.80).aspx

    M.


    • Edited by MStoppl Friday, July 3, 2015 12:13 PM
    • Marked as answer by sphilip14 Thursday, July 9, 2015 9:50 AM
    Friday, July 3, 2015 12:13 PM
  • Hi,

    I noticed the namespaces in your certificate include mail.domain.com and autodiscover.domain.com. Please make sure both two namespaces are pointed to your new Exchange server internally and externally.

    Then we can do the following settings:
    1. Autodiscover service:
    Set-ClientAccessServer -Identity NewExch07 -AutodiscoverServiceInternalUri https://autodiscover.domain.com/autodiscover/autodiscover.xml
    2. Outlook Anywhere service:
    Set-OutlookAnywhere -Identity "NewExch07\Rpc (Default Web Site)" -ExternalHostName mail.domain.com -ClientAuthenticationMethod Basic -IISAuthenticationMethods Basic,Ntlm
    3. Outlook Provider:
    Set-OutlookProvider EXPR -CertPrincipalName msstd:mail.domain.com
    Set-OutlookProvider EXCH -CertPrincipalName msstd:mail.domain.com

    Regards,


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Winnie Liang
    TechNet Community Support

    • Marked as answer by sphilip14 Thursday, July 9, 2015 9:50 AM
    Monday, July 6, 2015 2:15 AM
    Moderator

All replies

  • Hi,

    what about chaning Outlook anywhere URL from EXCG001.DOMAIN.local to email.domain.com?

    https://technet.microsoft.com/en-us/library/aa996902(v=exchg.80).aspx

    M.


    • Edited by MStoppl Friday, July 3, 2015 12:13 PM
    • Marked as answer by sphilip14 Thursday, July 9, 2015 9:50 AM
    Friday, July 3, 2015 12:13 PM
  • Hi,

    I noticed the namespaces in your certificate include mail.domain.com and autodiscover.domain.com. Please make sure both two namespaces are pointed to your new Exchange server internally and externally.

    Then we can do the following settings:
    1. Autodiscover service:
    Set-ClientAccessServer -Identity NewExch07 -AutodiscoverServiceInternalUri https://autodiscover.domain.com/autodiscover/autodiscover.xml
    2. Outlook Anywhere service:
    Set-OutlookAnywhere -Identity "NewExch07\Rpc (Default Web Site)" -ExternalHostName mail.domain.com -ClientAuthenticationMethod Basic -IISAuthenticationMethods Basic,Ntlm
    3. Outlook Provider:
    Set-OutlookProvider EXPR -CertPrincipalName msstd:mail.domain.com
    Set-OutlookProvider EXCH -CertPrincipalName msstd:mail.domain.com

    Regards,


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Winnie Liang
    TechNet Community Support

    • Marked as answer by sphilip14 Thursday, July 9, 2015 9:50 AM
    Monday, July 6, 2015 2:15 AM
    Moderator