locked
USB drive access is blocked RRS feed

  • Question

  • My machine is connected to my office network and i have local admin privileges, i can install anything and i can change/give  permissions to any one to any drive. But, when i insert my USB drive i am not able to access it, when i click on it, it says "Removable disk(E:) Access is denied"

    I have also tried unplugging my network cable and logged in as a local user (without logging in to the office network), but still i am not able to connect my USB to machine. 

    I have also tried regedit->USBSTOR->3(changing number), but no luck.

    Any ways to overcome it? or is there any other ways to use my USB on my machine?

    Tuesday, December 3, 2013 11:49 AM

Answers

  • 1. Once you change the USBSTOR value,try to execute below command on CMD.
    c:\>gpupdate /force

    2. Also, Please check the security permission on below files (your account needs to have full control) :
    %SystemRoot%\Inf\Usbstor.pnf
    %SystemRoot%\Inf\Usbstor.inf

    3. Unplug your USB 

    Go to run and type gpedit.msc 

    Navigate to computer configuration -> Administrative Templates->System, and then select Removable Storage Access in the left column 

    on the right side 

    you may find something like 

    Removable Disks: Deny execute access,deny write,deny read access, 
    all removable storage deny

    open them and disable all these four options. 

    Plug in your USB and check.
    Tuesday, December 3, 2013 3:56 PM

All replies

  • 1. Once you change the USBSTOR value,try to execute below command on CMD.
    c:\>gpupdate /force

    2. Also, Please check the security permission on below files (your account needs to have full control) :
    %SystemRoot%\Inf\Usbstor.pnf
    %SystemRoot%\Inf\Usbstor.inf

    3. Unplug your USB 

    Go to run and type gpedit.msc 

    Navigate to computer configuration -> Administrative Templates->System, and then select Removable Storage Access in the left column 

    on the right side 

    you may find something like 

    Removable Disks: Deny execute access,deny write,deny read access, 
    all removable storage deny

    open them and disable all these four options. 

    Plug in your USB and check.
    Tuesday, December 3, 2013 3:56 PM
  • Agreed with Amarprasad. Policies can be implemented using GP's.

    Arnav Sharma | Facebook | Twitter Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Saturday, December 14, 2013 2:10 PM
  • I have tried this and this din't work for me..
    Thursday, December 19, 2013 2:22 AM