locked
Unable to move folder RRS feed

  • Question

  • I am using windows 7 home premium.

    I have a folder on my desktop that I created. Whenever I try to move it I get a popup saying "you need permission to perform this action, you require permission from (my own name) to make changes to this file".

    I've done the following: right clicked > properties > security > advanced > owner and made myself the owner. It still does not work.



    • Edited by jering Tuesday, December 17, 2013 1:48 PM
    Tuesday, December 17, 2013 1:45 PM

Answers

  • Hi,

    Try getting the ownership of the folder in this way:

    Right-Click the folder -> Properties -> Security tab -> Advanced button -> Owner tab -> Edit button -> Select your user account -> Activate Replace owner on subcontainers and objects.

    When done, close all properties windows and open Properties again -> Security tab -> Advanced button -> Permissons tab -> Change Permissons button -> Add your user account and select Replace all child object.

    Sometimes, Malicious programs can affect the permission settings.

    Go to the Microsoft Safety Scanner webpage to download the scanner and then follow the instructions on the screen.

    http://www.microsoft.com/security/scanner/en-us/default.aspx

    If it not work, please try temporarily disable the UAC and see whether you can move the folder.

    Control Panel>Action Center>scroll down to User Account Control under the security section>select Change settings>move the slider to the Never notify.

    Also, we can test in safe mode.

    Restart the computer>press F8 before the windows logo appears.

    Hope this helps,


    Ada Liu
    TechNet Community Support

    • Marked as answer by Karen Hu Tuesday, January 7, 2014 7:42 AM
    Wednesday, December 18, 2013 3:56 PM
  • Hi,

    The folder is probably locked. You may try deleting while in Safe Mode as Cyber_Defend_Team mentioned.

    I also would like to suggest you temporarily disable User Account Control in the control panel and then try deleting again. 

    Or you could run explorer as Administrator and then delete. (Click Start > All Programs > Accessories , right-click Windows Explorer , and click Run as administrator.) 

    Meanwhile, I suggest you check the permission of this folder again, try to take the ownership of this folder to see what the result is:

    Take Ownership of a File or Folder

    http://technet.microsoft.com/en-us/library/cc753659.aspx

    If you still cannot delete the folder, try to delete the folder from the Command Prompt with administrator privileges. Find Command Prompt in your Start menu by typing 'Command'in the search box, then right-click it and select Run as Administrator. Switch to your folder location and  type 'del foldername.xyz'

    Hope it helps.

    Regards,

    Blair Deng


    Blair Deng
    TechNet Community Support

    • Marked as answer by Karen Hu Tuesday, January 7, 2014 7:42 AM
    Thursday, December 19, 2013 2:02 AM

All replies

  • I am using windows 7 home premium.

    I have a folder on my desktop that I created. Whenever I try to delete/move it I get a popup saying "you need permission to perform this action, you require permission from (my own name) to make changes to this file".

    I've done the following: right clicked > properties > security > advanced > owner and made myself the owner. It still does not work.

    • Merged by arnavsharma Wednesday, December 18, 2013 4:22 PM duplicate
    Tuesday, December 17, 2013 2:02 PM
  • Try restart your PC and attempt to delete it , see if it works.

    If not, restart your PC and press F8 key repeatedly and chose Safemode and boot into Safemode and try delete it.

    Tuesday, December 17, 2013 3:44 PM
  • IF YOUR ARE FINDING DIFFICULT TO DELETE FOLDER GO TO MY SITE IF YOU LIKE THEN CLICK LIKE ON FACEBOOK WEBSITE :http://yadvi.com/unable-to-delete-folder-in-window-os-1

    Tuesday, December 17, 2013 4:34 PM
  • Reboot in last known good config if normal reboot does not work.

    Arnav Sharma | Facebook | Twitter Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Tuesday, December 17, 2013 5:00 PM
  • Hi,

    Try getting the ownership of the folder in this way:

    Right-Click the folder -> Properties -> Security tab -> Advanced button -> Owner tab -> Edit button -> Select your user account -> Activate Replace owner on subcontainers and objects.

    When done, close all properties windows and open Properties again -> Security tab -> Advanced button -> Permissons tab -> Change Permissons button -> Add your user account and select Replace all child object.

    Sometimes, Malicious programs can affect the permission settings.

    Go to the Microsoft Safety Scanner webpage to download the scanner and then follow the instructions on the screen.

    http://www.microsoft.com/security/scanner/en-us/default.aspx

    If it not work, please try temporarily disable the UAC and see whether you can move the folder.

    Control Panel>Action Center>scroll down to User Account Control under the security section>select Change settings>move the slider to the Never notify.

    Also, we can test in safe mode.

    Restart the computer>press F8 before the windows logo appears.

    Hope this helps,


    Ada Liu
    TechNet Community Support

    • Marked as answer by Karen Hu Tuesday, January 7, 2014 7:42 AM
    Wednesday, December 18, 2013 3:56 PM
  • Hi,

    The folder is probably locked. You may try deleting while in Safe Mode as Cyber_Defend_Team mentioned.

    I also would like to suggest you temporarily disable User Account Control in the control panel and then try deleting again. 

    Or you could run explorer as Administrator and then delete. (Click Start > All Programs > Accessories , right-click Windows Explorer , and click Run as administrator.) 

    Meanwhile, I suggest you check the permission of this folder again, try to take the ownership of this folder to see what the result is:

    Take Ownership of a File or Folder

    http://technet.microsoft.com/en-us/library/cc753659.aspx

    If you still cannot delete the folder, try to delete the folder from the Command Prompt with administrator privileges. Find Command Prompt in your Start menu by typing 'Command'in the search box, then right-click it and select Run as Administrator. Switch to your folder location and  type 'del foldername.xyz'

    Hope it helps.

    Regards,

    Blair Deng


    Blair Deng
    TechNet Community Support

    • Marked as answer by Karen Hu Tuesday, January 7, 2014 7:42 AM
    Thursday, December 19, 2013 2:02 AM