none
Could not load OpenGL subsystem

    Question

  • I loved Windows 7 until it failed to load the only game I play (which, incidentally, I play almost religiously).  It's Smokin' Guns, a standalone game based on the Quake3 engine.  When I try to run it I get this output:
    SG 1.0 win-x86 Dec 29 2008
    
    -(SNIPPED: all this was successful)-
    
    ------- Input Initialization -------
    No window for DirectInput mouse init, delaying
    Joystick is not active.
    ------------------------------------
    ----- Client Initialization -----
    ----- Initializing Renderer ----
    -------------------------------
    QKEY building random string
    QKEY could not open qkey for write
    ----- Client Initialization Complete -----
    ----- R_Init -----
    Initializing OpenGL subsystem
    ...initializing QGL
    ...calling LoadLibrary( 'C:\Windows\system32\opengl32.dll' ): succeeded
    ...setting mode 4: 800 600 FS
    ...using desktop display depth of 32
    ...calling CDS: ok
    ...registered window class
    ...created window@0,0 (800x600)
    Initializing OpenGL driver
    ...getting DC: succeeded
    ...GLW_ChoosePFD( 32, 24, 0 )
    ...35 PFDs found
    ...GLW_ChoosePFD failed
    ...GLW_ChoosePFD( 32, 24, 0 )
    ...35 PFDs found
    ...GLW_ChoosePFD failed
    ...failed to find an appropriate PIXELFORMAT
    ...restoring display settings
    ...WARNING: could not set the given mode (4)
    ...setting mode 4: 800 600 FS
    ...using colorsbits of 16
    ...calling CDS: ok
    ...created window@0,0 (800x600)
    Initializing OpenGL driver
    ...getting DC: succeeded
    ...GLW_ChoosePFD( 16, 16, 0 )
    ...35 PFDs found
    ...GLW_ChoosePFD failed
    ...GLW_ChoosePFD( 16, 16, 0 )
    ...35 PFDs found
    ...GLW_ChoosePFD failed
    ...failed to find an appropriate PIXELFORMAT
    ...restoring display settings
    ...WARNING: could not set the given mode (3)
    ...shutting down QGL
    ...unloading OpenGL DLL
    ...assuming '3dfxvgl' is a standalone driver
    ...initializing QGL
    ...calling LoadLibrary( 'C:\Windows\system32\3dfxvgl.dll' ): failed
    ...shutting down QGL
    ----- CL_Shutdown -----
    RE_Shutdown( 1 )
    -----------------------
    GLW_StartOpenGL() - could not load OpenGL subsystem
    
    
    My hardware is very old (Dell Optiplex 170L desktop with integrated Intel graphics), but before I upgraded to the Windows 7 RC, I had XP installed and the game ran perfectly.  My video driver is up-to-date (though it was broken when I first installed the RC).  Microsoft seems to have neglected support for OpenGL in Windows 7?  Please tell me they'll put it in eventually; the reason I'm using the 7 RC is because XP crapped out on me; I really don't have much to go back to.
    Monday, June 8, 2009 8:02 PM

Answers

  • I have heard selective reports of OpenGL not working properly in the current Windows 7 ATi drivers. It's possible that the implementation has changed in Windows 7, and driver manufacturers have yet to catch up.

    Have you tried running the game in compatibility mode for Windows XP? To do this, right click on the program .exe and open the Properties menu, then navigate to the compatibility tab and select "Run this program in compatibility mode for..."
    -Alex
    Thursday, June 11, 2009 5:16 PM

All replies

  • I loved Windows 7 until it failed to load the only game I play (which, incidentally, I play almost religiously).  It's Smokin' Guns, a standalone game based on the Quake3 engine.  When I try to run it I get this output:
    SG 1.0 win-x86 Dec 29 2008
    
    
    
    -(SNIPPED: all this was successful)-
    
    
    
    ------- Input Initialization -------
    
    No window for DirectInput mouse init, delaying
    
    Joystick is not active.
    
    ------------------------------------
    
    ----- Client Initialization -----
    
    ----- Initializing Renderer ----
    
    -------------------------------
    
    QKEY building random string
    
    QKEY could not open qkey for write
    
    ----- Client Initialization Complete -----
    
    ----- R_Init -----
    
    Initializing OpenGL subsystem
    
    ...initializing QGL
    
    ...calling LoadLibrary( 'C:\Windows\system32\opengl32.dll' ): succeeded
    
    ...setting mode 4: 800 600 FS
    
    ...using desktop display depth of 32
    
    ...calling CDS: ok
    
    ...registered window class
    
    ...created window@0,0 (800x600)
    
    Initializing OpenGL driver
    
    ...getting DC: succeeded
    
    ...GLW_ChoosePFD( 32, 24, 0 )
    
    ...35 PFDs found
    
    ...GLW_ChoosePFD failed
    
    ...GLW_ChoosePFD( 32, 24, 0 )
    
    ...35 PFDs found
    
    ...GLW_ChoosePFD failed
    
    ...failed to find an appropriate PIXELFORMAT
    
    ...restoring display settings
    
    ...WARNING: could not set the given mode (4)
    
    ...setting mode 4: 800 600 FS
    
    ...using colorsbits of 16
    
    ...calling CDS: ok
    
    ...created window@0,0 (800x600)
    
    Initializing OpenGL driver
    
    ...getting DC: succeeded
    
    ...GLW_ChoosePFD( 16, 16, 0 )
    
    ...35 PFDs found
    
    ...GLW_ChoosePFD failed
    
    ...GLW_ChoosePFD( 16, 16, 0 )
    
    ...35 PFDs found
    
    ...GLW_ChoosePFD failed
    
    ...failed to find an appropriate PIXELFORMAT
    
    ...restoring display settings
    
    ...WARNING: could not set the given mode (3)
    
    ...shutting down QGL
    
    ...unloading OpenGL DLL
    
    ...assuming '3dfxvgl' is a standalone driver
    
    ...initializing QGL
    
    ...calling LoadLibrary( 'C:\Windows\system32\3dfxvgl.dll' ): failed
    
    ...shutting down QGL
    
    ----- CL_Shutdown -----
    
    RE_Shutdown( 1 )
    
    -----------------------
    
    GLW_StartOpenGL() - could not load OpenGL subsystem
    
    
    
    
    My hardware is very old (Dell Optiplex 170L desktop with integrated Intel graphics), but before I upgraded to the Windows 7 RC, I had XP installed and the game ran perfectly.  My video driver is up-to-date (though it was broken when I first installed the RC).  Microsoft seems to have neglected support for OpenGL in Windows 7?  Please tell me they'll put it in eventually; the reason I'm using the 7 RC is because XP crapped out on me; I really don't have much to go back to.

    Hello, Reviewing your log file it would seem there is driver that is failing to load on your machine.  3dfxvgl.dll is failing to load via loadlibrary.   Please make sure you have this binary on your machine at the path specified in your log file.

    ·         LoadLibrary( 'C:\Windows\system32\3dfxvgl.dll' ): failed

     

    Note that I’m curious.  Is this binary on your machine?

    Do you have 3dfx interactive hardware in your machine?

    Open GL is still supported.  This seems to be a configuration related issue based on your log file.  

     

    Note that Windows 7 ships with OpenGL32.DLL and it loaded successfully in your application log.

     

    ·         ...calling LoadLibrary( 'C:\Windows\system32\opengl32.dll' ): succeeded

     

    Thank you.

     

    Jeff Dailey
    Principal Escalation Engineer
    Microsoft Platforms Global Escalation Services

    Monday, June 8, 2009 8:29 PM
  • Hello,

    looks like a "phantom device" problem to me. The integrated Intel graphics adapter surely doesn't need any "3dfxvgl.dll" (a standalone driver for Voodoo2 cards from the past). May be this is a rest of a previous installation. The system looks for that driver, assuming that it should use it instead of the default OpenGL32, doesn't find it and refuses to proceed. To check that, it may be useful to go to Device Manager -> View, select "show hidden devices", and if there is some display device that shouldn't be there, uninstall it. If this was the source of the problem, Windows will not look for the suspicious driver anymore and use OpenGL32 as normal.


    Mobile AMD64 3000+, VIA Apollo K8T800 chipset, 1 G RAM, ATIRadeonMobility 9700, 20x DVDRW, C:XPSP3 (55G),D:WIN7 (25G),F:DATA (250G)
    Tuesday, June 9, 2009 9:38 AM
  • Thank you for your suggestions.  I do have the 3dfxvgl.dll in my System32 folder, and it did not seem to make a difference.  There are no hidden graphic controller devices installed.  I've asked around everywhere and from what I can gather from responses, Windows has pulled a little of its OpenGL support for older versions and hardware (which I have both) and expected graphics manufacturers to pick up the slack if they so choose.  Intel, apparently, did not-- at least not for older hardware like mine.  I'm currently digging around to find some other form of (non-Intel) graphics hardware in order to set it up and test that theory.

    The main problem here seems to be the GLW_ChoosePFD action.  I don't really know what that means.  What I can gather, though, is that OpenGL is recognized and started, but some core part of it fails.  Specifically, finding a pixelformat... whatever that is.  3dfxvgl.dll seems to be a fallback, but I don't think it was ever meant to be used by the game's designers (they modified Quake 3 code, so they might not have continued support for it).

    Not sure if I made it clear in the OP, but nothing has changed about my computer setup.  A summary of the problem is that when I had XP, OpenGL worked fine; now I have 7, and it does not.  While I had assumed it was fault on the part of Windows 7, it now seems to me that the problem lies with Intel's lack of legacy support... which, I suppose, I cannot blame them too much for.  Legacy support is a luxury I have grown rather used to.  Still, I would think with such economy people would be trying to wax life out of their old PCs like I am, and would greatly appreciate it.

    Anyways, I hate to just go on about a problem.  I'd like to also note that I'm enjoying my Windows 7 experience overall and really appreciate the work put into it.  Thanks.
    Thursday, June 11, 2009 4:20 AM

  • Out of curiousity, what DirectX version did you have on the XP machine?


    I have no idea how to solve Glide problems on a platform like this. As far as I recall, it was pretty solid back
    in the days. I had a SLI Voodo2 setup. Aah.. the memories. :)

    Hmm.. was Glide 32 bit or 16 bit system? I don't remember. Maybe that is the problem?
    Thursday, June 11, 2009 6:16 AM
  • I have heard selective reports of OpenGL not working properly in the current Windows 7 ATi drivers. It's possible that the implementation has changed in Windows 7, and driver manufacturers have yet to catch up.

    Have you tried running the game in compatibility mode for Windows XP? To do this, right click on the program .exe and open the Properties menu, then navigate to the compatibility tab and select "Run this program in compatibility mode for..."
    -Alex
    Thursday, June 11, 2009 5:16 PM
  • I faced the same problem with the game Jedi Knight II: Jedi Outcast (which uses the Quake 3 engine).

    Compatibility modes did not help, but updating graphics adapter drivers (I have Nvidia Geforce 7900 GTO) to the latest Windows 7 64-bit drivers fixed the problem. Now the game works without any need to use compatibility modes.
    Tuesday, July 7, 2009 1:18 AM
  • I had a problem with opengl system opening for ID games on windows XP.  The way I solved it was to update my chipset driver.  If you try to update the drivers for your display adaptor using the windows tool, it will tell you that you have to most recent version of the driver, but it WILL NOT find the outdated chipset driver.

     

    In order to update your chipset driver, you need to go to your video card manufacturer site to get it.  In my case it was intel.  Once I updated chipset driver, the games ran fine.

     

    HTH

    Sunday, November 14, 2010 4:09 PM
  • I had the same problem, did a search and found this solution that worked for me:

    Open the q3config.cfg file in notepad and change the seta r_mode value to 6 (or to 4).

    The q3config.cfg is located in the baseq3 folder in game directory.

    Saturday, February 12, 2011 2:30 PM