locked
Exchange 2003 - Users need to change "From" address RRS feed

  • Question

  • I have an Exchange 2003 Standard server (SBS 03).  I have two corporations that operation out of the same office (same owners).  Some people work for Corp1, some work for Corp2, and several work for both.  Our "primary e-mail domain" is user@corp1.com.  I've added the domain for corp2.com to the server and it works just fine.  I need to be able to have the people who work for both companies, be able to switch their "from" e-mail address between Corp1 and Corp2 so that people who receive their e-mail aren't confused.  Several of the customers aren't familiar with the "other" company.  I've tried using the "From" line in Outlook 2007 but when I do this, the e-mail never goes out and is never delivered.  Incoming e-mails for both CORP1 and CORP2 work fine (they are on separate domains).  I know that I can change the "default" FROM address on the server and that works fine for the people who only work for CORP1 or CORP2.  However, I need the users to be able to flip-flop the domains with Outlook.   I know outlook can do this but something on the server is not allowing.  Thanks for your help!

    Saturday, March 19, 2011 10:42 PM

Answers

  • Not familiar with SBS, but typically when you don't see the security tab in Active Directory Users and computers its because you don't have advanced features selected.

    Open ADUC, view menu, advanced features. Again this is where you would do it in ADUC, not sure where it would be in the SBS console so you will have to find it.


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com
    • Marked as answer by Novak Wu Friday, March 25, 2011 1:40 AM
    Tuesday, March 22, 2011 3:16 PM

All replies

  • You can't select which SMTP proxy to use when sending from a single account, You will need to create two mailboxes for this singe user, have the user opened this mailbox as a secondary mailbox in outlook, and grant the user rights to send as the second mailbox.

    There are third party tools as well.


    ChooseFrom for Microsoft® Exchange 2000/2003

    http://www.ivasoft.biz/choosefrom.shtml


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com
    Saturday, March 19, 2011 10:56 PM
  • James,

     

    Thank you for your reply.  I tried the "dual-account" method.  However, when the message is received, it says "Sent on Behalf of USER2".  Obviously this is less desirable than having the wrong address as it draws even more attention to the addressing issue.

     

    Is this problem worked out in Exchange 2010 as we're moving to that version in July.

     

    Thanks

    Scott


    Scott Heisler IT Manager Bronx/Diba/Luichiny Shoes www.luichiny.com
    Monday, March 21, 2011 6:43 AM
  • Remove the delegate. Open outlook for the second account, tools menu, options, delgate, remove the user1.

    Now open active directory userrs and computers. Find user2, go to security tab, add user 1 and allow send as. After you do this you may need to give it some time for Exchange to update the rights.  


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com
    Monday, March 21, 2011 1:35 PM
  • Unfortunately, this was not much help.  I don't have a "Security Tab" as you indicated in your instructions.  I further could not find any "send as" settings in the tabs that I do have.  Remember, this is an SBS 2003 server.

     


    Scott Heisler IT Manager Bronx/Diba/Luichiny Shoes www.luichiny.com
    Tuesday, March 22, 2011 2:36 PM
  • Not familiar with SBS, but typically when you don't see the security tab in Active Directory Users and computers its because you don't have advanced features selected.

    Open ADUC, view menu, advanced features. Again this is where you would do it in ADUC, not sure where it would be in the SBS console so you will have to find it.


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com
    • Marked as answer by Novak Wu Friday, March 25, 2011 1:40 AM
    Tuesday, March 22, 2011 3:16 PM