none
ZTIWipeDisk hangs during LiteTouch replace TS RRS feed

  • Question

  • Hi everyone,

    This has happened on numerous Dell machines that I have tested it on.  I created a blank Replace TS and disabled Capture User State and Backup.  I put WipeDisk=True in my customsettings.ini.  I have the LiteTouch ISO mounted to a USB stick.  I run it on a machine, executing this TS.  When it gets to the Wipe Disk action, it sits at the progress bar and the disk light goes solid for about 10 seconds.  Then the disk light does nothing (does not light up at all).  I've wait for 6-8 hours just to see if the progress bar moves, it does not. 

    Oddly, if I try to boot the machine it says "operating system not found" (yes, there was one previously).  Also weird, if I hit f8 and run DISKPART, I can still see the contents of the HD which include my user folder (so clearly the format didn't work).

    What am I doing wrong here?  I've read through a number of threads that talk about WinPE driver problems, but my drivers come directly from the Dell site for WinPE 5.0.  I even have the drivers broken out for x64 and x86.  Also read in a few threads that this might have something to do with UEFI or secureboot?  I don't really buy that since I can see the disk via DISKPART list disk.

    Any ideas?  Any help is appreciated.  Thanks.

    Friday, January 9, 2015 11:09 PM

All replies

  • Did you look at the bdd.log file? It should show what commands were running. 
    Either MDT didn't clean the correct disk, or the commands were issued correctly, and there may be a problem with your storage controller driver.
    If you need help, please copy the bdd.log file to a public site like onedrive and copy the link here.

    Keith Garner - Principal Consultant [owner] - http://DeploymentLive.com

    Sunday, January 11, 2015 6:42 PM
    Moderator
  • Thanks for the reply.  

    After looking at the bdd.log I think I see what the problem is.  It's trying to run the command "cmd /c format c: /fs:ntfs /p:3".  However, when I run a wmic query for drivetype=3, it returns C, E, and X.  The partition that has the OS (that I want to format) is E.  I can't actually CD to C, so I'm guessing that maybe this is the GPT partition? The wmic query indicates that C is not an NTFS partition, so I suppose that I could modify the query in ZTIWipeDisk so FileSystem=NTFS.  That should filter out the C drive so instead E will get formatted.

    Does this seem like a logical solution or am I missing something?

    Monday, January 12, 2015 3:24 PM
  • I changed the query to read:

    SELECT * from Win32_LogicalDisk WHERE DriveType = 3 and FileSystem = 'NTFS'"

    I'm not sure that this solution really solves any problems.  I suspect that the C drive represents the GPT partition which probably got wiped when I ran the TS the first time, although wiped unsuccessfully since the filesystem (wmic result) does not read NTFS for this partition.  That's probably why it said "operating system not found" even though the OS partition was fine.

    In any event, I ran the wipe TS again after the above change to ztiwipedisk on the machine that I was trying to test.  It did the same thing, disk light came on for 10 seconds then stayed off.  Couldn't CD into the E drive at that point - got an access denied.  The TS also appeared to be hung up again.  At that point, WMIC indicated that there was no filesystem on E so I'm guessing that the format did something less than graceful.  

    After manually rebooting and running the TS again, the TS finishes with zero errors, but WMIC query indicates that the E drive is now in some defunct state (just like C) where the filesystem field is blank.

    Is the wipe action widely adopted by MDT users or do people typically use another method to wipe disks?  Or should I backtrack here and try the storage controller driver?  I can't get the bdd.log at this point because the OS partition is not in a readable state.

    Monday, January 12, 2015 4:03 PM
  • Honestly, I'm not sure what's going on here, I can't tell from the descriptoin.

    My first thought is that the Format e: is just taking a *VERY* long time to complete, and that you just need to wait for it to finish, depending on the drive, speed and size, I would literally let it run over the weekend. Or run the same "format E: /fs:ntfs /p:3" command manually to see how long it take.

    It wouldn't surprise me if ZTIWipeDisk does not work on uEFI machines.

    As for who runs ZTIWipeDisk.wsf? Really no body.
    If the machine is just going to be repurporsed, then just do a quick format and reprovision.

    If the machine has sensitive data, then... IMHO you should be using Bitlocker to begin with so the data can't be reused.
    Finally, there are groups of people who feel they need to abide by DOD wipe requirements (Silliness), ZTIWipeDisk will not satisfy those people.


    Keith Garner - Principal Consultant [owner] - http://DeploymentLive.com

    Monday, January 12, 2015 5:50 PM
    Moderator
  • Keith, I'm skeptical of how this would work with UEFI as well.  FWIW, I manually cleaned up the disk with diskpart, recreated the partition and all went well with the deployment.

    You mentioned quick format and reprovision, I assume this gets done under the standard client TS - Format and Partition disk?

    I'm thinking about just modifying ztiwipedisk to include the following:

    list disk
    select disk 0
    clean
    create partition primary
    select partition 1
    active
    format fs=ntfs label="WindowsOS"
    exit

    I think that would satisfy our needs, and like you are saying, a DBAN equivalent is overkill.


    Monday, January 12, 2015 8:47 PM