none
Project server 2013 master project and site with subprojects and subsites RRS feed

  • Question

  • i have a master project and try to create a sub site off the master project site. when I use project pro and publish  and check "Provision the site as a subsite of another project I get an error. I have notice that the target URL changes. so unchecked I get http://sharepoint/pwa/project1. so when I check it the target url becomes http://sharepoint/masterproject/project1 where masterproject is the master. any ideas what I can do to have my sub project be a sub site of my master project. my master is a http://sharepoint/pwa/masterproject. so my subproject should be http://sharepoint/pwa/masterproject/project1

    Tuesday, May 27, 2014 8:19 PM

All replies

  • So what i am getting from your question is

    1. Problem you are getting error while trying to provision a site as subsite of another project, to resolve this we need to know what is the error you are getting ?

    Also when you say URL Changes, what does that means?

    2.  For having your sub projects as part of master project, you should first publish your Master project which would create a project workspace for Master Project and then insert your sub projects within the master project(Or individually) and start publishing your Sub projects and select provision this site as part of Subsite and in there  select your master program name

    Now when you goto the master project site and do view all site content, it should show you both other sub project sites underneathh it


    Thanks | epmXperts | http://epmxperts.wordpress.com




    Wednesday, May 28, 2014 3:06 PM
    Moderator
  • this is what I was saying when the URL changes, so if I don't do a subsite (check the box) I get this

    and so when I check the box provision the site as a sub site of another project, I should get http://sharepointapp1/pwa/2014/subproject2 but I get this

    now the project 2014 is at http://sharepointapp1/pwa/2014

    Thursday, May 29, 2014 1:56 AM
  • Navigate to server settings >>  Project site provisioning settings >> and check the Site URL settings >> Select correct Web Application from the dropdown and save the settings and try again  

    Thanks | epmXperts | http://epmxperts.wordpress.com

    Thursday, May 29, 2014 12:56 PM
    Moderator
  • so it is set right but the check box for "Restrict Project site creation to the default site collection" is checked and grayed out how do I uncheck it?
    • Edited by DCSpooner Thursday, May 29, 2014 3:34 PM clean copied tags
    Thursday, May 29, 2014 3:30 PM
  • Possible causes for Checkbox greyed out would be if you only have one site collection defined within the web app, or you are running in Sharepoint permission mode on project server, change that to Project server permissions mode using the powershell then you should be able to change it refer to this http://technet.microsoft.com/en-us/library/ff631142.aspx#section13 

    Thanks | epmXperts | http://epmxperts.wordpress.com

    Thursday, May 29, 2014 4:59 PM
    Moderator
  • would that cause the issue that I am having? the subsite

    yes I only have one site collection

    change it to project server mode what will that cause. will I be able to use AD groups and users?

    Thursday, May 29, 2014 5:39 PM
  • it would be helpful if you can post the snapshot of Site URL settings, i would be able to compare what's in there and why the URL is different in the dialog box, also if you can post the alternate access mapping for the URL if any done in Central Admin  

    Changing to project server security may have implications as you will need to reorganize users for project server security model as it deletes all security related settings :(Yes you can sync project server security groups (in project server permission mode) to AD groups

    http://technet.microsoft.com/en-us/library/fp161361%28v=office.15%29.aspx


    Thanks | epmXperts | http://epmxperts.wordpress.com


    Thursday, May 29, 2014 7:27 PM
    Moderator
  • SharePoint - 80

    http://sharepointapp1 default

    http://sharepoint intarnet

    Tuesday, June 3, 2014 8:07 PM