locked
IE 9 32 bit shortcut now opens up 64 bit IE 9 RRS feed

  • Question

  • Hi.

    I have a problem starting to occur where users IE 9 is starting to open up in IE9 64bit.

    Let me explain.

    When a user selects IE 9 from either the task bar or in the start menu and selects Internet Explorer (NOT the 64bit option), the browser opens in 64bit!

    Looking into the shortcut for the 32 bit IE, the target has been changed to C:\Program Files\Internet Explorer\iexplore.exe from C:\Program Files (x86)\Internet Explorer\iexplore.exe.

    This has started to happen for a number of users here. We are a school and we have internal applications that need the 32bit IE.

    I am starting to think that a Windows Update recently installed has caused this problem, as up until about a month ago, we have never had this problem.

    This update was the last to be applied to IE in July 2013:
    Cumulative Security Update for Internet Explorer 9 for Windows 7 for x64-based Systems (KB2846071) (2846071) (MS13-055)

    Now I can change simply correct this per user basis (well for staff anyway - students are locked down) so the IE target is back to C:\Program Files (x86)\Internet Explorer\iexplore.exe.

    The Operating system we use is WIN 7 Enterprise SP1 64bit.

    Nothing has been changed in any of the Group policy settings that relate to IE.

    It also seems to be profile based, not computer based.

    Looking forward to seeing some suggestion as what to try...

    Thanks

    Monday, August 5, 2013 5:40 AM

All replies

  • Hi,

    check that the workstations have not been automatically updated to IE10.

    Help>About Internet Explorer

    to view the version number.....

    there is no x64 iexplorer.exe for IE10....

    Tools>Internet Options>Advanced tab>check "enable enhanced protected mode"... reboot for full changes to take affect...

    EPM is a hybrid mode of both x84 and x64 rendering and chrome, it will automatically switch between x86 and x64 modes depending upon the content of web pages.

    Please include the full details of any error messages you receive in your questions.


    Rob^_^


    Monday, August 5, 2013 10:55 AM
  • Hi,

    For this issue, you can change the program that windows uses by default to open the IE.

    Let’s try the  following steps and check if the issue can be solved:

    1.Click Start and select Default Programs.

    2.Click Associate a file type or protocol with a program.

    3.Browse to all the extensions where internet explorer is set as default and then click on change.

    4.Now Click on browse and then go to location C:\Program Files (x86)\Internet Explorer\iexplore.exe and select it.

    5.Click OK and then Close.

    Regards,


    Kelvin_Hsu

    TechNet Community Support

    Wednesday, August 7, 2013 5:38 AM
  • determine the bitness of an IE frame (Internet Explorer_server)

    navigator.platform

    Your screenshot shows running IEx86 processes.

    iexplore.exe x64 indicates an IE frame process running in a x64 thread.

    see the MSDN IE developer documentation.


    Rob^_^

    Wednesday, August 7, 2013 11:05 PM
  • Yes...

    IE11-Windows6.1-x64-en-us.exe contains the CAB for the IE11 x64

    IE11-windows6.1-x86-en-us.exe contains the CAB for the IE11 x86

    see your answers to http://social.microsoft.com/Forums/en-US/reportabug/thread/d666c4a5-9cab-4fb0-a18c-0aed8eaffaf5/#02a76490-4160-4126-a12f-6fa9bcb0c8b2


    Rob^_^

    Thursday, August 8, 2013 4:50 AM
  • no x86 addons in a x64 frame... View>Toolbars...

    <plonk> http://social.msdn.microsoft.com/Profile/fl%C3%A4t%D1%95%C9%99m/activity


    Rob^_^

    Thursday, August 8, 2013 6:12 AM