none
All Windows 7 host are pinging to 127.0.0.1.home when host name is used

    Question

  • I have a local area network of four Windows 7 PCs. The PCs are named Term1, Term2, Term3 and Term4.

    Term1 is the server PC.

    When I map to Term1 from the other Terms(2,3 and 4) I always used the command:

    Net use F: \\Term1\c /user:Admin 1234
    

    This worked fine before; now it suddenly refuses to connect this way – I have to replace Term1 with the actual IP address of Term1 for it to work.

    I have tried the following Admin CMD commands:

    1. netsh int ip reset
    2. ipconfig /flushdns

    All of these commands make no difference; I just can't connect using the server name (Term1).

    What I strangely noticed is that from any of the terminals connected to Term1 (using the IP address); if I use, for example, ping Term1, I get an address return of 127.0.0.1.home; this address of 127.0.0.1.home will display if I ping to Term2, Term3 or Term4.

    I cannot find any solution on the web for this strange problem.

    Sunday, December 3, 2017 10:12 AM

All replies

  • hi

    are you  using DHCP or static IP for that four servers?

    try these steps

    in all  pc's go to c:\windows\system32\drivers\etc

    open hosts file and add your Term1 server details followed by Ip address

    example

    #############################

    # localhost name resolution is handled within DNS itself.
    # 127.0.0.1       localhost
    # ::1             localhost

    192.168.1.5  Term1

    #####################

    once done disable IPV6 on all nic's form all PC's

    reboot it and issue will fix..

    please try and reply

    Sunday, December 3, 2017 10:20 AM
  • I am using DHCP ! !  And my Term1 also using a dynamic IP so your solution will not work.
    Sunday, December 3, 2017 10:26 AM
  • Hi,

    Run nslookup -debug in cmd as administrator to see if your dns resolution is fine. It there is something wrong when you enter the command, what is the error message?

    If you haven't configure dns server and it is set on router, it is suggested that you can restart the router to test again.

    In addition, you can use nbtstat command to clear the Netbios cache.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, December 5, 2017 10:20 AM
  • I Have exactly the same problem on several clients sites, all clients respond as 127.0.0.1 and dns names resolve to "pcname".home, originally I thought it was as a result of a dlink router providing dhcp address but I have now found the same issue on client site where there is Huawei routers providing dhcp.
    Tuesday, December 5, 2017 12:41 PM
  • I have a similar issue. I have over 1000 independant business scattered throughout Southern Africa that use my client/server software which maps client to server using DNS Name. Each network has on average 5 PC'S including server PC. This setup has been working excellently for the past 15 years until early this month. Suddenly one business after another began to call me asking what is wrong. When I ask them to ping the server dns from client it now says ping 127.0.0.1 with bytes of data...before it would resolve to the correct IP address and ping the correct ip address.

    The fact that this problem is now being reported by hundreds of independent businesses that have never complained during last 15 years is quite clear Microsoft ran an update that changed things. Please tell me if this update was an intended update or not. If it was an intended update it now means I have to now force all the 1000 independend businesses to change to static IP addresses which is a very expensive mission.

    Looking forward tour urgent feedback. Thank you

    Wednesday, December 13, 2017 3:32 PM
  • I am also pretty sure it's got to do with an undocumented windows update ; don't know which one it is but now many of my client's are also phoning in support for the same problem !  to me the common denominator is that the clients are using windows 7 PC's. 
    Wednesday, December 13, 2017 7:41 PM
  • Has anyone managed to resolved this. I am having exact some issue with Windows 7 PC at spesific customer and funny enough they have a D-LINK adsl router.
    Monday, June 18, 2018 2:11 PM