none
Doesn't work the Configure the Audit Object Access Setting command on SQL 2008 - syntax error RRS feed

  • Question

  • Hello Gents,

    I have a problem to enable audit object access setting in order to capture the SQL 2008 events.

    There is the following command in Usage Tracker Guide:

    ....

    1.     Run the following statement to enable auditing from SQL Server:

    auditpol /set /subcategory:"application generated" /success:enable /failure:enable

    When our customer try to run this statement he got syntax error message.

    Do you have any idea what could be the problem?

    Thank you!

    Wednesday, October 26, 2011 7:32 AM

Answers

  • Sorry for my late reaction, i had to contact MS support finally. The problem was very simple, it is caused different server os language.

    auditpol /set /subcategory:"application generated" /success:enable /failure:enable

     Beetwen the "" have to use the localized parameter in my case it was the Hungarian.    

    Wednesday, November 30, 2011 9:31 AM

All replies

  • Did you copy and paste or type in the command manually? Sometimes special versions of characters are inserted by Word and Outlook.
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, October 27, 2011 12:58 AM
    Moderator
  • Hello Michael,

    Thank you for your answer. You're right, it's good idea, but unfortunately the command was typed manually.

    Any other idea maybe?


    • Edited by hehehun Thursday, October 27, 2011 9:10 AM
    Thursday, October 27, 2011 9:02 AM
  • Can you post a screenshot of the error message? I am unable to get the command prompt to give me a syntax error when I try to reproduce the issue by altering the text. It only gives me a "parameter incorrect" error. What is the OS? 


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, October 28, 2011 9:31 PM
    Moderator
  • Sorry for my late reaction, i had to contact MS support finally. The problem was very simple, it is caused different server os language.

    auditpol /set /subcategory:"application generated" /success:enable /failure:enable

     Beetwen the "" have to use the localized parameter in my case it was the Hungarian.    

    Wednesday, November 30, 2011 9:31 AM