locked
Severe Incompatibility Of USB Memory Sticks or other USB based Memory devices (like cameras) used on Microsoft Windows Vista and Microsoft Windows XP to transport data between the two... RRS feed

  • Question

  • I have used USB memory sticks (SanDisk Cruzer Micro), Voice recorders with USB memory interface (Creative MuVo NX), and cameras (SONY DSC-H9) on my two computers running Microsoft Windows XP, Service Pack 2 and Microsoft Windows Vista, Service Pack 2 respectively. There has not been any problems I have encountered as I have shuffled programs, pictures and other data between these computers, for nearly two years, until mid-March 2011.

    At that time, the computer with the Microsoft Windows XP operating system started to boot partway up, part of the time, missing most of the items on the desktop. After a while, the situation got worse, and I repaired the Microsoft Windows XP operating system on this computer using the installation DVD. The "repaired" system did not work well at all, showing all of the previous symptoms, in a short while. The system was acting as if the main disk drive it is booting from was slowly deteriorating. I have checked all of the BIOS options to see why this has been happening and I have found nothing wrong. I then decided to replace the boot drive with a new one, and I saved the boot drive contents using the software supplied by the one of the drive manufacturers: Maxtor MaxBlast 5. I put the new drive in, and restored the boot drive contents on it, and then I found out that the new drive was acting up exactly like the old drive. The only advantage was the extra space available on the drive. After going through several backup and restore sessions, I checked the computer hardware extensively and found it to be solid with no problems. The only other possibility left was the corruption of the operating system on the original boot disk. This computer was never on the network. It could not be a virus coming through the network hardware which was not ever connected to a network.  I repartitioned the boot drive and re-formatted it, and reloaded the Microsoft Windows XP operating system directly from the installation DVD. I then reloaded every other software I had been using from their original CD/DVD's with the original device drivers. I then connected everything that was connected to this computer only, and booted the machine up. It worked flawlessly. I made a copy of the working boot disk using Maxtor MaxBlast 5 as it had taken me nearly a day to load all of the software and then to make sure that all of them are properly registered and activated. I then plugged in a Memory stick which had been used on the machine with Microsoft Windows Vista. The operating system fell apart just like before within half an hour. I reloaded it faster this time using the saved clean image and put it in the safe mode and then re-formatted the memory stick using its software on this machine. I brought the machine back up. It worked flawlessly until I plugged the memory stick back again. Within minutes of plugging the empty, formatted stick in, the operating system again fell apart. I reloaded it again and tried the camera. The operating system seemed to work with it, but it corrupted several of the pictures, and then it fell apart again. It took nearly all night to check and back up my data disk separate from the boot disk. I lost only four, non-critical, duplicate pictures. I reloaded it back again, and tried the SanDisk Cruzer this time. Again, the operating system fell apart within half an hour. I this time made a boot CD for Maxtor MaxBlast 5, as it was clear that I needed to reload the system everytime some device made it fall apart.

     Finally, after an exhaustive search in two days, I determined that the only devices that made the Microsoft Windows XP fall apart were the ones that were used on the machine that ran Microsoft Windows Vista. This machine is on the network whenever I power the DSL modem up, and it is protected by Microsoft Security Essentials. It is up to date in Vista operating system patches.

     Does anyone know why a USB memory based device used and formatted on Microsoft Windows Vista will break Microsoft Windows XP apart (corrupt it beyond recognition, is a more accurate statement. It actually looks like a software "virus" is eating the system up) even with nothing on the USB memorysystem? It is not even possible to mount it so that one can format it under Microsoft Windows XP. The Microsoft Windows XP system is working flawlessly as long as the USB items without their direct dump software, and that are used on the Microsoft Windows Vista previously, are kept away.

     -- Yekta

    Follow up by Praseetha K, Microsoft Support Engineer, Microsoft Answers Forum:

    Hi Yekta,

     1. Have there been any performance issues on that machine?

     You can perform a full scan on your computer and post back the results. You can refer to the following article to download the Microsoft Safety Scanner.

    Microsoft Safety Scanner

    Note: When you perform the scan, there are chances of losing the data so you can take a backup of the important data before performing the scan.

     I would also advise against inserting any of those drives into any other computer as they are probably all corrupted by whatever is causing this.

     Hope this information is helpful.

    More information by Yekta, in response:

    The machines worked fine before mid-March 2011. They work fine now, after I have isolated and have restored the machine that has been running Microsoft Windows XP Professional. After mid-March 2011, the machine which ran Microsoft Windows XP Professional, started to have an odd trouble with USB sticks, previously used on my machine that ran Microsoft Windows Vista. It would mount them with the "Removable Storage" apparing in the "My Computer" display, but It would not open them, unless they were "re-named". Sometimes this had to be done several times.

    Here is some more information about what has happened as I have repaired the corrupted operating system on the machine that has been running Microsoft Windows XP Professional: After freshly loading the machine completely from the installation DVD and restoring all of the software I have been using from their installations CD's and activating them , and saving the disk image on another internal disk (NOT USB) for ease of retrieval as I have debugged, I have inserted one of the three devices I have mentioned in my message above into a USB 2.0 port on the motherboard. The device seemed to install fine, and its icon did appear in the "My Computer" list as "Removable media" installed as USB disk, but when one clicked on the icon, the windows explorer failed the open the disk with no error message or "hung" computer. It just returned the cursor to normal. After this point, the operating system corrupted slowly as one tried even to "Safely remove" or re-install the device. Pulling the device out did not help anything. At some point, the operating system got really corrupted, and I tried to shut down the system. During the shutdown (which is normally eventless), the screen went "black" and a never-before-seen display appeared. A small pink colored rectangle (about 1.5" on a side on my LCD screen) right at at the center of the display appeared. In the pink rectangle, a rendition of wisps of vapor rising in several layers was depicted in white color. The machine halted, and I shut the power off, before any disk access could happen, and wiped the boot disk clean by re-partitioning it and reformatting it completely. I then reloaded the disk from the saved clean disk image and I have never plugged those USB items into it again. The system has worked flawlessly ever after this.

    Yesterday evening, as I was installing the most recent updates from Microsoft, into my machine that runs Microsoft Windows Vista, Home Premium, Service Pack 2, a similar event happened. I have this system set up so that I can shut the power to the DSL modem at any time. First, I have installed the "Important" updates. When I do this, I wait until the updates are installed, then when the update asks that the machine should be rebooted, I shut the modem power off and I tell the "update" program to proceed. The "update" proceeded to do so, but during the "shutdown", again a never before seen scene appeared briefly on the screen: A pitch-black screen with a small, white rectangle flashed at the center of the lower right-hand quadrant. The white rectangle disappeared in a second and, machine left the the black screen on continuing the shutdown. A little while later, a "twanging" sound (not a beep, it is like a thin piece of metal vibrating at a low pitch) came out of the machine, and machine still continued to shutdown. After the disk is quieted down, I powered the machine down and brought it back up again. It had successfully installed the updates and there was no corruption. I turned the DSL modem on and I then decided to load three of the optional updates all at once. The first of these is an update to the Microsoft Security Essentials, the other two were the .NET updates. After loading the updates, the machine started to install them, but after the first one, it shut the Microsoft Security Essentials "off" all by itself, leaving the machine wide open during the installation of the long ".NET" updates. When I saw this happen in real time, I shut the DSL modem power off, and I tried to bring the Microsoft Security Essentials back on line. Machine slowed immensely, but it was able to sort itself out, and install one of the two ".NET" updates, and It waited too long on the second one. I shut the machine down and went to sleep. In the morning, it came up normally and finished installing the last update.

    The update system does have the "bug" that any loaded update through the regular update system to Microsoft Security Essentials (not through its own update) does shut it down even though the machine is on the network and working on installing other updates which could take a long time to install. Due to operating system priorities, it may be tens of minutes before it is ever turned on, leaving the machine extremely vulnerable to attack by outsiders. Sometimes, it just exits the server and displays a requester to offer to start it, but this almost always happens after an update to it.

    -- Yekta

     Advice by Praseetha, K, Microsoft Support Engineer, Microsoft Answers Forum:

    Hi Yekta,

     Your question is more complex than what is typically answered in the Microsoft Answers forums. It is better suited for the Windows Vista on TechNet. Please post your question in the Windows TechNet Forums.

     

    Saturday, August 13, 2011 10:34 PM

All replies

  • Hi,

    According to your description, I believe this issue is more hardware related. If possible please send the machine to repair shop and test on the chipset and BIOS side.

    Regards,

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Friday, August 19, 2011 8:41 AM
    Moderator
  • The problem was not hardware related.  I have tested this several times and I have determined that the Microsoft Windows XP machine never has corrupted its operating system as long as the USB memory stick and the camera, which have been used on the Microsoft Windows Vista machine on the network, have been kept away from it, and it always corrupted when those two (but not the others that have not been used on the Microsoft Windows Vista machine on the network) have been plugged into it.  I have recently changed the entire camera memory as well as initializing the camera computer to factory defaults.  I had kept the USB memory stick until I found out what had been wrong with it precisely.  

    Today, I needed to use the memory stick.  Knowing what had happened, I carefully plugged it into the Microsoft Windows Vista system which had the most current Microsoft Security Essentials scanner (Version 1.133.1237.0, dated 10/08/2011, 4:21 AM).  It caught the problem instantly.  The memory stick had been modified to have malware (or a software "virus" generator) , surely through the network, as there had been no other access.  Below is the display from the Microsoft Security Essentials, indicating the problem:

     

    It removed the problematic file in half an hour after my "remove" request.  It had to work on it for that long.

    I'll let you know what happens next...

    -- Yekta

     

    Saturday, October 8, 2011 7:30 PM
  • After locating the malware, and after my report of the malware to Microsoft Tech Forum, the Microsoft Windows Vista machine froze after exiting the Microsoft Internet Explorer, with the USB stick still in the USB slot.  I reset the machine and brought it up in the safe mode which did not see a problem.  After checking the hardware, I brought Microsoft Windows Vista up, and re-inserted the USB stick.  Microsoft Security Essentials located another malware on it, certainly related to the the first one.

    After I cleaned this last one up, several scans of the USB stick did not find any more problematic software.  I also scanned the entire machine, and nothing else was found.  Next, I plugged the camera in, with the original memory module.   Sure enough, it located the same problem as that in the USB memory stick, and cleaned it up at my request.  Upon a re-scan, it found the next item as well:

    After these, there were no problems with the camera with this memory module.  Same camera with a brand new memory module did not show any problems.

    -- Yekta

     

     

    Saturday, October 8, 2011 11:36 PM
  • Below, for reference, is the problem history of the Microsoft Security Essentials. None of the problems encountered has ever been deleted from this list.  I could not add this to my previous message as the forum took only two pictures per message:

    -- Yekta

     

    Saturday, October 8, 2011 11:39 PM
  • Here are a few more things that has come up since I have recovered the devices that have been corrupting Microsoft Windows XP operating system, due to a virus that have had come through a Microsoft Windows Vista system on the network.

    Microsoft Security Essentials has removed the so-called "viruses", but it does not remove the last containing directory from the devices (for example, the "\CJCUOO" directory shown in the Microsoft Security Essentials, History list in my previous messages.  This directory was made by the "virus" generator.), even though it says that it has removed it.  Furthermore, the directory, although still on the USB memory stick, or digital camera memory, or digital voice recorder memory, does not show up when plugged into either Microsoft Windows Vista or Microsoft Windows XP operating systems.  The devices do not contain the virus anymore, but an "invisible" directory is left behind, which in principle, can aid a malicious "virus generator" program in a subsequent "virus" formation. 

    In the case of one particular brand of a digital voice recorder (OLYMPUS DSS-30), Microsoft Security Essentials have failed to remove the containing directory link altogether, while indicating this failure.  In this last case, I saved the voice data and completely reformatted the voice recorder memory using recorder's own formatting function.  I then had to reload it features back from its original CD.

    I discovered the "left-over directory" problem  when I tested  the devices mentioned above on a "LINUX" system (Debian, Ubuntu, etc...) which mounted the Microsoft formatted memory devices and instantly showed the invisible directories together with the genuine data files.  I used their "Move To Trash Bin" command to clean up the devices completely.

    -- Yekta

     

    Saturday, October 15, 2011 7:05 PM
  • A different one of those so-called "viruses" has come in today, while I have been looking for a particular specification for a very familiar training aircraft I have often been flying.  I have accessed a web address which has seemed to contain this particular specification.  While the web server was going through its initialization, displaying a tilted circle of silver dots with a shaded dot train going around the circle, Microsoft Security Essentials came up over the Mozilla screen, announcing the "Exploit" type program it had detected coming from this web site. Below is a picture of the display shown by the Microsoft Security Essentials:

    I removed it as suggested, without any problems.

    -- Yekta

    Friday, September 14, 2012 2:09 AM