locked
App-V 5.0 and publish new versions RRS feed

  • Question

  • Hi,

    Have started trying version 5.0 and found some issues that someone might have an answer on...

    If I have published, for example version 0.0.0.0, and started it on the client and then added version 0.0.0.1 on the server (Publish the new version and unpublish the old version). I won't get the new version out to the client...

    I have verified that the old version is not "in use". I am looking in the registry for the current version IDs for that package and only the old version is there.

    If I use powershell and removes the old version and then push Update in the App-V client, the new version shows up...

    Any suggestions?

    Monday, November 5, 2012 9:11 AM

All replies

  • Hi Daniel,

    I do have exact the same problem.

    Regards,
    Michael

    Monday, November 5, 2012 4:12 PM
  • This issue has been reported in the beta program as well but with no solution.

    Is anyone able to apply an update to a package?

    Wednesday, November 14, 2012 7:31 AM
  • In my environment I have UAC enabled. If I start powershell normally and run "get-appvpublishingserver | sync-appvpublishingserver" I get  the error 1008 in eventviewer when trying to get a new version of an app:

    Package {....} version {...} failed configuration in folder C:\ProgramData\App-v\....\.... with error 0x4c401c0c-0x80070005

    But if I start powershell as admin and run the same command, the new version will be installed correctly.

    I haven't verified with an account that isn't admin at all but shall do it as soon as possible...

    /Daniel

    Tuesday, November 27, 2012 8:04 PM
  • I have same issue, and we are using 5.0 RTM version

    Wednesday, November 28, 2012 8:14 AM
  • Thursday, November 29, 2012 8:37 PM
  • How do you find that link helpful?

    We have done all that, but it is on the client the new version never get installed.

    There are two solutions:

    1. Run a sync-appvclientpackages as administrator

    2. Remove the old version and then do a sync....

    /Daniel

    Thursday, November 29, 2012 9:20 PM
  • Hello,

    I suggest you raise a call with Microsoft PSS. Localized contact information is available here;

    http://support.microsoft.com


    Nicke Källén | The Knack| Twitter: @Znackattack



    • Edited by znack Sunday, December 2, 2012 9:14 PM
    Sunday, December 2, 2012 9:13 PM
  • I report this to MS and they are working on it, no fixes or workaround yet.

    I hope Ms is publishing ServicePack soon as possible, there is couple more bugs/weird things which should be fixed.

    Wednesday, December 19, 2012 1:32 PM
  • Monday, January 28, 2013 8:14 AM