locked
Editing series of all-day, recurrent event causes error RRS feed

  • Question

  • One of my users recently reported receiving errors when attempting to edit the series of an all-day, recurring event. (When you attempt to change anything in the entry, description, title, etc., and click "ok", the edit page just blinks and re-loads, instead of returning you to the calendar view you started from.  If you click "cancel", you get a browser error saying the change couldn't be made due to a validation error on the page.)  Testing shows this is a reproducable issue across both my Sharepoint 2007 farms, so it's not a corrupt item or list.  If I uncheck the "all-day event" box, and click "ok", the change is processed normally.

    I'm assuming this is a problem introduced with a recent update.  Our current version is 12.0.0.6608 (SP2007, wss3).  Anyone have an idea how to resolve this?

    Thursday, February 9, 2012 3:31 PM

Answers

All replies

  • Hi jagod,

    Your error is no relationship with SharePoint version. Because my version(12.0.0.4518) is lower to you, but it is normal on my machine. There are may be some custom configures have affect it. You said when click “ok”, the edit page just blinks and re-load, instead of returning you to the calendar view. So, I want to know the item whether add successfully in your calendar list.so, if the item add successfully in your calendar, that is no problem with item add.

    You can check the page, may be some java script has influence it. you also need check the log file (C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\LOGS) . Only know where is wrong, then it can be fixed.

    Thanks,

    Jack


    Friday, February 10, 2012 7:30 AM
    Moderator
  • Jack, the item does not get updated in the calendar list when you click "ok".   Only if I turn off the all-day event will it update.  I've turned up logging and still don't find any related errors in the trace log.  We do not currently have any customizations on the server.
    Friday, February 10, 2012 4:28 PM
  • I'm just bumping this. I had an end user in BPOS experience this exact same issue. I am able to consistently reproduce it on my subscription as well. Since BPOS is built on SharePoint Server 2007 I can assume that this may be some kind of product...hiccup.
    Saturday, February 11, 2012 3:00 AM
  • Hi jagod,

    Because after my test, my environment is ok for “All day event”. If your environment is OOB, it shouldn’t get the error. After my search, there is a thread about this. may be some changes in SharePoint designer cause it.the following link is about the thread.

    http://social.msdn.microsoft.com/forums/en-US/sharepointcustomization/thread/f194e091-df94-4849-b32b-50ef16497e4b/

    Thanks,

    Jack

    Monday, February 13, 2012 3:08 AM
    Moderator