none
Macros not showing in Macro Name RRS feed

  • Question

  • We use Project Server 2013 and Project Professional 2013.

    I am not able to see any macros when I click 'view macros'. There is a dropdown box next to "Macros in" and this applies no matter which items are chosen. These include 'all open projects', 'global template' etc.

    This is the case even if I disconnect from project server and set up and save a new macro.

    Any ideas how I can get my macros to return, as there are macros in my global template, but I can't run them?

    Monday, October 2, 2017 12:32 PM

Answers

All replies

  • HFprojects --

    Try clicking File > Options > Trust Center > Trust Center Settings > Macro Settings.  From your description, it sounds like the Disable All Macros without Notification is set.  I personally use the Enable All Macros setting as I trust all of the macros that I write and record.  Hope this helps.


    Dale A. Howard [MVP]

    Monday, October 2, 2017 1:31 PM
    Moderator
  • Hi Dale

    Thank you for your speedy response.

    I forgot to add to my post that my settings are exactly as you suggest.

    Incidentally, we have a macro in our global template that runs when project files are saved and this seems to be working. My challenge is how to change it, save the changes and then run it.

    Monday, October 2, 2017 2:00 PM
  • When you say Global Template do you mean Project Server's Global Enterprise Template?

    If so, then you need Administrator rights to open the Enterprise Global so you can edit it.

    I advise you to copy the macro to a new Project file, then do all editing and testing there. Then finally re-open from the Enterprise Global and update the code.

    This also makes sure you have a back up.


    Rod Gill
    Author of the one and only Project VBA Book and VBA developer.
    www.project-systems.co.nz

    Wednesday, October 11, 2017 6:35 AM
    Moderator
  • I found the answer in a different discussion in the forum:

    https://social.technet.microsoft.com/Forums/projectserver/en-US/51fcda3d-8335-4232-922c-b3179b32b5f5/cannot-enable-project-pro-2010-macros?forum=projectprofessional2010general

    "Event based macros will NOT show up in the list of macros under Developer/View Macros" and that was my exact problem. Thanks to John - projects for 'indirectly' giving me the answer and a big 'thank you' to everyone above who provided extremely useful information for macro users! 

    • Marked as answer by HFprojects Sunday, October 15, 2017 6:01 AM
    Sunday, October 15, 2017 6:01 AM