LiteTouch Restore not working after Windows 7 x64 Re-Build RRS feed

  • Question

  • Hi 

    I am after some help with MDT LiteTouch if anyone can help.

    I am having issues with the restoring of user profiles after the machine has been built, although the capture appears to work fine capturing the image to a network share for some reason the Restore doesn't either appear to run or fails. 

    The odd thing is that the report appears to be showing that everything is successful but there is no files restored to machine.

    Below is the order that I run things:

    1. Run LiteTouch.WSF from scripts on the MDT server
    2. Machine Captures the image to a network share (Successfully)
    3. Machine rebuilds with Windows 7 x64
    4. Machine Completes (without any files being restored)

    Below is the the customsettings.ini

    Priority=TaskSequenceID, Default


    ScanStateArgs=/v:5 /o /c
    LoadStateArgs=/lac /v:13







    TimeZoneName=GMT Standard Time






    Here is the link to the Logs from the machine:

    Hope that someone can help as it is driving me crazy!!!!

    Thanks in advance....

    Tuesday, June 25, 2013 10:38 AM

All replies

  • First off, you should be running LiteTouch.vbs, not LiteTouch.wsf.  LiteTouch.vbs will call LiteTouch.wsf when it is ready, so calling the VBS directly may cause things not to work fully as intended.  Is the Restore the only thing not running after the WIM is layed down and the machine rebooted, or does it not run anything else after that point?  Can you look at the LoadState logs directly and see if there is an issue?

    David Coulter | | @DCtheGeek

    Tuesday, June 25, 2013 2:24 PM
  • Hi David

    Thanks for your reply, sorry for the mistake i did mean the LiteTouch.vbs and not the .wsf file. Regarding the running after the wim has been laid down it reboots the machine boots back up and finishes the setup. It even comes up in the list about restoring user data and then comes up the report screen saying that it has finished.  However when you check the Users folder there is no data been restored.


    Tuesday, June 25, 2013 3:00 PM
  • can you post the log files from c:\windows\temp\deployment logs somewhere?  I'd recommend you view the files with cmtrace.exe or trace32.exe and look for errors with scanstate and loadstate.
    Tuesday, June 25, 2013 8:48 PM
  • Can you validate that files are showing up in your folder: \\Server.domain\usmt\Profile\User\%OSDComputerName%?

    Also, I don't believe you want UserDataLocation set to a UNC when you are also specifying UDShare / UDDir.  In the case of those being specified, UserDataLocation should be set to NETWORK.

    David Coulter | | @DCtheGeek

    Wednesday, June 26, 2013 12:43 AM
  • Hi I can confirm that the files are there and once windows has been build I can locate the files on the network and double click the files manually to restore the user data. It then opens the Windows Easy Transfer Wizard to do so.

    However this is not the automated experience that I am aiming to achieve.

    Wednesday, June 26, 2013 7:44 AM
  • Hi Squeezer999, will have a look and get the logs online.


    Wednesday, June 26, 2013 7:46 AM
  • Here is the link to the logs, hope this helps.

    Wednesday, June 26, 2013 7:51 AM
  • I do not see a USMTrestore.log in your files, so loadstate is not running for some reason.  You should add the /c flag to the LoadStateArgs line.

    Do you have a standard client task sequence created with the ID of WinPE?  If you are doing a RESTORE task sequence you should have a REPLACE task sequence which I do not see configured in your customsettings.ini file.

    • Edited by Squeezer999 Wednesday, June 26, 2013 4:56 PM updated
    Wednesday, June 26, 2013 4:54 PM
  • This maybe where i am going wrong then, I do have a client task sequence as seen below.


    What would the Replace Task sequence be that I need to have in the customsettings.ini 

    Thursday, June 27, 2013 10:42 AM
  • Did you try changing UserDataLocation=NETWORK like I suggested?  I noticed this in the logs:

    No user state to restore, exiting.

    I believe that Restore IS running, it's just not finding the MIG files to restore from.

    David Coulter | | @DCtheGeek

    Thursday, June 27, 2013 1:45 PM
  • Hi David

    Sorry must have missed that, I am trying that now. 'Fingers Crossed'

    Thursday, June 27, 2013 2:02 PM
  • Hi David 

    I made the change but all that did was to default the option to Network selection but leave it blank. I have since moved the option back.

    I believe that the issue is now laying with permissions, when the machine builds it logs in with the local admin details to finish, as a result this account doesn't have access to the share where the data is stored.
    I have tried to allow the access and the only way that i can see of doing this is by having a service account to login with which has permission to the share.

    The issue that I have now is having the Windows Deployment log in with this service account to finish the install, do you know what options to change for this?

    Thanks again.

    Wednesday, July 3, 2013 9:32 AM
  • HI   this link will provide full information.

    Thursday, July 4, 2013 12:18 PM
  • The easiest is to make the UNC share where you are putting the data allow read/write for Everyone, not Authenticated Users.  This should allow the local admin running MDT to access it, despite it not being a domain account (and hence not authenticated).  These permissions need to be both on the share and the NTFS for the files themselves, of course.

    David Coulter | | @DCtheGeek

    Thursday, July 4, 2013 9:35 PM
  • Hi David

    I thought that you may say that, I have tried this and also tried it with Anonymous login but both still prompt for login credentials and of course by doing so stops the process and fails the USMT restore.


    Friday, July 5, 2013 7:56 AM