none
Error: " Could not retrieve Enterprise global template" on windows 2008 Terminal Server RRS feed

  • Question

  • Dear All,

    We are using Microsoft Windows 2008 Ent. Edition x64bits terminal server. From last couple of days we are observing the subject error while access the project server though "Microsoft Project server 2007" with SP2. while searching on the internet. We found some solution mentioned below. However; our problem still same.

    1. We delete the user profile from the MS project and re-create the profile.

    2. delete MS cache information from user profile.

    3. Reinstall the application on the terminal server however problem still same.

    Can anyone hlep me to resolve above problem.

    Thanks in advance.

    Regards

    Mesum Hussain

     

     

     

    Tuesday, March 15, 2011 10:49 AM

Answers

  • Dear Khurram,

    As per your advise I follow below steps. But getting the same behavior.

     

    1.       Delete the profile in Microsoft Project 2007.

    2.       Delete my windows profile from the terminal servers.

    3.       Create new windows and MS Project profile. But still same error

     

    After that; I rename my windows roaming profile through active directory . And logon to windows terminal server and create MS Project 2007 profile then its works fine.

     

    This is my workaround but not the permanent solution. B/c all the users having this problem and I can’t rename the windows roaming profile for each users.

     

    I will escalate this case to Microsoft for the permanent solution.

     

     

     


    Mesum Hussain Asst. Systems Administrator Pakistan Petroleum Limited
    Wednesday, March 16, 2011 6:02 AM
  • Dear All,

     

     

    At last we got the root cause of  "Could not retrieve Enterprise global template" on windows 2008 Terminal Server " problem. We found 2 solutions.

    1.     While installing MS Project 2007 Pro. Leave initial name information to blank. or if you already installed the application you can modify it through HKLM\Software\Microsoft\Windows NT\CurrentVersion\Terminal Server\Install\Software\Microsoft\Office\Common\UserInfo.  Furthermore; give Full permission to everyone on C:\Documents and Settings\administrator\Application Data\Microsoft\MS Project\Cache Folder.

    If this not resolved your problem then follow step2

    2.     Logon to user windows profile then go to registry (regedit), expand HKCU\Software\Microsoft\Office\12.0\MS Project\Settings > CacheLocation . Make sure that cache location is same as user profile name and location.

     

     

     point 2 solution is usually apply for roaming profile users  

     

     
    Mesum Hussain Asst. Systems Administrator Pakistan Petroleum Limited
    Tuesday, April 5, 2011 9:09 AM

All replies

  • Hi Meesum

    Is the mentioned issued appears for all your users or few? if you login as administrator, do you still come across the same issue?

    becaue this might could be the permissions issue, just let me know and we will try fix it.

     


    | Khurram Jamshed | Follow my blog about Enterprise Project Management Solution | http://khurramjamshed.blogspot.com |
    Tuesday, March 15, 2011 11:23 AM
  • Dear Khurram,

    Thanks for your response.

    We are observing this problem with all the users. Furthermore; when i logon to terminal server with administrator account and domain user profile in MS project 2007 then its working fine.

    i also thing that its seems to be some permission issue . But strange; its working fine from last 1.5 years.

     

     

     


    Mesum Hussain Asst. Systems Administrator Pakistan Petroleum Limited
    Tuesday, March 15, 2011 11:30 AM
  • with some effort, the only solution i have found is the one you have already tried. but just to recall i will copy the steps for you, just  see if you are not missing any of the steps mentioned below in your case:

    issue comes from the need for EPM 2007 to use roaming profile instead
    of local profile so the solution consist in
    Delete the local profil on the TSe server to delete the local cache and to
    be SURE that you use the roaming profile in pointing to the autorised share
    Desinstall Project Pro 2007 on TSE (to be prudent)
    Reinstall Project Pro 2007 on TSE - DO NOT USE the TSE last step of
    application wizard
    install Project Pro 2007 SP1 right after
    USE the TSE last step of application wizard

    Once the roaming work once, the connexion to PS is know, and will point to
    the web application

    Hope this helps.

    | Khurram Jamshed | Follow my blog about Enterprise Project Management Solution | http://khurramjamshed.blogspot.com |
    Tuesday, March 15, 2011 12:11 PM
  • Appreciate your efforts. Let me try and update you  accordingly


    Mesum Hussain Asst. Systems Administrator Pakistan Petroleum Limited
    Wednesday, March 16, 2011 4:13 AM
  • Dear Khurram,

    As per your advise I follow below steps. But getting the same behavior.

     

    1.       Delete the profile in Microsoft Project 2007.

    2.       Delete my windows profile from the terminal servers.

    3.       Create new windows and MS Project profile. But still same error

     

    After that; I rename my windows roaming profile through active directory . And logon to windows terminal server and create MS Project 2007 profile then its works fine.

     

    This is my workaround but not the permanent solution. B/c all the users having this problem and I can’t rename the windows roaming profile for each users.

     

    I will escalate this case to Microsoft for the permanent solution.

     

     

     


    Mesum Hussain Asst. Systems Administrator Pakistan Petroleum Limited
    Wednesday, March 16, 2011 6:02 AM
  • Hi Meesum,

    i did suspect that the issue is because of the roaming profile, and the only solution i came across is the one you have tried.

    I think its better to take it on with the MS, hope it will be sorted for you soon.

    thanks.


    | Khurram Jamshed | Follow my blog about Enterprise Project Management Solution | http://khurramjamshed.blogspot.com |
    Wednesday, March 16, 2011 6:23 AM
  • Dear All,

     

     

    At last we got the root cause of  "Could not retrieve Enterprise global template" on windows 2008 Terminal Server " problem. We found 2 solutions.

    1.     While installing MS Project 2007 Pro. Leave initial name information to blank. or if you already installed the application you can modify it through HKLM\Software\Microsoft\Windows NT\CurrentVersion\Terminal Server\Install\Software\Microsoft\Office\Common\UserInfo.  Furthermore; give Full permission to everyone on C:\Documents and Settings\administrator\Application Data\Microsoft\MS Project\Cache Folder.

    If this not resolved your problem then follow step2

    2.     Logon to user windows profile then go to registry (regedit), expand HKCU\Software\Microsoft\Office\12.0\MS Project\Settings > CacheLocation . Make sure that cache location is same as user profile name and location.

     

     

     point 2 solution is usually apply for roaming profile users  

     

     
    Mesum Hussain Asst. Systems Administrator Pakistan Petroleum Limited
    Tuesday, April 5, 2011 9:09 AM