none
UAG+OWA 2010 Problem opening other user's mailbox RRS feed

  • Question

  • We have Forefront UAG SP1 & Exchange 2010 SP1 (14.1, build 218.15), and we have a problem with OWA using the UAG Portal link. When we use it this way, the 'sign out' and the '%USERNAME%' buttons in the upper right corner disappear. I normally use the %USERNAME% link to open an other user's mailbox.

    I know there are some workarounds:

    - Right clicking in the left column to open another user's inbox/calendar (but not the full mailbox)
    - adding the SMTP address to the URL (https://UAGLINK.company.com/owa/mailbox@company.com/), but this is not really an option for 'normal users'

    When i go to https://UAGLINK.company.com/owa/ directly (instead of clicking the 'Webmail' link in the Portal) I get the UAG login screen. After logging on I am directly sent to OWA, and I CAN see the two buttons and they work as expected.

    What can I do to solve this problem?

    UPDATE: I noticed that, when zooming out, I DO see the %USERNAME% link. I do NOT see the 'sign out' link, but I guess that's the way it should be, because signing out should only be done from the portal page.

    It is still odd that it all works perfectly when using OWA internally, without UAG. It seems that the mechanism that 'strips' the 'sign out' link messes up the page layout, placing the button outside the screen area.

    I tested this in both IE8, IE9, FF5 and FF6

    Wednesday, August 17, 2011 11:00 AM

Answers

  • This issue was fixed for us by MS Support. I received a custom xml file that I had to put in a folder named CustomUpdate in the "%UAG_INSTALLATION_ROOT%\von\Conf\WebSites\%TRUNK_NAME%\conf\" folder. After that (and a reboot) it worked fine. MS advised me not to put the file here, but to ask anyone with this problem to contact MS Support. My call# was REG:113010210109475, maybe they can send it to you right away with that info.

    If you would like to give the file I received a try anyway you can let me know.

    Thursday, January 17, 2013 12:43 PM

All replies

  • Hi Michiel,

     in my eyes it  seems to be a bug.

    If you look in the HTML code of the OWA page you'll see some "min-width: 1770px" inline code for the "|" seperator on the left side of  the "User Name" menu. So i guess using a Full-HD compliant monitor would also solve this problem^^ ;)

    I recommend to open a ticket in this case...

    -Kai

     


    Thursday, August 18, 2011 9:08 AM
  • Hi Kai,

    Thanks for the reply. If you (or someone else) open OWA using a Portal link, does this work properly for you? I think I have a pretty default installation, but I was wondering if this is different for other UAG users.

    I think I will open a ticket to get support for this problem anyway, thanks!

    Michiel

    Thursday, August 18, 2011 10:06 AM
  • Hi Michiel,

    at least i can repro this issue. The user name box is out of window on my UAG/OWA, too. In my case its "min-width: 1770px" @1600x1200 resolution.

    -Kai

    Thursday, August 18, 2011 10:12 AM
  • OK, thanks for testing, glad it's not me... :)

    I'll let you know if I have any updates.

    Thursday, August 18, 2011 2:15 PM
  • Any update on this issue?

    How can we get OWA to display properly in UAG?

    Sunday, October 16, 2011 9:44 AM
  • Any news yet about this BUG???
    Friday, April 13, 2012 8:05 AM
  • No, I still do not have a fix for this. In our company, there are not that many users that use this functionality (from within OWA), so we still have it on the to-do list, but not with high priority. Sorry... :-)
    Thursday, April 19, 2012 11:59 AM
  • We are having this same issue. Has this bug been allready fixed or is there a way to fix it myself?

    Friday, May 25, 2012 12:30 PM
  • Don't mean to bump an old thread, but I am having this same issue on 2 separate UAG servers with SP2. Wondering if anyone found a fix.
    Saturday, December 8, 2012 3:33 PM
  • I decided to enter a support request at Microsoft after all. We did not have all the UAG/Exchange updates installed earlier, but now we have (UAG SP2 and Exchange 2010 SP2 Update Rollup 5). The problem still exists, so I hope they can help me now...

    Wednesday, January 2, 2013 1:06 PM
  • This issue was fixed for us by MS Support. I received a custom xml file that I had to put in a folder named CustomUpdate in the "%UAG_INSTALLATION_ROOT%\von\Conf\WebSites\%TRUNK_NAME%\conf\" folder. After that (and a reboot) it worked fine. MS advised me not to put the file here, but to ask anyone with this problem to contact MS Support. My call# was REG:113010210109475, maybe they can send it to you right away with that info.

    If you would like to give the file I received a try anyway you can let me know.

    Thursday, January 17, 2013 12:43 PM
  • This issue was fixed for us by MS Support. I received a custom xml file that I had to put in a folder named CustomUpdate in the "%UAG_INSTALLATION_ROOT%\von\Conf\WebSites\%TRUNK_NAME%\conf\" folder. After that (and a reboot) it worked fine. MS advised me not to put the file here, but to ask anyone with this problem to contact MS Support. My call# was REG:113010210109475, maybe they can send it to you right away with that info.

    If you would like to give the file I received a try anyway you can let me know.

    Hi Michiel,

    We don't have a Technet account or software assurance so I only have the option to get paid support from Microsoft as far as I know. Would it be possible to share the custom xml file with me?

    Tuesday, January 22, 2013 2:02 PM
  • I guess it's not possible to attach a file or send a PM , so I'll put the file content here. This is the content of the xml file I received, the file name should be WhlFiltAppWrap_HTTPS.xml. this should be put in a folder named CustomUpdate under the conf folder as I described earlier. Good luck!

    Could you let me know if it worked for you?

    <APP_WRAP ver="3.0" id="RemoteAccess_HTTPS.xml">
    <MANIPULATION>
    <MANIPULATION_PER_APPLICATION>
    <APPLICATION_TYPE>ExchangePub2010</APPLICATION_TYPE>
    <DATA_CHANGE>
    <URL case_sensitive="false">/owa/.*startpage\.js</URL>
    <SAR conditional_variable="UsePortalFrame" conditional_var_value="True">
    <SEARCH encoding="base64">Zy5zZXRfTWluV2lkdGgobCk=</SEARCH>
    <REPLACE encoding="base64">dmFyIGx0PSQoJ21pZFRvcFNpZGVCYXJDZWxsJykuZ2V0X1dpZHRoKCk7Zy5zZXRfTWluV2lkdGgobC1sdCk=</REPLACE>
    </SAR>
    </DATA_CHANGE>
    <DATA_CHANGE> 
    <URL case_sensitive="false">/owa.*</URL> 
    <SAR conditional_variable="DontShowLogoff" conditional_var_value="FALSE"> 
    <SEARCH encoding="base64">X2Vfb25jbGljaz0ibG9nb2ZmKCk7Ig==</SEARCH> 
    <REPLACE encoding="base64">X2Vfb25jbGljaz0iZW5kU2Vzc2lvbigpOyI=</REPLACE> 
    </SAR> 
    <!-- Accessing without toolbar --> 
    <!-- Send logoff to our endSession function and add our scripts --> 
    <!-- First part for OWA Premium; Second part for OWA Basic --> 
    <SAR conditional_variable="DontShowLogoff" conditional_var_value="FALSE"> 
    <SEARCH encoding="base64">PGEgaWQ9ImFMb2c=</SEARCH> 
    <REPLACE encoding="base64">PHNjcmlwdCBsYW5ndWFnZT0iSmF2YVNjcmlwdCIgc3JjPSJXaGxPd25VUkxzY3JpcHRzL0NhY2hlQ2xlYW4uanMiPjwvc2NyaXB0PjxzY3JpcHQgbGFuZ3VhZ2U9IkphdmFTY3JpcHQiIHNyYz0iV2hsT3duVVJMbG9nb2ZmUGFyYW1zLmFzcD9zaXRlX25hbWU9V2hsU2l0ZU5hbWUmc2VjdXJlPVdobFNlY3VyZSI+PC9zY3JpcHQ+DQo8c2NyaXB0IGxhbmd1YWdlPSJKYXZhU2NyaXB0IiBzcmM9IldobE93blVSTHNjcmlwdHMvbG9nb2ZmLmpzIj48L3NjcmlwdD48YSBpZD0iYUxvZw==</REPLACE> 
    </SAR> 
    <SAR conditional_variable="DontShowLogoff" conditional_var_value="FALSE"> 
    <SEARCH encoding="base64">PGEgaWQ9ImxvIg==</SEARCH> 
    <REPLACE encoding="base64">PHNjcmlwdCBsYW5ndWFnZT0iSmF2YVNjcmlwdCIgc3JjPSJXaGxPd25VUkxzY3JpcHRzL0NhY2hlQ2xlYW4uanMiPjwvc2NyaXB0PjxzY3JpcHQgbGFuZ3VhZ2U9IkphdmFTY3JpcHQiIHNyYz0iV2hsT3duVVJMbG9nb2ZmUGFyYW1zLmFzcD9zaXRlX25hbWU9V2hsU2l0ZU5hbWUmc2VjdXJlPVdobFNlY3VyZSI+PC9zY3JpcHQ+DQo8c2NyaXB0IGxhbmd1YWdlPSJKYXZhU2NyaXB0IiBzcmM9IldobE93blVSTHNjcmlwdHMvbG9nb2ZmLmpzIj48L3NjcmlwdD48YSBpZD0ibG8i</REPLACE> 
    </SAR> 
    <!-- Accessing with toolbar --> 
    <!-- Remove Logoff --> 
    <!-- First part for OWA Premium; Second part for OWA Basic --> 
    <!--SAR conditional_variable="DontShowLogoff" conditional_var_value="True"> 
    <SEARCH encoding="base64">PGRpdiBpZD0iZGl2TG9nT2ZmIg==</SEARCH> 
    <REPLACE encoding="base64">PGRpdiBpZD0iZGl2TG9nT2ZmIiBzdHlsZT0iZGlzcGxheTpub25lIg==</REPLACE> 
    </SAR> 
    <SAR conditional_variable="DontShowLogoff" conditional_var_value="True"> 
    <SEARCH encoding="base64">YWx0PSIiPjwvdGQ+PHRkIG5vd3JhcD48ZGl2IGNsYXNzPSJzY2giPjxhIGlkPSJsbyI=</SEARCH> 
    <REPLACE encoding="base64">YWx0PSIiIHN0eWxlPSJkaXNwbGF5Om5vbmUiPjwvdGQ+PHRkIG5vd3JhcD48ZGl2IGNsYXNzPSJzY2giPjxhIGlkPSJsbyIgc3R5bGU9ImRpc3BsYXk6bm9uZSI=</REPLACE> 
    </SAR--> 
    </DATA_CHANGE> 
    </MANIPULATION_PER_APPLICATION> 
    </MANIPULATION> 
    </APP_WRAP> 


    • Edited by Michiel Hilberdink Wednesday, January 23, 2013 1:21 PM
    • Proposed as answer by Roy.D Thursday, February 14, 2013 9:58 AM
    Wednesday, January 23, 2013 1:21 PM
  • Thanks for pasting the contents of the XML file. Unfortunatly it doesn't fix my issues.

    As advised I saved the contents to a file named WhlFiltAppWrap_HTTPS.xml and placed this file in the folder CustomUpdate (wich I had to creacte) in the \von\Conf\WebSites\portal\conf folder were portal is the name of our trunk.

    After a reboot of the machine I checked the CustomUpdate folder and the xml file was gone. So I guess it has been applied then.


    I've browsed to our UAG portal, logged in and click on the OWA link. I do see my name in the right corner but after a few seconds it disappears. When I zoom out it gets back.

    Monday, January 28, 2013 9:58 AM
  • Thanks for pasting the contents of the XML file. Unfortunatly it doesn't fix my issues.

    As advised I saved the contents to a file named WhlFiltAppWrap_HTTPS.xml and placed this file in the folder CustomUpdate (wich I had to creacte) in the \von\Conf\WebSites\portal\conf folder were portal is the name of our trunk.

    After a reboot of the machine I checked the CustomUpdate folder and the xml file was gone. So I guess it has been applied then.


    I've browsed to our UAG portal, logged in and click on the OWA link. I do see my name in the right corner but after a few seconds it disappears. When I zoom out it gets back.


    I had the same issue initially. After I created the XML file, I activated the configuration, then rebooted. That seemed to make it stay.
    • Proposed as answer by Roy.D Thursday, February 14, 2013 9:58 AM
    Monday, January 28, 2013 3:59 PM
  • I've just received the same file from MS looking to deploy this weekend
    Saturday, February 2, 2013 1:46 PM
  • I had the same issue initially. After I created the XML file, I activated the configuration, then rebooted. That seemed to make it stay.


    Just had the time to try again and indeed after activating the configuration and then a reboot I can confirm the posted XML file works. Many thanks Michiel Hilberdink<abbr class="affil" sab="2666"></abbr> and fusky2.
    Thursday, February 14, 2013 9:58 AM