locked
Erro deploying BDC model RRS feed

  • Question

  • I got an error in Visual Studio 2010: "Error 1 Error occurred in deployment step 'Add Solution': There is no default Business Data Connectivity Service Proxy available for the given SPServiceContext." when deploying a BDC model to local SharePoint instance. Anyone can point me to where to set the proxy?

    Thanks
    Ben
    Thursday, March 18, 2010 9:50 PM

Answers

  • Make sure you have installed WCF hot fix - http://support.microsoft.com/kb/976462 and then try to create new BCS Service application, it should help.

     

    Hrayr

    www.lightningtools.com

     

    • Proposed as answer by JürgenD Tuesday, March 23, 2010 8:55 AM
    • Marked as answer by Tobias ZimmergrenMVP Monday, September 13, 2010 10:16 AM
    Sunday, March 21, 2010 6:17 PM

All replies

  • Have you configured the BDC service application for your SharePoint web application?
    Regards,
    Chakkaradeep || SharePoint Developer - MCTS SharePoint Dev, WSS Dev
    http://www.intergen.co.nz || Twitter: http://twitter.com/chakkaradeep || http://www.chakkaradeep.com
    Thursday, March 18, 2010 9:53 PM
  • I got an error when trying to configure BDC service application: "The load balancer is not provisioned. Verify the load balancer was provisioned successfully before retrieving endpoint addresses. ". This is on my local workstation. I am looking around to see how I can "provision the load balancer" on my PC.

    Any suggestion?

    Ben

    Friday, March 19, 2010 1:46 PM
  • Hi. I got the same problem. When trying to activate the featurea I get this error: 

    "There is no default Business Data Connectivity Service Proxy available for the given SPServiceContext. "

    When I try to configure the Business Data Connectivity Service I get a similar error

    Could it be that I am missing some credentials? Other posts say that there is an entry in the Central Administration -> System Settings , click Manage services on server. In my Central Administration I cannot find such a link.

    Thank you!

    Friday, March 19, 2010 2:52 PM
  • Is your local machine a Domain Controller? Did you do a standard or complete installation of SharePoint?
    Regards,
    Chakkaradeep || SharePoint Developer - MCTS SharePoint Dev, WSS Dev
    http://www.intergen.co.nz || Twitter: http://twitter.com/chakkaradeep || http://www.chakkaradeep.com
    Friday, March 19, 2010 7:22 PM
  • Make sure you have installed WCF hot fix - http://support.microsoft.com/kb/976462 and then try to create new BCS Service application, it should help.

     

    Hrayr

    www.lightningtools.com

     

    • Proposed as answer by JürgenD Tuesday, March 23, 2010 8:55 AM
    • Marked as answer by Tobias ZimmergrenMVP Monday, September 13, 2010 10:16 AM
    Sunday, March 21, 2010 6:17 PM
  • Thank you for your replies!

    At the end the hotfix was missing. After deleting the service and creating a new one again it runs now.

    A problem could also have been that I made everthing on a Windows 7 whereas now I am working on a Windows Server 2008...

    Thanks for you help!

    Tuesday, March 23, 2010 8:55 AM
  • Hi Chakkaradeep Chandran!

    <abbr class="affil">Actually Im not sure if it is a domain controller. Where can i check that out? Would it make a big difference!</abbr>

    <abbr class="affil">I did a standard installation. Is it better todo a full installation?</abbr>

    <abbr class="affil">Thank you</abbr>

    Tuesday, March 23, 2010 3:23 PM
  • I encountered the same problem when trying to deploy a feature with a Business Data Connectivity model inside it. What worked for me was the following:

    1. Open up Central Administration
    2. Click Application Management on the left
    3. Click Configure service application associations under Service Applications
    4. Click the Application Proxy Group (2nd column) to which the WebApplication you're deploying to is assigned to
    5. Make sure the checkbox in front of Business Data Connectivity Service is checked. Here it wasn't.
    6. Click OK to save your changes and try deploying again.

    Sunday, September 12, 2010 12:08 AM
  • Just had the same Problem,

    Try to create a new Application Service (Type: Business Data Connectivity Service)

    Central Administration -> Application Management -> Manage Service Applikation -> New -> Business Data Connectivity Service

    Monday, May 21, 2012 2:58 PM
  • Sharepoint 2013 Users:

    I have been re-setup Business Data Connectivity Service and its associated Databases on SQL with different service account (

    1: I created new admin account on AD (Copy Administrator account) and add that account on Local admin on all servers+
    2:  Created 2 SQL Databases one for App Management Service and One for Business Data Connectivity and Set that account DBOwner role on SQL, +
    3:  Allow full control permission on Registry path on SQL Server HKLM-Software-Microsoft-Microsoft SQL Server+ (right click and permission)
    4: Add that account on Manage Service Account on SP Farm+ 
    5: Deleted existing App Management Service application and Business Data connectivity Service Application and created new one and point the database path which I created for both and Application pool service account was new account+ 
    6: Set the SharePoint Timer service log on to account with new service account and restart services ).

    Now it was fixed.

    Very complected right? But yes this is only the fix.

    Saturday, March 29, 2014 7:40 AM