none
Windows SteadyState Port Conflict Issue RRS feed

  • Question

  • Hello,

     

    I have run into an odd issue I was hoping someone might be able to help with.  I have two systems which are using Windows SteadyState 2.0 to restrict access to Windows and Internet access.  On these two systems I am not able to access an application which is required.  The application is a reporting tool.

     

    This application uses SOAP as a messaging/data processing mechanism.  Basically the system uses the following (behind the scenes mechanism to retrieve the data):

     

    http://<Host>:1023/soap

    Where <Host> must be replaced with the computer name or IP.

     

    On both of these systems, the application cannot be found and therefore does not execute. 

     

    Ironically enough, I have another 10 systems using the same exact application; Operating System/Image; and user profile which are working without any problems.  On the two systems where this is not working, it does work when logged in as Administrator.

     

    Does anyone have any idea what could be causing this problem?  I have reviewed the profiles setting by setting and cannot find any differences.

     

    Thanks,

     

    Joe

    Tuesday, July 8, 2008 4:05 AM

All replies

  • Hi Joe, does the issue occur if we remove those restrictions of Internet access in SteadyState? Do you mean another 10 systems are also equipped with SteadyState with the same settings?

    Wednesday, July 9, 2008 7:15 AM
    Moderator
  • Sean,

     

    I will have to check regarding removing the restrictions.

     

    I have 3 systems running exactly the same profile (Imported to all 3).  2 of the 3 when logged in as that profile fail to execute an application which use the port outlined in my original post.  The 3rd location has no issues.

     

    As well, all three locations have no issues when logged in as Administrator.

     

    Is it possible that something did not import correctly?

     

    All three locations are using the same Hardware and Software versions.

     

    Thanks,

     

    Joe

    Wednesday, July 9, 2008 8:08 PM
  • Sean,

     

    I was finally able to get back to testing this.  I have an answer to your question.

     

    When I removed all restrictions for the user in question, the application launched without any issues.  I then went ahead and turned back on the restrictions.  This time it failed with the same error.

     

    Is it possible that somehow during the import process the import did not complete 100% successful?  2 out of the 3 systems I am looking into have the same exact problem.  The third one works.  The two that are failing are using profiles that were imported from the 3rd.

     

    Joe

     

    Tuesday, July 15, 2008 4:54 PM
  •  

    Hi Joe, this issue seems to be odd, is there any difference between the users on the two computers than the third one? If the issue may relate to permission, we can also temporarily set them as administrator instead of standard user to check the result. Also, were the profiles on first and second computer imported from the third one?

    Wednesday, July 16, 2008 6:03 AM
    Moderator
  • Sean.

     

    The two additional locations were imported based on the Manager.SSU export file created.

     

    I think I may have narrowed down this issue, but will need some additional feeback from you.

     

    In all of the system testing I have done, the systems were running IE7.  However in the system I worked on today (has the problem), it was running IE 6.0.2900.xpsp2....

     

    Is there some interdependencies with SteadyState restrictions and the IE Version?  I know that in SteadyState 2.5, specifically on the Feature Restriction tab, some of the restrictions explicitly call out Internet Explorer 7 Only, while others call out Internet Explorer 6 Only.

     

    Since there is no user-guide which explicitly details what each restriction does, it makes it difficult at times to no what enabling a setting will actually do.

     

    Any Help would be much appreciated,

     

    Joe

    Wednesday, July 16, 2008 5:21 PM
  •  

    I'd like to list the related restrictions in SteadyState 2.5 as below:

     

    Disable RSS Feeds (Internet Explorer 7 only)

     

    Search (Internet Explorer 6 only)

    Folders (Internet Explorer 6 only)

    Discussions (Internet Explorer 6 only)

    Media (Internet Explorer 6 only)

    History (Internet Explorer 6 only)

    Tools (Internet Explorer 6 only)

     

    Command Bar (Internet Explorer 7 only)

    Friday, July 18, 2008 7:06 AM
    Moderator
  • Sean,

     

    Thanks for your response.  I am a bit confused though.  Could you elaborate in more detail?  I understand the features that explicity call out an IE Version.  What I am trying to determine is what in IE 6 is preventing this?

     

    The system I am running in the problem with is using SteadyState 2.0 not 2.5.

     

    Joe

     

    Friday, July 18, 2008 2:14 PM