locked
Outlook : Corrupted text in e-mails when moving/copying RRS feed

  • Question

  • Hi,

    We have some users who write e-mails in Japanese. With some e-mails, they have a problem : when moving/copying the e-mail (for example drag-and-drop to another Outlook folder, attach the e-mail to a new e-mail, or save it as .msg on disk), then some characters are corrupted.

    For example, this line :

    小林様

    is changed to this :

    ¬—Ñ—l

    As long as the messages stays in its original place (the "Sent items" folder for example), there is no problem. But as soon as it is moved/copied, the corruption happens.

    I asked the user to send a test e-mail to me. The e-mail I received in my inbox was fine. Then I moved it to another folder, and the corruption happened.

    I tried copying the text of the e-mail, and pasting it myself in a new e-mail (to myself). The e-mail was fine, even after moving/copying it. So I guess it's a setting on the user computer or account when he writes the e-mail, and I can't even reproduce the problem myself.

    Any idea ?

    Thanks.

    Friday, February 3, 2017 9:55 AM

All replies

  • Dear,

    Kindly check the encoding option of the email before and after.

    On Message select - Actions - other actions -encoding before arrival of the mail and after movement of the mail to different folder.

    Thanks

    Syed Abdul Kadar M.

    Friday, February 3, 2017 10:02 AM
  • Thanks for the reply.

    Unicode (UTF-8) for both.

    Friday, February 3, 2017 10:51 AM
  • I made some more tests. I am now able to reproduce the problem with my own account.

    I noticed this :

    - The problem only happens when using Outlook from a computer which has "Japanese (Japan)" as system locale (Control panel > Region and Language > Administrative).

    - However, I can not clearly identify what is causing this. I tried a lot of things to reproduce the problem, but the simplest way was this :

    • Click reply on a message where we already have the problem.
    • Change the To: and Subject: fields to anything.
    • Write japanese characters in the body.
    • Send.
    • Drag and drop from "Sent Items" to desktop.
    Monday, February 6, 2017 1:54 PM
  • No one can help me?
    Thursday, February 9, 2017 9:54 AM
  • I noticed this :

    - The problem only happens when using Outlook from a computer which has "Japanese (Japan)" as system locale (Control panel > Region and Language > Administrative).

    Hi,

    What's your Office language version?

    In Outlook, click File > Options > Language, check your Editing Languages setting and Display and Help Languages settings.

    Additionally, please restart Outlook in safe mode: Press Win+R to open Run in Windows, type Outlook /safe, press Enter. Then confirm if the issue can be reproduced in safe mode.


    Regards,

    Winnie Liang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, February 13, 2017 6:14 AM
  • Hi,

    Thanks for the reply.

    Editing language:

    - English (U.S.) <default> : keyboard + proofing

    - English (U.K.) : keyboard + proofing

    - French (Switzerland) : keyboard + proofing

    - Japanese : keyboard

    Display language :

    1. Match Microsoft Windows <default>

    2. English

    Help Language :

    1. Match Display Language <default>

    2. English

    I can reproduce the problem in safe mode too.


    Friday, February 17, 2017 3:07 PM