none
Can't lock my Windows 8. Also does not lock my computer after Hibernation or Sleep. RRS feed

  • Question

  • Hi everyone

    It's been about two weeks that I can't lock my laptop computer (with Windows 8 Pro installed on it):

    - Ctrl+Alt+Delete now has 4 options instead of 5: No Lock Option

    - WinKey+L does not work

    - After hibernation or sleep, it does lock my password (although in Power Options, "Require Password on wakeup" is ENABLED)

    - When I click my account name in Start, there is not Lock option. Only "Change Account Picture" and "Sign Out"

    - The LockWorkStation() function from User32.dll does not work either. From C++, it returns Success but nothing happens.

    (However, "Switch User" is available in Ctrl+Alt+Delete.)

    This is so important to me, because I usually use my laptop at work or public places and I sometimes have to leave it locked.

    Note that I recently did two new things: (1) Used my computer to Remote Control another computer with Remote Desktop Connection. (2) Installed Windows Driver Kit Test Target (Which after installing Windows Driver Kit, is available in C:\Program Files (x86)\Windows Kits\8.1\Remote\x64) to have my Windows debugged for driver development. I think this is the source of my problem because another computer which I have installed "Test Target" on, faces the same problem. Uninstalling the Test Target didn't help.

    I have tried many methods including these:

    - Over the net, many people with the same issue where suggested to do something with group policy:

    gpedit.msc -> User Configurations -> Administrative Templates -> System -> Ctrl+Alt+Delete Options -> "Remove Lock Computer"  DIDN'T WORK

    gpedit.msc -> Computer Configurations -> Administrative Templates -> System -> Logon -> ....  DIDN'T WORK

    Even the registry key equivalents for these group policy options didn't work.

    - SFC.EXE /SCANNOW    (fix the system files) DIDN'T WORK

    - I can't find any options about "Fast User Switching" in User Accounts

    ...

    Does anyone have any idea?

    Monday, November 18, 2013 7:56 AM

Answers

  • Hi,

    For the issue, I would like to confirm if you reboot the system after modifying the Group Policy.

    Please reboot your system to check the result.

    Also, I suggest you try to perform the steps below to check the again.

    1.Please open the Group Policy to check the following path again.

    Local Computer Policy/Computer Configuration/Administrative Templates/System/Logon

    2.Just double-click Hide Entry Points for Fast User Switching to bring up a dialog box to change Fast User Switching policy setting.

    At the top, there are Not Configured, Enabled and Disabled options available. Selecting each setting will let you read its affect in Help section. Just select Disabled from the list and click OK.

    Note: Once done, you will have to enforce the change made to Fast User Switching policy setting. To do so, close the Local Group Policy Editor and open the Run dialog box. Enter the  command “gpupdate /force“ and click OK. The policy will be updated and applied on all user accounts.

    If the issue persists, try to create a new account to test it.

    Regards,


    Kelvin hsu
    TechNet Community Support

    Tuesday, November 19, 2013 9:49 AM
    Moderator

All replies

  • Hi,

    For the issue, I would like to confirm if you reboot the system after modifying the Group Policy.

    Please reboot your system to check the result.

    Also, I suggest you try to perform the steps below to check the again.

    1.Please open the Group Policy to check the following path again.

    Local Computer Policy/Computer Configuration/Administrative Templates/System/Logon

    2.Just double-click Hide Entry Points for Fast User Switching to bring up a dialog box to change Fast User Switching policy setting.

    At the top, there are Not Configured, Enabled and Disabled options available. Selecting each setting will let you read its affect in Help section. Just select Disabled from the list and click OK.

    Note: Once done, you will have to enforce the change made to Fast User Switching policy setting. To do so, close the Local Group Policy Editor and open the Run dialog box. Enter the  command “gpupdate /force“ and click OK. The policy will be updated and applied on all user accounts.

    If the issue persists, try to create a new account to test it.

    Regards,


    Kelvin hsu
    TechNet Community Support

    Tuesday, November 19, 2013 9:49 AM
    Moderator
  • Just uninstall all programs about WDTF.
    • Proposed as answer by Sf Wang Friday, September 19, 2014 3:44 PM
    • Unproposed as answer by Sf Wang Friday, September 19, 2014 3:44 PM
    Friday, September 19, 2014 3:43 PM