locked
SCVMM Storage Pool not visible to Host RRS feed

  • Question

  • Hi,

    We have an existing installation of VMM and have purchased a Unity EMC SAN that is attached to the Fabric.   I was able to successfully connect the SAN to VMM.   VMM can see the storage array,  I created the classification and added the pool to VMM.  I can create a LUN and assign the Pool and LUN to a host group.  Everything looks correct.   My problem is this.   The storage pool which can be seen under All Hosts and under All Hosts>Cluster,  cannot be seen by the the host in VMM. So when I goto the host>cluster>host1  and add storage  it does not show the pool as being available to assign to the host.   I was able to connect a LUN directly to the host without VMM.  So the connection between them is up and running.   Anyone have any other ideas.

    Thanks!

    Thursday, July 2, 2020 7:24 PM

All replies

  • Hello,

    Basically, if the host is part of a cluster, registering file shares and logical units are disabled an must be performed at the cluster level from the properties dialog.

    Therefore, please assign the LUNs to the cluster. 

    For more information about allocating storage, please click the following link.

    https://docs.microsoft.com/en-us/system-center/vmm/storage-host-group?view=sc-vmm-2019

    Best regards,

    Andy Liu


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, July 3, 2020 2:14 AM
  • Thank you.  I have followed the instruction from the link.   

    Allocate a LUN to a host group
    Click Fabric > Storage > Allocate Capacity > Allocate Storage Capacity and click the host group.
    Click Allocate Logical Units, select a unit > Add.
    After LUNs are allocated to host groups you can assign them to Hyper-V hosts and clusters.

    However,   my problem is still the following.

    "VMs and Services>Cluster>ClusterProperties>Storage"   I show the Allocated LUN and capacity as available. 

    But when I goto  "VMs and Services>Cluster>"PickMyCluster">properties>Available Storage>Add Cluster Disk>Create Logical Unit> On the drop down for Storage pool it is blank.


    So even though the storage pool is assigned correctly to the cluster group.  It is not showing up as available under that dialog box.

    Anyone have any other ideas?

    Wednesday, July 15, 2020 12:34 PM
  • When you first add a host/cluster in VMM, it configures MPIO on the host (if MPIO is enabled) and it requires a reboot so that all the DSMs are configured properly. If the host is not rebooted, you may encounter this issue. Try reboot all the cluster nodes after putting it into the maintenance mode and then refresh the host from SCVMM console. Once all done, try to create the LUN and see if the LUN is visible. 

    If MPIO is not enabled but already added on the SCVMM, you need to remove it from SCVMM, enable MPIO and then add it back on the SCVMM console. Once you add, it will ask for a reboot. Reboot all the cluster nodes, after that refresh the host cluster and then you should be able to see the LUN 


    Regards,
    Aayoosh Moitro
    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.


    Wednesday, July 15, 2020 6:28 PM
  • Hello,

    Just to make it clear, I write a summary here.

    Issue

    ============

    The storage pool which can be seen under All Hosts and under All Hosts>Cluster,  cannot be seen by the the host in VMM. 

    Possible Resolution

    ============

    If the MPIO on the hosts have been enabled, Try reboot all the cluster nodes after putting it into the maintenance mode and then refresh the host from SCVMM console. Once all done, try to create the LUN and see if the LUN is visible. 

    If MPIO is not enabled but already added on the SCVMM, you need to remove it from SCVMM, enable MPIO and then add it back on the SCVMM console. Once you add, it will ask for a reboot. Reboot all the cluster nodes, after that refresh the host cluster.


    Best regards,

    Andy Liu


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, August 19, 2020 5:53 AM