none
GPO to reboot at scheduled time

    Question

  • This seems like it should be stupidly easy, but continues to fail on me. What am I doing wrong??


    BlankMonkey

    Wednesday, September 14, 2016 5:55 PM

Answers

  • This is a different issue.  The test machine I was working on has was a BAD image, so there was something more fundamental wrong under the hood.  I have purged the image and am starting fresh with a new computer.

    BlankMonkey

    • Marked as answer by BlankMonkey Monday, September 19, 2016 2:40 PM
    Monday, September 19, 2016 2:40 PM

All replies

  • What error code is showing in the task scheduler on a client PC? Did you set the gpo preference to create the task?

    Wednesday, September 14, 2016 7:40 PM
  • Error codes are weird, but the direct symptom is that the task never shows up in the task scheduler.  I have wiped the box, so I can replicate it now, but will I need to.  The error is something about the account not being recognized.

    The GPO preference?  I am not sure what you are referring to.  I did set it to update every time.


    BlankMonkey

    Wednesday, September 14, 2016 8:25 PM
  • As far as I was aware update will update an existing task. But you would need to create it in the first place. in the preferences there should be the option to update / create and delete.

    Also I use NT Authority/system account for any administrative tasks like shutting down / rebooting etc.


    GPO preferences is where you create the scheduled task.
    Wednesday, September 14, 2016 9:50 PM
  • > The error is something about the account not being recognized.
     
    Might be "the account needs the right to logon as batch job"? :-)
     
    Thursday, September 15, 2016 8:43 AM
  • I'm not sure without seeing it. But generally when you create the scheduled task in group policy preferences you have the section where you specify the account to use in the scheduled task settings. Here you could change this and just type: system

    also allow the check box that says allow task to be run even if the user is logged off.

    Thursday, September 15, 2016 10:26 AM
  • Thank you both for your help on this.  I have rebuilt the test box and can now be specific.

    • The task is set to UPDATE, and should be creating it
    • I changed the task to runas SYSTEM
    • The specific error I get (NOT from rsop.msc, but from the task scheduler) is;
    •       An error has occurred for task append to log. Error message: The specified account name is not valid.

    BlankMonkey

    Thursday, September 15, 2016 2:51 PM
  • Does this help at all : see images

    Thursday, September 15, 2016 3:07 PM
  • Thursday, September 15, 2016 3:08 PM
  • >   * I changed the task to runas SYSTEM
     
    Did you type this in or select via [...]?
     
    Thursday, September 15, 2016 3:23 PM
  • OK, life is getting interesting.

    I typed in SYSTEM.  The error occurred (and I see it in Task Schd), BUT the task ran.

    I changed to (cut and past) NT Authority/system.  The error occurred, and the task did NOT run.

    I deleted ALL tasks and reset to BUILTIN\SYSTEM (by selection).  The task now does not show up in the task scheduler at all, the system did NOT reboot, and I continue to get the error.


    BlankMonkey

    Thursday, September 15, 2016 3:43 PM
  • No, the create made no difference :(

    BlankMonkey

    Thursday, September 15, 2016 5:34 PM
  • can you screenshot that account not being recognized error?
    Thursday, September 15, 2016 6:41 PM
  • Not easily, its on a test box in an insecure network.

    But the text is as precisely written as I can make it


    BlankMonkey

    Thursday, September 15, 2016 7:12 PM
  • This is a different issue.  The test machine I was working on has was a BAD image, so there was something more fundamental wrong under the hood.  I have purged the image and am starting fresh with a new computer.

    BlankMonkey

    • Marked as answer by BlankMonkey Monday, September 19, 2016 2:40 PM
    Monday, September 19, 2016 2:40 PM