none
Memory usage on SharePoint 2013 application server

    Question

  • Hi,

    In SHarePoint 2013 farm, application server is utilizing maximum memory(16gb). Previously it was not like, I am seeing this issue since past couple of days and as per my knowledge we didn't change anything on the server.

    Even If I restart the server, initially it is utilizing 5 to 6 gb out of 16gb and later gradually it is increasing to 16gb.

    May I know what could be the reasons?

    Any help would be greatly appreciated.

    Thank you.


    OK29

    Tuesday, April 18, 2017 1:44 PM

All replies

  • That isnt' necessarily a bad thing. SharePoint is supposed to make use of as much memory as it thinks it can make use of.

    The first thing to do is to check which services are using the memory.

    To see if it is an error you'd need to do some moderately in depth checks, i'd start with the memory fields from the Performance and Logging (PAL) tools, there are some excellent templates in there that let you see what is happening in your memory and to try to work out if it's working as hoped or high because of errors.

    Also is this a single server farm or is it an application server in a multi server farm?

    Tuesday, April 18, 2017 1:50 PM
  • Hi Alex,

    Thank you for your comments. It has 1 Web SErver, 1 App SErver and 1 DB server.

    In my company, Servers Operations team using Nagios for monitoring but I do not have access for that tool. 

    Is there any way to find on server itself?

    Thank you,



    OK29

    Tuesday, April 18, 2017 2:40 PM
  • 1st step check which process is consuming the memory? Open the task manager on the server and look for which process is consuming the memory...

    Please remember to mark your question as answered &Vote helpful,if this solves/helps your problem. ****************************************************************************************** Thanks -Waqas Sarwar(MVP) Blog: http://krossfarm.com

    Tuesday, April 18, 2017 2:44 PM
    Moderator
  • Thank you Sarwar for your comments.

    I did check the task manager and found the noderunner is using more memory and followed below steps to fix the issue.

    Noderunner.exe is set to “0” by default, which means unlimited memory usage. Reduced Noderunner memory usage to 1024.

    Opened noderunner.exe config file and updated the <nodeRunnerSettings memoryLimitMegabytes="1024" />

    noderunner path: 

    DRIVE:\Program Files\Microsoft Office Servers\15.0\Search\Runtime\1.0



    OK29

    • Marked as answer by OK29 Tuesday, June 06, 2017 9:46 PM
    • Unmarked as answer by OK29 Tuesday, June 06, 2017 9:46 PM
    Tuesday, June 06, 2017 9:46 PM
  • Setting memoryLimitMegabytes is not supported and will most likely lead to noderunner crashing with out of memory errors.

    Trevor Seward

    Office Servers and Services MVP



    Author, Deploying SharePoint 2016

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Tuesday, June 06, 2017 11:26 PM
    Moderator