UM Problem - XXXX is not a valid mailbox extension



    I am having a UM problem.  We deployed some people from using avaya phones over to all ocs client.  When I disabled UM and reenabled with the OCS UM Policy, I have one user who tries to call our VM extension and they enter their extension and they receive an error stating =


    (insert extension here) is not a valid mailbox extension.


    However if you call their extension and do not answer the phone, it will roll to the UM Voicemail.  Any suggestions on how to fix this?

    Monday, August 25, 2008 6:18 PM

All replies

  • As far as I know voice mailbox is found by OCS through lookup of SIP-Address. Have a look at the EUM-Address of this user if it has the right extension configured.





    Tuesday, August 26, 2008 11:26 AM
  • I'm facing the same problem.

    If i dial the extension, and do not answer the call, it will go to VoiceMail and i'm able to leave a voicemail and receive the voicemail in my Exchange Inbox.

    But if i dial the UM Pilot it prompts me for my extension but I will get "(insert extension here) is not a valid mailbox extension."

    Anyone have any resolution for this?

    Wednesday, September 22, 2010 9:40 AM
  • If you have multiple UM dial plans then you will need to dial into the UM dial plan that is associated with the mailbox in question.
    Wednesday, September 22, 2010 2:30 PM
  • If you have multiple UM dial plans then you will need to dial into the UM dial plan that is associated with the mailbox in question.

    ... or add multiple EUM "e-mail addresses" to the user's account. Use the same extension number, but add one for each dial plan.

    Here's mine: x639 in 2 dial plans, as well as the SIP one for Lync:


    Tuesday, May 15, 2012 11:08 PM
  • Ensure the UM account/User account is not 'disabled' in Active Directory.

    Find the account, right-click and if 'Enable' is an option on the context menu, then the account is disabled and you will get this error message.  Also the icon will show a small down arrow on it in Active Directory.


    • Proposed as answer by DanRichter Wednesday, May 14, 2014 9:34 AM
    Tuesday, July 30, 2013 2:12 PM
  • The suggestion to add multiple EUM addresses to the account can work but would be difficult to maintain.  I have found you need to have the Pilot Identifier set properly in your hunt group, especially if you have more than one associated with an IP PBX or gateway.  That fixed it for me.

    Tuesday, August 20, 2013 5:37 PM
  • I'm having this problem as well. Did you ever find a solution?

    Adam Desmond

    Saturday, January 25, 2014 4:35 PM
  • Hi,

         I have the same issue and adding  the previous EUM address does fix my issue but we will be removing the 2nd EUM dial plan once we complete our migration of all users to Lync EV.  For the new UM Hunt group,  what need to be enter as the pilot indentifier,?  If our SA number is 12345, is that what must be enter as the pilot indentifier?  We currently have the DialPlan name entered as the Pilot Indentifier.   Thank you.  

    BTW - the default Hunt Group, has no Pilot Indentifier set. 

    Wednesday, February 12, 2014 4:48 PM
  • Hi, I have exactly the same issue. I deleted and recreate the IP GW and Hust Group (default) but the same. The EUM Address of my Users are correct, the data is on the Active Directory and the Users account are enabled and operating. I have only one Dial Plan. Any idea for solve this?


    Friday, November 06, 2015 12:39 AM