none
You can not join a computer that uses Windows 7 pro to domain RRS feed

  • Question

  • I have a win 7 pro  device joined the domain, and then changed the server, domain, and I want to enter it again, but I could not as it appears at the top of the dialog box, contain it can not join a computer that uses Windows 7 Pro to domain
    I need help
    Sunday, September 13, 2015 8:44 AM

All replies

  • Can you provide some screen shot so i can understand better?
    Sunday, September 13, 2015 11:58 AM
  • I'm sorry I can not add an image
    A message appears(body text cannot contain images or links until we are able to verify your account

    Monday, September 14, 2015 7:36 AM
  • You can try with actions below.

            • Make sure NETLOGON service is set to automatic 
            • Join the PC to Workgroup
            • Remove Antivirus
            • Restart
            • Make sure you can ping your DNS server
            • Change your computer name and try adding to domain again



    Monday, September 14, 2015 8:21 AM
  • Hi,

    Firstly, could you send your error message to us so that we can help you better? Before we know that, I suggest you can try the ways below to troubleshoot.

    Open “Network and sharing center” > “Local area connection” > “Properties”, just uncheck “Internet Protocol Version 6”. Then double click “Internet Protocol Version 4”, and choose “Obtain DNS server address automatically”.

    If it doesn’t work, you need flush your DNS cache in client side.

    http://www.noip.com/support/knowledgebase/how-do-i-flush-my-windows-dns-cache/

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Then, let’s create the following registry value for a try:

    HKLM\System\CurrentControlSet\Services\LanManWorkstation\Parameters

     

     - Created a DWORD DomainCompatibilityMode = 1

     - Created a DWORD DNSNameResolutionRequired = 0

    Reboot the machine and check the result again.

    Wish you will troubleshoot the issue smoothly.

    Best Regards

    Simon  


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, September 15, 2015 1:11 AM
    Moderator
  • I do all these actions and the problem is still ongoing

     note:I use google translation of the understanding with you because I Arabic user

    Tuesday, September 15, 2015 8:15 AM
  •  error message (you cannot join a computer running windows 7 professional to a domain)

    Open “Network and sharing center” > “Local area connection” > ................... address automatically”.

    If it doesn’t work, you need flush your DNS cache in client side.

    I did that and the problem is still ongoing 

    Then, let’s create the following registry value for a try:

    HKLM\System\CurrentControlSet\Services\LanManWorkstation\Parameters

     - Created a DWORD DomainCompatibilityMode = 1

     - Created a DWORD DNSNameResolutionRequired = 0


    I dont understand that Can you explain That please

    Tuesday, September 15, 2015 8:39 AM
  • Hi,

    Thank you for your feedback. Do you mean you don't know how to perform the steps in registry or the theory of the steps?

    In addition to that, Why don't you choose the language at the right of forum interface and then post question for support? Maybe there is a Arabic supporter for you.

    Best Regards

    Simon


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, September 15, 2015 8:58 AM
    Moderator
  • thank you for all

    don't know how to perform the steps in registry

    I chose English supporter because the solutions and interact more

    Tuesday, September 15, 2015 9:09 AM
  • Hi,

    Thanks for feedback.

    Firstly, click "Start", then type "regedit" in search box and press enter. You will come to the registry interface.

    Then in the list left, find the folder according to the path which I give you before.

    HKLM\System\CurrentControlSet\Services\LanManWorkstation\Parameters

    After you find the folder, click it. Then right click the blank area at right of the window > “New” > “DWORD Value”. Type name “DomainCompatibilityMode”. Click the value, and type “1” in value data box > “Ok”.

    Then right click the blank area at right of the window > “New” > “DWORD Value”. Type name “DNSNameResolutionRequired”. Click the value, and type “0” in value data box > “Ok”.

    Then reboot the computer and check the result.

    Best Regards

    Simon


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    Tuesday, September 15, 2015 9:50 AM
    Moderator
  • Do you have the admin rights for the PC?

    BasementMouse

    Tuesday, September 15, 2015 9:58 AM
  • Then, let’s create the following registry value for a try:

    HKLM\System\CurrentControlSet\Services\LanManWorkstation\Parameters

     - Created a DWORD DomainCompatibilityMode = 1

     - Created a DWORD DNSNameResolutionRequired = 0

    Reboot the machine and check the result again.

    I did that and the problem is still ongoing 

    Wednesday, September 16, 2015 6:17 AM
  • yes, i have the admin rights for the pc
    Wednesday, September 16, 2015 6:18 AM
  • To illustrate the problem more

    Device works like an win 7 home

    i can not click on domain

    Wednesday, September 16, 2015 6:56 AM
  • Usually I remove workstation from domain. It joins workgroup that I set. Then I can join workstation to new domain (active directory).

    Do not forget to change DNS settings to point to new server and delete DNS cache on workstation (ipconfig /flushdns). If you have DHCP, then release first and then renew. Do not use DHCP from Internet router.

    Do not use public DNS settings in TCP/IP specifications.

    If nothing helps, use network monitor to analyse what happens (Wireshark will do the job.)

    Regards

    Milos

    Wednesday, September 16, 2015 7:27 AM
  • thank you

    a workstation now joined to workgroup but can not join to domain

    Do not forget to change DNS settings to point to new server If you have DHCP, then release first and then renew. Do not use DHCP from Internet router. Do not use public DNS settings in TCP/IP specifications. If nothing helps, use network monitor to analyse what happens

    I'm sorry i cannot understand that can you explain that pleas (steps by steps )

    • Edited by foollhh Thursday, September 17, 2015 4:56 AM
    Wednesday, September 16, 2015 8:52 AM
  • :( :(  :(
    Wednesday, October 7, 2015 5:37 AM