none
MS Project 2010 Error Using "Import Wizard - Task Mapping" via ODBC Connection to Access 2003 / 2007 Database and Excel 2010 / CSV RRS feed

  • General discussion

  • I recently upgraded my MS Project application on my Windows XP (Service Pack 3) laptop from MS Project 2003 to 2010.  During the upgrade MS Project 2010 asked if I wanted to import any customized settings / changes from 2003; I accepted defaults and went on (not sure if this has anything to do with it...just background).  This evening I've been trying to connect my MS Project file to my Access database. Steps below cover the Access Database situation...but one of the troubleshooting steps was to see if I could open an Excel 2010 or CSV file into MS Project 2010.  Neither of those would import and gave the same error listed below.

     

    ODBC Connection Setup.

    • Configured under System DSN: Driver: Microsoft Access Driver (*.mdb, *.accdb) Version 14.00.4760.1000 (Date 3/22/2010)

    MS Project 2010 Steps to Reproduce Error:

    1. Open MS Project 2010
    2. File > Open > ODBC > Machine Data Source > Project Portfolio 2003 > Open
    3. Import Wizard > Next > New Map (or existing) > Next > As New Project (2010) or My Project File Created in MS Project 2003. (Note - I selected "As new project for this walkthrough) > Next > Select Tasks
    4. Click Next
    5. Source Database Table Name - Select table name from Access Database (in my instance it's called tbl_pp_baseline).
    6. All the fields in the table are displayed with some automatically being mapped to matching fields in MS Project 2010.
    7. If I click the drop down next to the first field in the "From: Database Field" which contains a field name: Request_Number...and reselect Request_Number I get the following error.

    -------------------------

    The field "" does not exist

    click a field name in the list, and then press Enter

    (CLICK OK)
    -------------------------

    I've tried several things...

    1. Deleting the auto-populated field names in the From: Database FIeld column and manually adding them back.  Got the same error message.
    2. Unisntalled the Microsoft Access ODBC Drivers and installed the latest 2010 found here (Microsoft Access Database Engine 2010 Redistributable).
    3. Converted the 2003 Access database to 2007 and got the same errors when importing.
    4. Started with a black 2007 and 2003 database with simple table and got the same errors.
    5. Then tried to import a Excel 2010 and CSV file into MS Project 2010 by opening each.  Both will fail on import as well...giving the same error message above. 

    Observations:

    • The only way I can enter the field i wanted to add in the From: Database Field column without generating the error...is by manually typing in the field name in the field above with the "red X" and "green check mark".  I've noticed when doing that it...after typing in "Request_Number" and tab...the value in that field adds a space in front...looking like this " Request_Number" (there's a space before the R). 

    Any help provide would be much appreciated.  I don't think I'm doing anything out of the ordinary.  I'm using all Office 2010 products (MS Project 2010, Excel 2010 and Access 2010).  I basically want to import a simple table into MS Project 2010 daily directly from Access using ODBC. 

     

    Are there any known issues with importing into MS Project 2010 where an error like this would be given during the Import Mapping Wizard?

     

    Thanks for your help and consideration in advance.

    Bill

    Wednesday, May 18, 2011 1:58 AM

All replies

  • I've been playing around with this a little further.  It seems when I try to import data from a table within Access or open from an Excel file - any field in the source table that does not match a field (by name) in MS Project 2010...i get the following in the Import Wizard Mapping.  Two example fields below where I setup the "Saved Map" to map them to the Finish and Start Date within MS Project. I'm starting to wonder if there's a problem in MS Project 2010 with the saved MAP feature.  I've created a new map multiple times.  The first time i import it works fine.  The second time it shows these fields out of context and doesn't stick with the mapping i saved.  Hope that helps.  Any recommendations?

    • OUT OF CONTEXT:Finish_Date
    • OUT OF CONTEXT:Start_Date

     Thanks,

    Bill

    Wednesday, May 18, 2011 3:22 AM
  • Wednesday, May 18, 2011 4:42 AM
  • Bill,

    I'm having the same problem after switching from Project 2003 to Project 2010 and was wondering if you ever resolved your issues with importing from Access.

    Thanks.

    Jay Scott

    Monday, November 21, 2011 7:53 PM