none
VHD must be uncompressed and unencrypted

    Question

  • So, I am attempting to do some rather substantial upgrades to a local school district; moving them from old servers running hyperV on Server 2008 (some core, some standard) to new ones running Server 2012 r2

    Obviously, issue are expected as there is no direct upgrade path from 2008 to 2012r2.  But I thought we could failrly easily make a new VM and simply import the VHDs.  But when turning on the VM I get an error saying

    "
    x failed to start.
    Microsoft Emulated IDE Controller (instance bla bla bla): Failed to Power on with error "The requested operation could not be completed due to a virtural disk system limitation. On NTFS, virtuar disk files must be uncompressed and unencrypted.  On ReFS, virtual hard disk files must not have the integrity bit set".

    etc. etc. etc.
    "

    So, I looked around on the web and found that this can happen if the 'compress files' option is checked on disk properties.  So I fired up the VM on the old box, and looked, but that setting is not checked.

    I downloaded the VHD recovery tool that MS suggests, and it seems to have no issue looking at the files on the drive.  But as the process of buying software takes 2-3 weeks I can't realistically get a licence to use that to recover anything.  And again, it works perfectly fine on the older 2008 system.

    Any thoughts and ideas on what is going on would be greatly appreciated!

    Daniel

    Sunday, February 12, 2017 4:27 PM

Answers

  • Hi Daniel,

    The error message is talking about the setting of the VHD file.

    Right click on the VHD file, click properties. On General tab, click Advanced and check if the Compress or Encrypt is selected.

    Best Regards,

    Leo


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by CaedenV Friday, February 17, 2017 5:52 PM
    Monday, February 13, 2017 3:08 AM
    Moderator

All replies

  • Hi Daniel,

    The error message is talking about the setting of the VHD file.

    Right click on the VHD file, click properties. On General tab, click Advanced and check if the Compress or Encrypt is selected.

    Best Regards,

    Leo


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by CaedenV Friday, February 17, 2017 5:52 PM
    Monday, February 13, 2017 3:08 AM
    Moderator
  • Check your VM's permissions for that VHD also.

    If you created a new VM and want to just attach the VHD, don't use import, just browse to the VHD and attach it.

    Monday, February 13, 2017 3:14 AM
  • Ah! ok that was the root of the issue!

    So the VHDs themselves were not set to compress, but the RAID they were stored on was set for compression.  Turned it off (which took a while) and now everything is importing properly!

    Thanks for the help!

    Caeden

    Friday, February 17, 2017 5:52 PM