none
DPM 2016 - Stuck on Calculating Disk Storage Allocation

    Question

  • DPM Server 2016 is running on a Windows 2016 Hyper V Host in a Windows 2016 Guest VM

    Creating a new Protection Group consisting of partial volumes of a Windows 2008 R2 (physical server).  It's been stuck on Calculating Data Size on the "Review Disk Storage Allocation" screen of the Create New Protection Group wizard.  It does this every time I attempt it for that server needing protecting.  It never finishes. The total data size on disk is 1.2TB of a 1.4TB disk.


    (This current time, its been at least 5 hours)
    • Edited by Vince P Tuesday, November 22, 2016 10:54 PM
    Tuesday, November 22, 2016 10:53 PM

All replies

  • Same problem here. Did you find any resolution?

    Our total file data size on disk is about 9TB.

    Wednesday, January 4, 2017 1:33 PM
  • Any comments from MS about this issue?

    Thursday, January 5, 2017 2:52 PM
  • Also same problem.
    Wednesday, January 11, 2017 5:08 PM
  • We used to have this with DPM 2012R2 on our big file server. The solution: Just wait and go home. Next day i could finish protecting the data.


    Thursday, January 12, 2017 6:16 PM
  • Same problem here. We have a >1TB file server with deduplication. I'm trying to set up the backup for days. I have waited patiently, but when it finally finished it throw an exception that the agent timed out and did not respond, end closes the whole management console. I don't know what to do.
    Friday, January 20, 2017 12:57 PM
  • We did not take backup of the hole drive. Only some of the folders. If we take backup of the entire drive then it can make the calculating and backup is running without problem. In Microsoft's world 10 TB is huge data..... And DPM is not happy with huge data.... 
    Monday, January 23, 2017 8:20 AM
  • Update: I've created a protection group with only one folder (not the entire drive). This way it successfully created the protection group. After that I started to add folders one-by-one. It successfully added them. As I see the disk allocation it really happened. But I cannot see the newly added folders on the recovery tab, just after a while (next day or so) when a full backup cycle happened. (confusing)
    Monday, January 23, 2017 9:45 AM
  • MS-Case is still in progress (~3 weeks). Workaround didn´t fix the problem. Waiting for a solution........
    Tuesday, January 24, 2017 7:49 AM
  • Roland, out of curiosity, is your case a Premier case?  We're going to open a case too (with Premier) and escalate with our TAM.

    Thanks.

    Tuesday, January 24, 2017 2:56 PM
  • Yes, it is a premier case.
    Tuesday, January 24, 2017 3:03 PM
  • Thanks, Roland.  I wish there was a way to private message in these chats so we could share notes and get our TAMs working together to push the product group.  Do you know of a way?
    Tuesday, January 24, 2017 3:53 PM
  • Case has been escalated to highest level. Looks like a code defect. A possible workaround will not be available.
    Wednesday, January 25, 2017 5:59 AM
  • Update Rollup 2 for DPM2016 available, BUT the UR2 will not solve the issue.

    Before you install the update, make a backup of the DPM-Database!

    https://support.microsoft.com/en-us/help/3209593/update-rollup-2-for-system-center-2016-data-protection-manager

    The development team is working on a fix.......

    Monday, February 13, 2017 10:27 AM
  • Hope this issue gets resolved asap, trying to migrate from 2012R2 to new 2016 DPM server and it making me nervous waiting for DPM to calculate space while me server is sitting unprotected in the meantime...
    Tuesday, February 14, 2017 9:46 AM
  • Morning All 

    i have been working on an issue that saw this behavior ( it may not be the same )  on a fresh install. Server 2016. DPM 2016. 

    First thing - you need to make sure that your using ReFs formatted volumes instead of disks. What i found during troubleshooting was that although in disc manager it was initially showing as basic when trying to add disc storage DPM would present you with  the below pop up 

    so you think ok its must be fine DPM is asking me if i want to convert it for it to use, so you choose yes, the wizard continues and you get stuck on calculating. 

     

    and does eventually either crash the mmc or falls over 

    So i asked myself 

    why would dpm be happy about me converting the disk to dynamic when i know that DPM needs it not to be ? why would it actually happily let me carry on at this point ?  

    why is it complaining about the amount of space available when there is plenty 

    so digging a bit deeper and looking at the documentation more closely if your using server 2016 and dpm 2016 you should not be using disk storage it needs to be volumes.   

    The volume(s) must not reside on a Windows Dynamic Disks, just a basic disk which should be GPT if the disk is 2TB or larger.  Add the volume(s) to the DPM storage pool.

    now when you go through the wizard rather than selecting add disk storage which is seems to default too, choose add a volumes at the top right of the add storage window . carry on through the wizard and happy days it runs through without an issue. 

    i know this is not identical to what every ones seeing but this may be the answer to the behavior some one else sees and help them out. 

    • Proposed as answer by Thomas_EBG Sunday, April 9, 2017 2:49 AM
    • Unproposed as answer by Thomas_EBG Sunday, April 9, 2017 2:49 AM
    Monday, February 20, 2017 9:52 AM
  • I also have this issue. When creating a new PG certain VMs show as having 0KB data size.
    Monday, March 6, 2017 11:36 AM
  • The DPM Product Group is still working with the ReFS Team in order to optimize this process!
    Monday, March 6, 2017 2:18 PM
  • Fix still in Progress....

    Workaround:

    In the wizard -> Select Group Members -> you have to select the volume (drive letter) and then unselect the not needed folders and files

    The Review Disk Storage Allocation finishes immediatley!


    • Edited by roland2399 Monday, March 13, 2017 9:33 AM
    • Proposed as answer by RandomJohn Tuesday, March 28, 2017 9:32 PM
    Monday, March 13, 2017 9:32 AM
  • We have the same problem.

    DPM 2016 UR2. One folder, about 3Gb in size that have a lot of xml files (about 350 000).

    roland2399`s workaround don`t suit for us, cause we have to backup that folder.

    Tuesday, April 4, 2017 2:03 PM
  • The problem will be fixed in UR3!

    But in the meantime you can also try this:

    To re-add the sizes to the datasources please take the following steps:

    -          Open registry and delete the following key: HKLM:\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Configuration\DiskStorage

    -          Restart DPM server and calculation will resume the normal behavior. This may take a while before all datasources are calculated.

    Tuesday, May 16, 2017 12:39 PM
  • Tks. This alternative solution worked for me!

    Nicholas Marshall Micaloski | MCT, MCP, MCTS, MCITP, CompTIA N+

    Thursday, June 22, 2017 2:56 PM
  • That didn't work for me. I had the same issue with DPM 2016 UR4 installed and I couldn't backup Hyper-V cluster VMs.

    I reinstalled UR4 which fixed the problem for me.

    Tuesday, March 13, 2018 2:58 PM
  • Trying to backup a shared folder (home directories of users ~6TB) of a physical fileserver cluster. DPM stucks at "Review Disk Storage Allocation" for 7 hours now. So, I guess we ran into the same issue :-(

    Based on what I've learned from the comments, this is what I'm going to try:

    1. Going home and check tomorrow
    2. Select a few folders first and add the rest later
    3. Delete the following key: HKLM:\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Configuration\DiskStorage
    4. Reinstall DPM

    We are currently in a PoC. This issue can be a show stopper indeed. Our DPM 2016 is version 1801 and is running on a physical host with a 70TB storage pool as backup target. Other jobs work well, but do not include such a huge folder.

    Monday, March 26, 2018 3:11 PM
  • as mentioned by Roland2399 above, his workaround worked for me.  Select the entire volume or drive letter and deselect what you don't want to back up.  

    Thomas N

    Monday, March 26, 2018 3:29 PM
  • This workaround wouldn't work for me as I cannot exclude the profiles of some users. I have to backup the whole directory.

    However, I was successful applying workaround 2 mentioned in my comment above: "Select a few folders first and add the rest later".

    It seems the algorithm that calculates the overall disk size while creating a protection group is not very efficient. It ends up in a timeout in case there are too many files and folders in your selection set.

    So what I basically did was, I created an empty folder within the directory and selected this one only. Right after creating the protection group (which finished immediately as nothing had to be calculated) I changed the selection set of the protection group and selected the whole root folder. I launched a consistency check and DPM started to copy files over the wire. It took me three attempts until everything has actually been replicated. From there on synchronization and creation of restore points work like a charm :-)

    Friday, April 6, 2018 2:38 PM
  • One thing to add: It definitely makes sense to use the script from https://blogs.technet.microsoft.com/dpm/2017/04/14/how-to-increase-dpm-2016-replica-when-using-modern-backup-storage-mbs/ in order increase the replica storage size. Otherwise it takes ages to replicate data for the first time as DPM does increase the storage quota each 15 min in small chunks only. It avoids getting the error message: "DPM is out of disk space for the replica. (ID 58 Details: There is not enough space on the disk (0x80070070)) 2016"
    Monday, May 7, 2018 3:44 PM