none
Cannot paste in a cmd window RRS feed

  • General discussion

  • I recently lost the ability to paste inside a CMD window.  I have always had this capability and can still do it from other machines.  Quick Edit and Insert modes are on.  I can copy and paste anwhere else in the UI.  I can copy and paste within the CMD window.  I just cannot copy and paste from outside the CMD window to within the cmd window.  I live inside the CMD window so it is a real nuisance to have lost this.  Any ideas?  Also, this happens regardless of permissions.  Same results on this system whether or not I have admin priivileges and happens if I run a standard cmd window or if I run as an Administrator.  Does not matter whether I right click in the cmd window or Edit\Paste.  When I do Edit\Paste, Paste is available and not greyed out but it does not do anything.  If go to say notepad, I can paste the contents there, so I know the data is still in the clipboard.  Any help would be greatly appreciated.
    Wednesday, April 8, 2009 3:06 PM

All replies

  • One additional observation.  If I disable UAC and reboot, I can then paste in the cmd window.  Once I re-enable UAC I lose the ability to paste in the cmd window.  I can't keep UAC disabled becasue it is against company policy.  And it worked fine for over a year with UAC enabled. The has to be some registry setting or local policy that controls this.  I just can't seem to find anything on it.  I have found others in various forums reporting the same problem but have never yet seen any solution. 
    Friday, April 10, 2009 1:41 AM
  • Hi, thanks for the post. As the issue has been narrowed down as UAC related, you can try: type "cmd" in Start Search, on the panel, right click on "cmd" icon and choose "Run as Administrator" and check if this works properly.


    Sean Zhu - MSFT
    Friday, April 10, 2009 2:48 AM
    Moderator
  • Hi Sean,

    I tried that but it still does not allow the paste.
    Friday, April 10, 2009 7:30 PM
  • Have you tried "Run as Administrator" on source application? For example, you can use "Run as Administrator" to open Notepad, copy, open cmd by "Run as Administrator" and paste.


    Sean Zhu - MSFT
    Monday, April 13, 2009 8:58 AM
    Moderator
  • I tried that as well, ran notepad using "run as administrator", copied data, opened cmd prompt using "run as administatrator", still could not paste in CMD window.  I could paste everywhere else. 
    Monday, April 13, 2009 4:28 PM
  • After reading similar threads in different forums with the same problem and no resolution, I ended up rebuilding my system to fix this.  But this is not really a solution if the action is to rebuild.  At this time I know of no root cause or resolution to this problem.
    Monday, April 20, 2009 11:06 AM
  • Well, Its just the way microsoft have decided to have it. Maybe its for security reasons but whatever it is maybe it will be changed in upcoming updates or / and even Windows 7.
    Wednesday, April 22, 2009 3:54 PM
  • There is another temporary solution. Dissable UAC, run your task, then re-enable UAC. when you are finished
    Diana
    Sunday, May 3, 2009 10:11 PM
  • Rediculis that the only fix is to rebuild.

    WOW :(

     

    Tuesday, January 4, 2011 6:55 PM
  • greetings everyone...

    simply..the solution is to copy the text you want...then open a command window...then RIGHT CLICK ON THE MOUSE...so it is pasted    

    Saturday, March 29, 2014 7:24 PM