locked
Remap Heading Styles RRS feed

  • Question

  • I would like to repurpose Alt+Ctrl+# keys to run macros I have written that convert hard typed numbers to Heading styles.  I already have Heading Styles applied to normal text with Alt+# keys.  For example, Alt+Ctrl+1 would ideally run MY macro that converts the text to Heading 1 style (as well as remove the tabs and hard text for the number). 

    I store them in a global template that is saved in the Startup directory.  When I assign keystrokes to the macros, it indicates the keystroke is currently assigned to "Heading Style 1" for example.  So I press to REASSIGN. 

    But it still does not run the macro.  If I Alt+F8 to run the macro manually, it does as expected.  It shows the macros are assigned in the global template. 

    If I go into Normal, it shows the Styles are still assigned to the Ctrl+Alt+# keystroke, even if I delete Normal and let it rebuild.  I then tried pressing REMOVE to delete all keystrokes from Normal, but the macro still does not run with Alt+Ctrl+# assigned in the global template.

    I used to do this in Word 2003 with no problem.  Please advise.

    Monday, August 19, 2013 10:48 PM

All replies

  • Hi,

    Which version do you use now? Please try to reset all (Here is an instance of Word 2013):

    1. Click FILE -> Options;

    2. Click Customize Ribbon at the navigation pane of the left;

    3. Click Customize... button next to Keyboard shortcuts;

    4. Select Macro from Categories under Specify a commands;

    5. Click Reset All... button;

    6. Click Close;

    7. Click OK;

    8. Restart Word and check the result.


    Karen Hu
    TechNet Community Support

    • Proposed as answer by Karen Hu Tuesday, August 27, 2013 7:07 AM
    • Marked as answer by Tony Chen CHN Thursday, August 29, 2013 4:30 AM
    • Unmarked as answer by orlandp Wednesday, September 4, 2013 5:23 PM
    Wednesday, August 21, 2013 1:18 AM
  • This did not work.  Still unable to reassign the Alt+Ctrl+# keys.  They revert back to applying the Heading styles.  We use Word 2010.
    • Edited by orlandp Wednesday, September 4, 2013 5:24 PM
    Wednesday, September 4, 2013 5:23 PM
  • What you describe suggests that a poorly designed add-in is preventing you from saving the Normal template correctly. Open the Normal template as a document (via File | Open) and then recreate the shortcuts.

    You should also get rid of the problematic add-in. For assistance with troubleshooting startup and COM add-ins, take a look at http://support.microsoft.com/kb/921541/en-us.


    Stefan Blom, Microsoft Word MVP

    Wednesday, September 4, 2013 6:09 PM