none
IE8 - Win XP Pro SP3 - Certificate error that I -DO- want RRS feed

  • Question

  • OK, here's a good one.   I have a website I go to for WebMail.  I sometimes need to use webmail over Outlook.  This server does not have a certificate, due to the cost to the hosting party who is providing support for free.  The webserver supports a number of non-profit entities of which we are one at our Assistance Center (AC).  He has me specifiy the port number after the address to gain access to a "backdoor" for webmail.  Previous to IE8, IE7 was able to take the address, go to the site, get a certificate error, I'd click go ahead anyway (because it is trusted - I know the guy) and pull up my username and login panel and continue on to eMail.

    With IE8, I can no longer do this.  When I type in the URL, I go to an immediate "Internet Explorer cannot display the page".  I don't get the cert error page.  Here's a list of the systems I have tried this on.

    Main House computer - Win XP SP 3 - IE8 - all patches up to date.

    Supplemental House desktop - Win XP SP 3 - IE8 - all patches up to date.

    Third House desktop - Win XP SP 3 - IE 8 - all patches up to date.

    AC workstation - (not on my home network) Win XP SP 3 - IE 8 - all patches up to date.

    Home laptop - Win XP SP 3 - IE 8 - all patches up to date.

    Home lab - Win 7 SP1 - IE 9 - all patches up to date - See below *

    OK, let's try another browser:

    Main House computer - Firefox - yields the cert error and allows me to bypass to the login page.

    Third House desktop - Chrome - yields the cert error and allows me to bypass to the login page.

    AC workstation - Chrome - yields the cert error and allows me to pass to the login page.

    Home Adroid tablet - Android Browser - yields the cert error and allows me to pass to the login page.

    * Home lab - Win 7 -  IE 9 - I do get the cert error but clicking to bypass does nothing but leave me on the cert error.

    So what do we see as the common thread here?  IE8, (or IE 9 for Win 7) I suppose.  I can discount a home networking/firewall problem because I tested at the AC on a completely different network.  On each (you can see I've been at this a while):  I have ensured that the time and date are valid and are updating via the same web time base.  I have attempted to go to Tools > Internet Options (IO) > Advanced and tick on/off "Check for publisher's certificate revocation" and "Check for server certificate revocation" independently and together with an IE restart on each iteration.  I have turned on/off SSL2.  I have placed the URL in the Trusted Sites zone.  I have cleared the SSL state cache.  I have run IO > Delete to clear the caches.

    I am retiscent to show the url in the open since this is a backdoor of sorts.  It goes like this: https://xxxxxxxxxxxxx.com:20000   This is the only non-certificate website I use thus it is the only time I have this issue.

    Can anyone help me make sense of this?  It's not one computer or one instance of IE8.  It's really got me stumped (and the web server owner as well).

    HoibO


    • Edited by HoibO Tuesday, March 5, 2013 2:48 AM Typos
    Tuesday, March 5, 2013 2:43 AM

All replies

  • Hi ,

    You may test the issue in IE7 Compatibility Mode.

    Please refer to the part of Compatibility Lists (“Emulate IE7” mode) in the following link:

    http://blogs.msdn.com/b/askie/archive/2009/03/23/understanding-compatibility-modes-in-internet-explorer-8.aspx


    Tracy Cai
    TechNet Community Support

    Wednesday, March 6, 2013 6:29 AM
    Moderator
  • Not a compat view issue.  I went in and set Compat View for all websites, reloaded IE, called the troubled website.  Still shows "IE cannot display the webpage"  In fact when I get this error, Compat View isn't even selectable which I read to mean this "error page" doesn't require a compat view button as it's greyed out in IO.  You have to have a valid page that needs compat view displaying before compat view button is active.

    I guess I really don't understand how Chrome and Firefox and my Android can get the results and IE8 cannot (or easily do so).

    Any other suggestions?

    H


    • Edited by HoibO Wednesday, March 6, 2013 1:25 PM
    Wednesday, March 6, 2013 1:14 PM
  • Well, it's been a week now and no reply.  What do I do next.  I still have this problem and am without any substantive solution.  I realize it's busy here and it's something we all have to live with.  But, this is the kind of odd behavior that turns people off to IE and makes it so hard to resist alternative browsers that "just work".

    What would be my next move?

    H


    HoibO

    Wednesday, March 13, 2013 1:03 PM
  • I'm trying to involve someone familiar with this topic to further look at this issue. There might be some time delay.

    Appreciate your patience.


    Tracy Cai
    TechNet Community Support

    Thursday, March 14, 2013 3:04 AM
    Moderator
  • Reset IE settings to default, then try again.

    Regards,

    Diana


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by tracycaiModerator Thursday, March 21, 2013 8:00 AM
    • Unmarked as answer by HoibO Tuesday, April 9, 2013 10:30 PM
    Friday, March 15, 2013 10:20 AM
  • I'm trying to involve someone familiar with this topic to further look at this issue. There might be some time delay.

    Appreciate your patience.


    Tracy Cai
    TechNet Community Support

    @Tracey Cai - I wonder if you've heard from your "people" on this issue yet?  It is still an issue with me and now with someone else that I'm trying to help sort through it.  Any answer apreciated.  And, yes I always mark my good/not so good answers here....  I will be sure to do so this time as well.

    Thank you for your time.

    HoibO


    HoibO

    Wednesday, May 29, 2013 1:23 PM
  • I am retiscent to show the url in the open since this is a backdoor of sorts.  It goes like this: https://xxxxxxxxxxxxx.com:20000   This is the only non-certificate website I use thus it is the only time I have this issue.

    Why not just switch to  HTTP  instead of   HTTPS?   The host server could still obfuscate the otherwise clear text by using compression or some other transport encoding.

     
    HTH

     
    Robert Aldwinckle
    ---

    Wednesday, May 29, 2013 4:20 PM
    Answerer
  • Hi Robert -

    All I can say is, "I don't own the server.  I have no rights to modify its behavior".  Whatever the owner sets up is what we have to live with.  I will ask about it but I seriously doubt the owner is going to buy it.  I'm sure it has to be a client side fix.

    Hope Traci can come back here and respond.

    H


    HoibO

    Friday, May 31, 2013 11:25 AM
  • Tracey - if you're monitoring replies to your posts, please come in and tell us (me) if your contact(s) have any suggestions.  I can't PM you (probably a good thing!)

    HoibO


    HoibO

    Monday, June 3, 2013 10:28 PM