locked
Extra Excel Icon in Alt+Tab Window RRS feed

  • Question

  • If I have more than one Excel file open, there is an extra icon in the Alt+Tab window. So for example, if I have File1.xlsx and File2.xlsx open, there will three icons in the Alt+Tab window: one icon for one file and two icons for the other. Is there way to fix this so only two icons appear? The extra icon causes confusion and slows down my work process.

    Please note that I am aware of the option to not "Show all windows in the taskbar" and then use Ctrl+Tab to cycle through open Excel files. This does not work for me. I would just like one icon for each open Excel file in the Alt+Tab window. 

    I'm using Windows 7 and Excel 2010.  Thanks.

    Wednesday, February 18, 2015 6:53 PM

Answers

  • You can achieve this by opening the Excel files in separate windows. For example, open the second file by using

    - Start -> All Programs -> Microsoft Office -> Excel
    - File -> Open -> myfile2.xlsx

    Alt-Tab should now show just two icons.

    For other ways of opening separate instances of Excel try Googling "open excel files in separate windows"

    Ah I see, I was double clicking saved files, thus opening them in separate windows. Explains everything!
    • Proposed as answer by Michael_LS Friday, February 20, 2015 6:30 AM
    • Marked as answer by Cloud_TS Tuesday, March 3, 2015 9:27 AM
    Thursday, February 19, 2015 9:17 PM

All replies

  • I just ran a test with the situation you described and i only see two icon in the alt -tab menu. One for each file. Are you positive that two icons open the same file? Not just two of the same files opened?
    Wednesday, February 18, 2015 6:56 PM
  • Yes, I'm positive; I've been dealing with this issue for a long, long time but finally decided to look for a way to fix it.  I'm unable to attach a pic because my account here is not yet verified, but I've uploaded one here: http://s11.postimg.org/43ya23t0z/Alt_Tab.jpg  It's a pic of my desktop that shows two different excel files open at the bottom, but three icons in the Alt+Tab window.  Thanks for your help!

    Thursday, February 19, 2015 5:45 PM
  • From my research this looks to be a very common issue that has yet to be resolved. When I open two excel files and try to alt tab it only shows two files in that menu. I noticed by your screen shot that you have disabled the preview windows for your alt tab menu, so I did the same to see if that made a difference and it didn't. The only difference between you and I is that I'm running office 2007 and you're on 2010 - My assumption by reading other peoples complaints is its a feature in 2010 that doesn't currently have a fix.
    Thursday, February 19, 2015 6:35 PM
  • You can achieve this by opening the Excel files in separate windows. For example, open the second file by using

    - Start -> All Programs -> Microsoft Office -> Excel
    - File -> Open -> myfile2.xlsx

    Alt-Tab should now show just two icons.

    For other ways of opening separate instances of Excel try Googling "open excel files in separate windows"
    • Proposed as answer by Michael_LS Friday, February 20, 2015 6:30 AM
    Thursday, February 19, 2015 7:50 PM
  • Who is blanket upvoting replies in threads?

    Update: Ah, it is Computate. Activity seems to be centered solely on voting as helpful. At best it looks like someone has a naive admirer. At worst...

    Update 2: After last update, I have been upvoted 18 times. Reported here: https://social.msdn.microsoft.com/Forums/en-US/9cd76a42-1010-465f-883c-19d8f3841ce9/serial-upvoter?forum=reportabug
    • Edited by mystifeid Thursday, February 19, 2015 9:47 PM
    Thursday, February 19, 2015 8:39 PM
  • You can achieve this by opening the Excel files in separate windows. For example, open the second file by using

    - Start -> All Programs -> Microsoft Office -> Excel
    - File -> Open -> myfile2.xlsx

    Alt-Tab should now show just two icons.

    For other ways of opening separate instances of Excel try Googling "open excel files in separate windows"

    Ah I see, I was double clicking saved files, thus opening them in separate windows. Explains everything!
    • Proposed as answer by Michael_LS Friday, February 20, 2015 6:30 AM
    • Marked as answer by Cloud_TS Tuesday, March 3, 2015 9:27 AM
    Thursday, February 19, 2015 9:17 PM
  • This works, of course, but is much too cumbersome for me since I'm constantly opening excel files all day long directly from Windows Explorer via a double-click (I'm a CPA). I also get a warning message regarding my PERSONAL.XLSB file (where macros are saved) being "locked for editing" when using this method. 

    I've searched for ways to open a separate instance of Excel by default but only came across someone's reg edit that I don't want to experiment with (http://community.spiceworks.com/topic/473287-how-to-open-multiple-windows-of-excel-just-by-double-clicking-the-files).  Plus, I suspect I'll run into the same .xlsb warning message each time anyway. 

    It appears that I'm out of luck on this one and will just have to continue dealing with the extra icon. But thanks for your help.

    Thursday, February 19, 2015 11:56 PM